Page 1 of 6 123456 LastLast
Results 1 to 10 of 56

Thread: WOOHOO! UPDATE- It's working! -- HELP! Ugly picture - sharp LQ9D161 and Allens Cont

  1. #1
    Variable Bitrate
    Join Date
    Dec 2001
    Location
    usa
    Posts
    231

    Post WOOHOO! UPDATE- It's working! -- HELP! Ugly picture - sharp LQ9D161 and Allens Cont

    Hey Everyone,
    It's working!!!

    Thanks to Toto, Infrared, and littlej for suggesting to wire the LCD and controller differently. Pinouts for colors are

    ro to r2
    r1 to r3
    r2 to r4
    r3 to r5

    and so on for the other colors.

    Now, here's the downside. Just like several of you have said, 12bit is not good enough for DVD. Film Movies look pretty bad, cartoons look OK but not great.

    But who the hell cares you're watching a 8.4" screen in a car. It's sure better than nothing! Plus it's TFT VGA and not composite so for the PC screen it looks really sharp. I'm hoping it's good enough for GPS and it certainly is going to be great for Winamp!!!

    Thanks to everyone for their help.

    Now time to get the touch screen going. Anyone know how to connect the touch screen controller to the serial port? DennisK didn't provide a pinout and the link he shows for pinouts is not for the same touch screen controller.

    Finally, I'll be ordering hirose cables and will be placing a bulk order. I need 3 or 4. If anyone needs one let me know. I can get the 1 to 1s and for the LQ9D161 to Allen controller too.

    Price will probably be around $31 plus shipping.

    Let me know if you're interested and I'll order extras.

    Pigseye

    >>>>>>>>>>>>Or iginal Post<<<<<<<<<<<&l t;<<<<<
    I bought the LQ9D161 LCD from that guy on Ebay but can't get it to work right with Allen's controller.

    Has anyone been able to get this combo to work and look good?

    I built a custom hirose 31 pin cable using the pin out of Allens controller and the pin out of the LCD but the picture looks terrible. Specifically anything that is white or bright comes out orange and yellow. There seems to be to much contrast or brightness but contrast adjustments don't help and the brightness adjustments don't do anything. I can tell the picture can be better because when a scene fades dark the picture looks much better (not to much contrast) just before it fades to black.

    Blacks, greens, and flesh tones look pretty good.

    I'm not expecting DVD movies to look perfect but certainly better than this.

    Did I screw something up?
    Am I missing a color on the controller or VGA cable?
    Has anyone seen this before?

    Any feedback is greatly appreciated.

    thanks,
    Pigseye

    [ 02-10-2002: Message edited by: pigseye ]

    [ 02-17-2002: Message edited by: pigseye ]

  2. #2
    Variable Bitrate
    Join Date
    Dec 2001
    Location
    usa
    Posts
    231

    Post

    By the way here's the pinout I used.

    gnd = ground
    nc= no connection
    tst= test (I'm guessing)
    CK=Clock
    enab=?

    I did not connect any test points and tied all the grounds together.


    Allen's
    Controller/ LQ9D161
    1 gnd/ 2 gnd
    2 ck/ 10 ck
    3 hsync/ 6 hsync
    4 vsync/ 4 vsync
    5 gnd/ 8 gnd
    6 r0/ 1 r0
    7 r1/ 3 r1
    8 r2/ 5 r2
    9 r3/ 7 r3
    10 r4/ nc
    11 r5/ nc
    12 gnd/ 9 gnd
    13 g0/ 11 g0
    14 g1/ 13 g1
    15 g2/ 17 g2
    16 g3/ 19 g3
    17 g4/ nc
    18 g5/ nc
    19 gnd/ 12 gnd
    20 b0/ 23 b0
    21 b1/ 25 b1
    22 b2/ 29 b2
    23 b3/ 31 b3
    24 b4/ nc
    25 b5/ nc
    26 gnd/ 15 gnd
    27 enab/ 28 enab
    28 Vcc 5V/ 22 Vcc 5
    29 Vcc 5V/ 24 Vcc 5
    30 tst/ nc
    31 tst/ nc


    /14 tst nc
    /16 tst nc
    /18 tst nc /20 gnd
    /21 gnd
    /26 tst nc
    /27 gnd
    /30 gnd

    Thanks
    Pigseye

    [ 02-10-2002: Message edited by: pigseye ]

    [ 02-10-2002: Message edited by: pigseye ]

  3. #3
    Live and Kickin'
    Arby's Avatar
    Join Date
    Dec 2000
    Location
    Houston
    Posts
    1,377

    Post

    maybe your video card outputs voltages higher than the lcd wants... and it's screwing up the brights?

    If your video card has gamma adjustments in the display properties, mess with that.

  4. #4
    Variable Bitrate
    Join Date
    May 2001
    Location
    Atlanta
    Posts
    305

    Post

    hmm could this be because your LCD is 12bit and allens controller has up to 18 bit?

  5. #5
    Variable Bitrate
    Join Date
    Dec 2001
    Location
    usa
    Posts
    231

    Post

    Hi Arby,
    I tried that already and it didn't help. I still don't udnerstand why the brightness control doesn't do anything.

    maybe I got a bad controller.

    Thanks for your suggestion,
    Pigseye

  6. #6
    Variable Bitrate
    Join Date
    Dec 2001
    Location
    usa
    Posts
    231

    Post

    Hi Infrared,
    Well Allens web site says the controller will drive the LQ9D161, it just won't have as many colors.

    So with this setup I did not hook up r4, r5, g4,g5, b4 and b5.

    Allen also said that it should work fine with his controller, just need to build the custom Hirose cable and no connect the unused colors.

    Thanks,
    Pigseye

    [ 02-10-2002: Message edited by: pigseye ]

  7. #7
    Newbie
    Join Date
    Aug 2000
    Location
    SF, CA
    Posts
    33

    Post

    pigseye. I have the same controller from allen. and the same LCD from ebay. : ) our connections are the same.. guess what !!?? .. SAME thing!! ugly picture! Maybe Arby is right about the outputs voltages thing. Allens controller puts out 5v and the lq9d161 takes 3.3v vcc. Take a look at the .pdf. Think we can just drop the voltage down with a resistor. (will try that when i have the time)
    Pigseye. brightness adjustments don't do anything is becos you are not connecting the inverter to the 5 pin connecter on the controller ? .. (same here , dont' know pin out for the 5 pin inverter con. inverter is just puting out Max output)
    (Things i find out)
    A way for you the see a "better" picture is holding up/down then adjust contrast.
    H pos and H clk toghter will do a reset of adjustments.

    How about connecting it like this ??

    TAllen's
    Controller/ LQ9D161

    r0/ nc
    r1/ nc
    r2/ r0
    r3/ r1
    r4/ r2
    r5/ r3

    What do you think ? . report back please ..
    sorry .. me got bad english

    [ 02-10-2002: Message edited by: toto3 ]
    neo4 and "M" installation E-mail for info

  8. #8
    Maximum Bitrate Meatballman's Avatar
    Join Date
    Jul 1999
    Location
    Hartsville, SC
    Posts
    747

    Post

    I'm not using Allens controller, but with 3.3V, the colors all look fine. There's just not enough of them. My controller uses the CHIPS 65550 chipset.

  9. #9
    Low Bitrate
    Join Date
    Mar 2001
    Posts
    66

    Post

    As far as the pinout i think you want to connect the least significant bits of the colors (ie. r0,r1,r2,r3) but you also might want to make sure that you aren't overdriving the amount of colors. Try setting your video driver to 256 colors first
    and see if that looks ok. if it does then you just have to figure out how to up it to 4096. if it doesn't look ok then i bet its your voltage problem.

  10. #10
    FLAC mp3z24's Avatar
    Join Date
    Apr 2001
    Location
    Chicago Suburbs
    Posts
    1,282

    Post

    hey, kinda off topic, but what backlight invertor was included with the screen. in the specs, it lists 2 different cuurent ratings for the invertors and 2 different corresponding brightness values. i believe the 2 currents listed were 2A and 5A output for the invertors. do you know which one comes with the screen. im waiting to get my kit in the mail, and i was curious.
    thanks

    ~mike
    Single Member of the "1000 Post and No MP3 Car" Club
    PROJECT ON INDEFINATE HOLD... BOUGHT A HOUSE
    2000 Cavalier Z24 [###-------] Only 30% Done ... Still

Page 1 of 6 123456 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •