Results 1 to 8 of 8

Thread: HD44780 LCD Display Trouble (please help)

  1. #1
    Newbie
    Join Date
    Oct 2005
    Posts
    10

    HD44780 LCD Display Trouble (please help)

    I recently recived a hd44780 4x20 and wired it up to what i thought was the correct pins on the parallel port.
    Result: The two test lines

    So then i consulted the diagram to find that i read it wrong. i corrected the wiring.
    Result: The LCD displays 3/4 full with white squares 1/4 is just blank. After a min that faded away. Then Nothing

    I removed all the wires to the parallel port leaving just pins 1,2,3,5 and 15,16 hooked up to the apropriate power,.... Ground and +5v.
    No test lines display.

    Have I ruined my lcd?

    i will be forever thankfull to whoever can help me

    I already extensivly searched google and fopund nothing.

    -Dylan

  2. #2
    Newbie
    Join Date
    Oct 2005
    Posts
    10
    I also used the program "portmon" to monitor the LTP port.... and it doesnt read anything when i run LCD smartie, but when i run lcd smartie for serial portmon goes crazy ... could it be the software?

    Also arent the 2 test lines... 1 and 3 .... supose to always come on when u give the unit power?

  3. #3
    Calm
    Down
    Or
    Get
    A
    2
    Week
    Vacation
    -Love
    The
    Forum
    Policeman
    Wiredwrx's Avatar
    Join Date
    Jan 2003
    Posts
    3,605
    Quote Originally Posted by totalconfusion5
    I also used the program "portmon" to monitor the LTP port.... and it doesnt read anything when i run LCD smartie, but when i run lcd smartie for serial portmon goes crazy ... could it be the software?

    Also arent the 2 test lines... 1 and 3 .... supose to always come on when u give the unit power?

    That is the problem with LCDs, they have a million wires, and have limited usefullness.

    First, confirm that you have everything correctly wired.

    Did you short anything. Perhaps you reveresed power and ground, which would bork the unit, or make it work in wierd ways, depending on what got fried.

    Nest, it could be the sw, or your LPT port. Is it enabled in your BIOS. Does a printer work. Is your printer port setting correct, like EPP, ECP, ECP/EPP. I do not recall which setting is correct.

    Did you somehow feed power into the LPT port accidentaly. Of course, that could cause some problems also.

    THat should get you started.

    Michael
    ...I love the French language...especially to curse with...Nom de Dieu de putain de bordel de merde de saloperies de connards d'enculés de ta mère. You see, it's like wiping your *** with silk, I love it.

  4. #4
    FreeDrive Creator CdRsKuLL's Avatar
    Join Date
    Feb 2004
    Location
    Manchester
    Posts
    3,513
    when using lcd smartie I had to install a nport something file, which you can grab in there faq section if I remember rightly, on my 2x16 on power up even when its not connected to the lpt port the screen lights up with 2 solid bands across

    CdR

  5. #5
    Newbie
    Join Date
    Oct 2005
    Posts
    10
    I hate to admit it but i think its fried .....ugh well now i have a cool 20$ blue light right? lol

    i still think its wierd that portmon doesnt show any LPT activity ...i had it set to EPP wich i belive is recomended and nothing


    ..... new lcd time.... i hate waiting for things in the mail

    Thanks anyway

  6. #6
    Constant Bitrate AngryMan's Avatar
    Join Date
    Aug 2005
    Location
    Lewiston, Maine
    Posts
    114

    Unhappy hd44780 character lcd problems

    Quote Originally Posted by totalconfusion5
    I hate to admit it but i think its fried .....ugh well now i have a cool 20$ blue light right? lol

    i still think its wierd that portmon doesnt show any LPT activity ...i had it set to EPP wich i belive is recomended and nothing


    ..... new lcd time.... i hate waiting for things in the mail

    Thanks anyway
    IM having trouble with my lcd too.
    what programs did you test it with besides lcd smartie?

    I can get it to work "okay" with lcdcenter, but everything else I try to use it with doesnt work right.. if I use it with smartie I get all kinds of artifacts, and the occasional unhandled exception. and god forbit I should accidentally click the "backlight off" button..
    anyway, im using a:
    16x2 lcd with
    hitachi hd44780 "proccessor" connected via
    parallel cable. LPT1, port 378 - ECP
    and windows xp sp2...
    .______
    / '__|__\____ VW CarPC project
    \(o)_____(o)/ Full Spead Ahead!
    Props to my Sponsor, Summit Adventure Systems Mobile Climbing Walls
    www.summitadventuresystems.com

  7. #7

  8. #8
    Constant Bitrate AngryMan's Avatar
    Join Date
    Aug 2005
    Location
    Lewiston, Maine
    Posts
    114

    lcd issues`

    Quote Originally Posted by djchicago
    this doesnt help us much with the hd44780 lcd. and since programs like centrafuse dont use WinAmp to play, this is effectively useless.

    come on people, we need help with the Hitachi HD44780 PARALLEL interfaced LCD panel.

    someone must have some input here..
    .______
    / '__|__\____ VW CarPC project
    \(o)_____(o)/ Full Spead Ahead!
    Props to my Sponsor, Summit Adventure Systems Mobile Climbing Walls
    www.summitadventuresystems.com

Similar Threads

  1. USB -> Parallel -> HD44780 LCD
    By Zip-Lock in forum General Hardware Discussion
    Replies: 5
    Last Post: 03-09-2005, 06:31 AM
  2. Replies: 2
    Last Post: 04-13-2004, 07:52 AM
  3. Can't get LCD to Display Right NEED HELP ! !
    By Squeeky in forum General Hardware Discussion
    Replies: 1
    Last Post: 01-23-2001, 07:02 PM
  4. Looking for Display 4x40 or LCD?
    By Squeeky in forum General Hardware Discussion
    Replies: 1
    Last Post: 01-17-2001, 01:25 PM
  5. Looking for Display 4x40 or LCD?
    By Squeeky in forum General MP3Car Discussion
    Replies: 4
    Last Post: 01-16-2001, 03:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •