Results 1 to 6 of 6

Thread: 8" Lilliput touchscreen NOT WORKING but powers up! HELP!!!!

  1. #1
    Low Bitrate Tibby93's Avatar
    Join Date
    Apr 2006
    Location
    Ottawa, Ontario
    Posts
    79

    8" Lilliput touchscreen NOT WORKING but powers up! HELP!!!!

    Alright so I got the 8" Lilliput Touchscreen come in today, and it worked for about half an hour, then I left the room for about an hour and came back, only to have the screen be blank. I know the touchscreen aspect still worked, and the unit powers on with the lights and stuff, but the screen itself is BLANK. Not only can I not see what should be on the screen but I CAN'T EVEN SEE THE "NO INPUT" OR "VIDEO 1" AND STUFF THAT'S IN THAT FUNKY LIME GREEN COLOR! Grrr. So frustrating. HELP ME!

  2. #2
    Low Bitrate Tibby93's Avatar
    Join Date
    Apr 2006
    Location
    Ottawa, Ontario
    Posts
    79
    UPDATE: After more fiddling around with it, somehow it started working but the quality of the text on the screen was very poor. By that, I mean the INPUT 1, lime green text was poor quality, and when I hit Menu, the menu screen's icons weren't even icons, but more lines... Then I started playing XBOX on the screen and the quality was there for the physical screen, and then about 2 minutes later, cut out again and still doesn't work.

    Any suggestions?

  3. #3
    Banned xdjxklusivex's Avatar
    Join Date
    Dec 2004
    Location
    Diamond Bar, CA (909,951)
    Posts
    2,742
    loose ribbon cable

  4. #4
    Low Bitrate Tibby93's Avatar
    Join Date
    Apr 2006
    Location
    Ottawa, Ontario
    Posts
    79
    Quote Originally Posted by xdjxklusivex
    loose ribbon cable
    Ribbon cable?

    There is a cable that goes into the screen, it's in all the way, as far as it will go, clicked in, and that wire has the RCA out's, a power input, the VGA wire input and some other input, i think it's S video.

  5. #5
    Low Bitrate Tibby93's Avatar
    Join Date
    Apr 2006
    Location
    Ottawa, Ontario
    Posts
    79
    Quote Originally Posted by xdjxklusivex
    loose ribbon cable
    And whether that cable was loose or not, I should still be able to see the green writing that says NO SIGNAL or whatever.

  6. #6
    Low Bitrate Tibby93's Avatar
    Join Date
    Apr 2006
    Location
    Ottawa, Ontario
    Posts
    79
    Why didn't anyone respond? Cmon, someone must know... How about "How do you get an exchange for free?"

Similar Threads

  1. Lilliput 8" Touchscreen broken
    By waltwalt in forum LCD/Display
    Replies: 3
    Last Post: 04-27-2006, 12:37 PM
  2. Lilliput screen works but touchscreen doesn't
    By JohnChimpo in forum General Hardware Discussion
    Replies: 6
    Last Post: 02-16-2005, 12:00 AM
  3. Replies: 1
    Last Post: 01-31-2005, 12:35 PM
  4. FS: 7" Lilliput Touchscreen VGA Monitor : Broken
    By jaeger in forum Classified Archive
    Replies: 12
    Last Post: 08-21-2004, 08:46 AM
  5. Lilliput touchscreen problems -- Need Help
    By BrUTaL in forum LCD/Display
    Replies: 1
    Last Post: 08-20-2004, 09:41 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •