Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Lilliput died; white screen?

  1. #11
    Newbie bdqpdx2000's Avatar
    Join Date
    Sep 2004
    Location
    Cranbury NJ
    Posts
    38

    sigh

    alright well im gettin a new lilliput from mp3car... maybe i can get another year out of this one

  2. #12
    Constant Bitrate
    Join Date
    Nov 2004
    Location
    NY tri-state
    Posts
    189
    Must be dead lilliput time around here...

    One of my screens just went dead, I opened up the dash and found one of the wires on the ribbon cable was busted -- not even sure how that happened. Probably gremlins chewing on the thing...

    Replaced the cable, still bad. Time for a new screen, I guess.

  3. #13
    Low Bitrate
    Join Date
    Dec 2004
    Location
    CT
    Posts
    82

    Lilliput Flickerd Then Died

    I'm having the same problem, one day driving back from a long trip the screen stared to flicker for about 20 seconds then just died. no vga,vid1,vid2 but the touchscreen still works and the button pad. does any one know whats wrong with it? anything i can replace?

  4. #14
    Constant Bitrate
    Join Date
    Jun 2006
    Posts
    116
    When my CTF700 from cartft.com fades to white, i only have to unplugged - re plugged it and everything goes back to normal...

    I must admit that i was really scared the first time it happenned to me a month after the installation ... it only happenned once after that..
    VIA EN15000 C7 // CTF700 7" Screen // Morex 3688 Black Case
    M2-ATX // 80GB HD
    DVD-RW // PowerMate
    Belkin Bluetooth V1.2 // Hauppauge WinTV FM

    Centrafuse RC5

    JBL GTO 75.4 520W // Pionneer Kevlar 260w Speakers

  5. #15
    Newbie bdqpdx2000's Avatar
    Join Date
    Sep 2004
    Location
    Cranbury NJ
    Posts
    38
    well i got my new lilliput running streetdeck (awesome) installed yesterday.. this one is the same model number as my old one but the board design is completely different, seems a little cleaner. screen is also a lot brighter, pretty visible in daylight. maybe this one will outlast the rest....

  6. #16
    Newbie
    Join Date
    Oct 2006
    Location
    Australia
    Posts
    7

    Dead Lilliput

    Well finaly got a response from Lilliput have shiped it back to them they said they will fix it for me will just have to wait and see what happens! In the mean time I bought this one on ebay works great hasn't given any troubles yet...

    http://cgi.ebay.com.au/ws/eBayISAPI....MEWN:IT&ih=020

  7. #17
    Low Bitrate Charles1's Avatar
    Join Date
    May 2003
    Location
    cali orange in fullerton
    Posts
    90
    for the record its the controllor card and ribbon cable that goes from the lcd to the controller card. So yeah I bought longer lcd ribbon cable and a new controller card different from my original but it works now

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Replies: 37
    Last Post: 03-19-2010, 01:08 PM
  2. Lilliput with permanent white screen of death
    By Pale Rider in forum LCD/Display
    Replies: 30
    Last Post: 01-10-2009, 02:15 PM
  3. My Lilliput is black and white??
    By munkynpunky in forum LCD/Display
    Replies: 7
    Last Post: 11-20-2005, 08:25 AM
  4. BROKEN Lilliput 7" VGA SCREEN
    By thekuai in forum Classified Archive
    Replies: 17
    Last Post: 11-10-2005, 06:32 PM
  5. Replies: 4
    Last Post: 09-01-2004, 01:02 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •