Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 44

Thread: Linux Space Navigator Development Thread

  1. #21
    Raw Wave shotgunefx's Avatar
    Join Date
    Apr 2005
    Location
    Boston, MA
    Posts
    1,800
    Quote Originally Posted by kraft View Post
    Don't know what's happening with google but it's damn slow.
    Could it be possible to post the video to youtube or dailymotion ?
    Still having a problem? If so, I'll upload it to youtube when I'm at that machine.

    In other news, the newest version of xdotool fixed the input problems I was having so I don't really need xte.

    I also made an additional command "getwindowfocus", so you can track the current window, and restore when your done. Most of these tools I've found lacked that. My C is a little rusty but everything seems to work fine.

    I'm going to send it off to the other of xdotool, but in case anyone is interested, the modified source is available http://www.leeland.net/lib/leeland/x...722-lee.tar.gz

    update Author added it to the main source with some slight modifications.

  2. #22
    Maximum Bitrate
    Join Date
    Aug 2004
    Location
    at home
    Posts
    591
    Well i think i that my firefox is attempting to download the whole video instead of starting playing it, when i click on the video thumbnail, nothing happens apart the whirling dots that shows it's busy and working. I'll let it run in background.

    Playing with window's focus could be sometimes a real pain especially when a modal window appears and steal the focus. Fortunately it the Desk configuration some option exists to avoid focus theft

  3. #23
    Raw Wave shotgunefx's Avatar
    Join Date
    Apr 2005
    Location
    Boston, MA
    Posts
    1,800
    Quote Originally Posted by kraft View Post
    Well i think i that my firefox is attempting to download the whole video instead of starting playing it, when i click on the video thumbnail, nothing happens apart the whirling dots that shows it's busy and working. I'll let it run in background.

    Playing with window's focus could be sometimes a real pain especially when a modal window appears and steal the focus. Fortunately it the Desk configuration some option exists to avoid focus theft
    Weird. Here's a link on Youtube

    I'm not really familiar with X on that level yet, though I suppose by the time I'm done, I'll know a hell of a lot more about it than I care to

  4. #24
    Maximum Bitrate
    Join Date
    Aug 2004
    Location
    at home
    Posts
    591
    Thanks for the video

    I love the VFD look of your frontend, simple and elegant
    So now what is the next step ?

  5. #25
    Raw Wave shotgunefx's Avatar
    Join Date
    Apr 2005
    Location
    Boston, MA
    Posts
    1,800
    Quote Originally Posted by kraft View Post
    Thanks for the video

    I love the VFD look of your frontend, simple and elegant
    So now what is the next step ?
    Thanks.

    Well, Sirius tuner this week. Then a ground up rewrite. Also need to get the Video quad and a bunch of other stuff straightened out. The Quad's RS232 interface isn't working, and the lack of docs and answer from China are A. Slow, B. Not too helpful

  6. #26
    Maximum Bitrate
    Join Date
    Aug 2004
    Location
    at home
    Posts
    591
    Try to spy the logs and/or have a look into your kernel, maybe some support is not activated ?
    Setserial can be helpfull as well if modules are mounted right in the kernel, this tiny tool has a query mode

  7. #27
    Raw Wave shotgunefx's Avatar
    Join Date
    Apr 2005
    Location
    Boston, MA
    Posts
    1,800
    Quote Originally Posted by kraft View Post
    Try to spy the logs and/or have a look into your kernel, maybe some support is not activated ?
    Setserial can be helpfull as well if modules are mounted right in the kernel, this tiny tool has a query mode
    Not even in Linux, doesn't work in Windows with the app they provided (eventually) either. Tried every cable combo I could think of too.

  8. #28
    Maximum Bitrate
    Join Date
    Aug 2004
    Location
    at home
    Posts
    591
    mmm, so i would see an irq battle for the title

    Jump to your BIOS configuration and try to eventually deactivate the internal uart just to see if some changes occurs.
    Maybe this could help the card to say it's word

  9. #29
    Raw Wave shotgunefx's Avatar
    Join Date
    Apr 2005
    Location
    Boston, MA
    Posts
    1,800
    Quote Originally Posted by kraft View Post
    mmm, so i would see an irq battle for the title

    Jump to your BIOS configuration and try to eventually deactivate the internal uart just to see if some changes occurs.
    Maybe this could help the card to say it's word
    I really think it's the quad (or cabling). Tried it from multiple computers. Computers that I use the serials for programming PICs and controlling VCRs etc.

    I've tried real serials and usb ones too. It sees the connection with the app, meaning if I'm not connected, the quad screeches an alarm, if I connect through the software, it stops, but no commands are acknolwedged, I'm going to have to look into some windows serial sniffing tools or put a computer in between.

  10. #30
    Maximum Bitrate
    Join Date
    Aug 2004
    Location
    at home
    Posts
    591
    arf these are bad news

    If connectors are like some HE-10 connectors, unplug them and try to pressure them gently with tool, of course protect the plastic part to avoid the tool to crush them, maybe they were fast mounted with not enough pressure ?
    if soldered check them too but as you speak of PIC, you are familiar with electronics so i won't explain you what to check

    What could i say more, in then end if everything fails, maybe minicom could help enter in deep with serial ports to watch what is going on.

Page 3 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. Replies: 44
    Last Post: 02-15-2008, 12:53 AM
  2. Help in Linux
    By Jagaer in forum Linux
    Replies: 3
    Last Post: 04-21-2006, 10:50 PM
  3. Possible EPIA distro for Linux, Can we make one?
    By adamis in forum Software & Software Development
    Replies: 15
    Last Post: 02-23-2005, 05:50 PM
  4. PS2 Linux ?'s
    By jws95hardbody in forum Newbie
    Replies: 5
    Last Post: 01-11-2004, 10:18 PM
  5. Help with linux boot...
    By cyrocr in forum General MP3Car Discussion
    Replies: 1
    Last Post: 11-12-2003, 08:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •