Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 35

Thread: First Car PC, Gentoo Attempt..

  1. #21
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    don't use libnghost2.0.2. It's too old. Use the svn version posted in the beginning of this thread. The error is about missing the libboost-dev headers/libs.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  2. #22
    Newbie
    Join Date
    Mar 2008
    Posts
    12
    Thank you,
    here what I did:
    first: svn checkout -r2024 url to libnghost
    autogen.sh, configure, make, make install
    done.
    then: svn checkout -r2024 url to trunk
    then:autogen.sh, configure : at this point I get the error: Package requirements (nghostcore) was not met: No package 'nghostcore' found.
    I thought while libnghost is installed I will not get this error !!

  3. #23
    Newbie
    Join Date
    Oct 2009
    Posts
    20
    check /usr/local/libs/

    I bet you will find the libnghost libs there. If not, use locate/find and see where they were. On my system, gentoo, pkg-config-path was looking in /usr/lib for these files. I think you can specify a variable for the new location, but I just copied the contents of /usr/local/lib to /usr/lib, including subdirectories(creating accordingly).

    After that, it installed.

  4. #24
    Newbie
    Join Date
    Mar 2008
    Posts
    12
    I copied the contents of /usr/local/lib to /usr/lib . configure is done. make : list of errors like:
    /usr/lib/libxml++-2.6.so: undefined reference to `xmlValidateDtd@LIBXML2_2.4.30'
    /usr/lib/libxml++-2.6.so: undefined reference to `xmlParseDocument@LIBXML2_2.4.30'
    /usr/lib/libxml++-2.6.so: undefined reference to `xmlDocDumpFormatMemoryEnc@LIBXML2_2.4.30'
    .
    .
    .
    /usr/lib/libxml++-2.6.so: undefined reference to `xmlTextReaderSetParserProp@LIBXML2_2.5.0'
    /usr/lib/libxml++-2.6.so: undefined reference to `xmlOutputBufferCreateIO@LIBXML2_2.4.30'
    /usr/lib/libxml++-2.6.so: undefined reference to `xmlCreateIntSubset@LIBXML2_2.4.30'
    /usr/lib/libxml++-2.6.so: undefined reference to `xmlTextReaderLocalName@LIBXML2_2.4.30'
    /usr/lib/libxml++-2.6.so: undefined reference to `xmlSetProp@LIBXML2_2.4.30'
    collect2: ld returned 1 exit status
    make[3]: *** [nghost] Error 1
    make[3]: Leaving directory `/root/trunk/src'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/root/trunk/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/root/trunk'
    make: *** [all] Error 2
    libxml2-2.7.7-1 installed
    libxml++-2.30.1-1 installed

  5. #25
    Newbie
    Join Date
    Oct 2009
    Posts
    20
    Did you already try, ldconfig and revdep rebuild?

    I've never seen that error, and nothing on google quickly found anything. I'll keep looking.. maybe Kev has seen it before.

    configure finished clean though?

  6. #26
    Newbie
    Join Date
    Mar 2008
    Posts
    12
    sorry for the delay,
    yes, configure finished clean, make: still with same error.

  7. #27
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    Quote Originally Posted by jmorgan6 View Post
    Did you already try, ldconfig and revdep rebuild?

    I've never seen that error, and nothing on google quickly found anything. I'll keep looking.. maybe Kev has seen it before.

    configure finished clean though?
    when i see that, ldconfig fixes it. did you make install libnghost? also, is your LDPATH/LIBPATH looking in the place you installed it (/usr/local/lib?)?
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  8. #28
    Newbie
    Join Date
    Mar 2008
    Posts
    12
    ldconfig created /etc/id.so.cache but did't fix the error.

  9. #29
    Newbie
    Join Date
    Mar 2008
    Posts
    12
    Thanx Kev ,
    Quote Originally Posted by tripzero View Post
    when i see that, ldconfig fixes it. did you make install libnghost? also, is your LDPATH/LIBPATH looking in the place you installed it (/usr/local/lib?)?
    libnghost is installed. Usually in Archlinux libs exist in /usr/lib I just copied the contents of /usr/local/lib :
    libnghostcore.a libnghostgui2.so.0.0.0 libnghostplugins.so.1
    libnghostcore.la libnghostlog.a libnghostplugins.so.1.1.0
    libnghostcore.so libnghostlog.la libxml2.a
    libnghostcore.so.0 libnghostlog.so libxml2.la
    libnghostcore.so.0.0.0 libnghostlog.so.0 libxml2.so
    libnghostdao.a libnghostlog.so.0.0.0 libxml2.so.2
    libnghostdao.la libnghostnet.a libxml2.so.2.6.30
    libnghostdao.so libnghostnet.la libxml2.so.2.6.9
    libnghostdao.so.0 libnghostnet.so mms
    libnghostdao.so.0.0.0 libnghostnet.so.0 nghost
    libnghostgui2.a libnghostnet.so.0.0.0 pkgconfig
    libnghostgui2.la libnghostplugins.a python2.6
    libnghostgui2.so libnghostplugins.la xml2Conf.sh
    libnghostgui2.so.0 libnghostplugins.so
    to /usr/lib then configure is done. make with errors !! Do you think I need to export LIBPATH=usr/local/lib ?

  10. #30
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    can you give me more compile output? It doesn't appear to be linking correctly to libxml++ or the version you installed isn't compatible and configure thought it was.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

Page 3 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. Toyota 4-Runner Car PC (first attempt)
    By RP28FLA in forum Show off your project
    Replies: 11
    Last Post: 04-15-2004, 05:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •