Results 1 to 8 of 8

Thread: Simple networking help for Linux

  1. #1
    Admin. Linux loser.
    Auto Apps:loading...
    Bugbyte's Avatar
    Join Date
    Sep 2004
    Location
    Corning, NY
    Posts
    7,359
    Blog Entries
    2

    Simple networking help for Linux

    I just got a new embedded Linux board, the igepv2. It comes with Poky Linux and I'm trying to get it online but can't figure out what the problem is. Right now it is plugged into my router via ethernet cable but won't show up as an attached device.

    I'm able to iwconfig and iwlist and the if config reports:

    Code:
    eth0  Link encap:Ethernet  HWaddr 76:09:B3:FF:F5:05
            inet addr: 192.168.1.100  Bcast:192.168.1.255 Mask:255.255.255.0
            inet6 addr: fe80::7409:b3ff:feff:f505/64 Scope:Link
            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
            RX packets:0 errors:0 dropped:0 overruns:0 frame:0
            TX packets: 176 errors:0 dropped:0 overruns:0 carrier:0
            collisions:0 txqueuelan:1000
            RX bytes:0 (0.0 B)   TX bytes:17831  (17.4KiB)
            Interrupt: 80
    I was able to set the IP address to the 192.168.1.100 and it took it just fine. I can actually ping 192.168.1.255 and get a response. But when I try to ping one of my home pc's FROM the igep terminal, I get nothing. It sends the ping and then waits.

    The web browser built into Poky won't connect to anything either.

    If I enter:

    ifup eth0 <--the ethernet device, then I get:

    udhcpc (v1.9.1) started
    Sending discover...
    Sending discover...
    Sending discover...
    No lease, failing

    Any help is appreciated!
    Quote Originally Posted by ghettocruzer View Post
    I was gung ho on building a PC [until] just recently. However, between my new phone having internet and GPS and all...and this kit...Im starting to have trouble justfiying it haha.
    Want to:
    -Find out about the new iBug iPad install?
    -Find out about carPC's in just 5 minutes? View the Car PC 101 video

  2. #2
    Admin. Linux loser.
    Auto Apps:loading...
    Bugbyte's Avatar
    Join Date
    Sep 2004
    Location
    Corning, NY
    Posts
    7,359
    Blog Entries
    2
    Edit - I've been trying to add my default gateway as I think that might be the problem but I haven't been able to. Here is my netstat -nr output:

    Code:
    Kernel IP routing table
    Destination      Gateway           Genmask         Flags    MSS Window  irtt Iface
    192.168.254.0  0.0.0.0             255.255.255.0   U             0  0             0 eth0
    0.0.0.0        192.168.254.19      0.0.0.0            UG           0  0             0 eth0
    
    route add default fw 192.168.1.1 eth0
    route SIOCADDRT: Network is unreachable
    Quote Originally Posted by ghettocruzer View Post
    I was gung ho on building a PC [until] just recently. However, between my new phone having internet and GPS and all...and this kit...Im starting to have trouble justfiying it haha.
    Want to:
    -Find out about the new iBug iPad install?
    -Find out about carPC's in just 5 minutes? View the Car PC 101 video

  3. #3
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    I wouldn't mess too much with the stock poky.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  4. #4
    Maximum Bitrate nasa's Avatar
    Join Date
    Aug 2006
    Location
    PA
    Posts
    696
    Bugbyte,

    Why did you *set* the ip address? Doesn't poky support dhcp? I would reboot the machine and then try 'dhclient' from a command line and see what happens...

    edit:

    NM -- just noted it uses udhcpc.... did you set an ip address prior to the 'ifup' command? And is your subnet '1' or '0' ?

  5. #5
    Maximum Bitrate
    Join Date
    Aug 2004
    Location
    at home
    Posts
    591
    Didin't messed with poky but

    - Check if any firewall service is started like iptables or shorewall
    - Check the content of the files /etc/hosts.allow and btw the content of hosts.deny if they are present in the directory /etc/

    you could take a look in some log files like tail -f /var/log/messages or eventually dmesg.

  6. #6
    Newbie
    Join Date
    Aug 2010
    Posts
    36
    Quote Originally Posted by Bugbyte View Post
    Edit - I've been trying to add my default gateway as I think that might be the problem but I haven't been able to. Here is my netstat -nr output:

    Code:
    Kernel IP routing table
    Destination      Gateway           Genmask         Flags    MSS Window  irtt Iface
    192.168.254.0  0.0.0.0             255.255.255.0   U             0  0             0 eth0
    0.0.0.0        192.168.254.19      0.0.0.0            UG           0  0             0 eth0
    
    route add default fw 192.168.1.1 eth0
    route SIOCADDRT: Network is unreachable
    Edit your /etc/sysconfig/network file with the default gateway

  7. #7
    Admin. Linux loser.
    Auto Apps:loading...
    Bugbyte's Avatar
    Join Date
    Sep 2004
    Location
    Corning, NY
    Posts
    7,359
    Blog Entries
    2
    Thanks for the tips. No joy on any of them.

    I think it is a gateway problem, too but there is no /etc/sysconfig directory. I tried to set the default gateway using a command I can't recall, but it did not help.
    Quote Originally Posted by ghettocruzer View Post
    I was gung ho on building a PC [until] just recently. However, between my new phone having internet and GPS and all...and this kit...Im starting to have trouble justfiying it haha.
    Want to:
    -Find out about the new iBug iPad install?
    -Find out about carPC's in just 5 minutes? View the Car PC 101 video

  8. #8
    Newbie
    Join Date
    Jul 2007
    Posts
    12
    Quote Originally Posted by Bugbyte View Post
    Edit - I've been trying to add my default gateway as I think that might be the problem but I haven't been able to. Here is my netstat -nr output:

    Code:
    Kernel IP routing table
    Destination      Gateway           Genmask         Flags    MSS Window  irtt Iface
    192.168.254.0  0.0.0.0             255.255.255.0   U             0  0             0 eth0
    0.0.0.0        192.168.254.19      0.0.0.0            UG           0  0             0 eth0
    
    route add default fw 192.168.1.1 eth0
    route SIOCADDRT: Network is unreachable
    The above command should probably be
    route add default gw 192.168.1.1 eth0

    not: route add default fw 192.168.1.1 eth0 (gw for gateway instead of fw)

Similar Threads

  1. simple bluetooth dialer
    By liquid_smoke in forum Road Runner
    Replies: 24
    Last Post: 08-13-2010, 10:44 PM
  2. Simple Checklist
    By Chuck in forum Road Runner
    Replies: 3
    Last Post: 01-31-2006, 02:38 AM
  3. A simple front end!???
    By wilsonj in forum Software & Software Development
    Replies: 23
    Last Post: 01-07-2006, 05:08 PM
  4. Simple Sound Card
    By millerbc in forum Car Audio
    Replies: 3
    Last Post: 03-04-2005, 10:08 AM
  5. I want more cool stuff in my car. (wireless networking)
    By LoreleiGuy in forum General Hardware Discussion
    Replies: 10
    Last Post: 02-27-2000, 02:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •