Results 1 to 4 of 4

Thread: Liliput 669GL Debian Wheezy Kernel 2.6.39, X 1.10.2.902

  1. #1
    Newbie
    Join Date
    Jul 2011
    Posts
    1

    Liliput 669GL Debian Wheezy Kernel 2.6.39, X 1.10.2.902

    I've got a Liliput 669GL and I can't get the touchscreen to work. It registers touches ut needs calibration. tslib reports "selected device is not a touchscreen I understand." I've searched countless forums, Google, etc. but unfortunately all of the driver information posted is quite old. Nothing covers X 1.10.*.

    dmesg and XOrg.0.log both report finding an eGalax touchscreen and it's assigned to /dev/input/event0. ts_calibrate reports "selected device is not a touchscreen I understand" and promptly crashes.

    Has anyone get a Liliput working with the latest kernel and X?

    Thanks!

  2. #2
    Variable Bitrate
    Join Date
    Jun 2008
    Location
    Seattle, WA
    Posts
    366
    Yes I do. I don't use any third party drivers or software. I manually set the calibration values in my xorg.conf through trial and error. Add this to your xorg.conf:

    Code:
    Section "InputClass"
            Identifier "touchscreen"
            MatchIsTablet "on"
            MatchVendor "eGalax"
            MatchDevicePath "/dev/input/event*"
            Option "SwapAxes" "1"
            Option "Calibration" "50 2000 100 1910"
            Option "InvertY" "1"
            Driver "evdev"
    EndSection
    Notes:
    1. I needed SwapAxes on mine, because X and Y axes were reversed.
    2. I needed InvertY because the Y axis was backwards.
    3. The calibration values I determined by trial and error. It was made more difficult by the fact that the values are applied before the SwapAxes or InvertY parameters are applied. So I would sometimes edit the wrong number, or change it in the wrong direction.

    Hope this helps!
    -- Kevin
    Last edited by kross; 08-02-2011 at 04:32 PM.

  3. #3
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,560
    have either of you used xinput_calibrator? It runs but doesn't produce anything I can use in my Xorg.conf. This goes for any egalax touchscreen that i have.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  4. #4
    Variable Bitrate
    Join Date
    Jun 2008
    Location
    Seattle, WA
    Posts
    366
    It's been awhile since I setup my touchscreen with Linux, but I remember trying something like that, and it wasn't working for me, so I resorted to manual trial and error for calibration values. It didn't take that long, really, to get the values dialed in.

Similar Threads

  1. In Debian Sid!
    By chunkyks in forum OBDII GPS Logger
    Replies: 1
    Last Post: 06-06-2011, 04:37 PM
  2. Replies: 6
    Last Post: 03-08-2011, 10:03 PM
  3. liliput 669gl vs ebyv701
    By b3ltazar in forum LCD/Display
    Replies: 2
    Last Post: 05-17-2010, 09:10 PM
  4. Debian and egalax drivers, please help.
    By shotgunefx in forum Linux
    Replies: 3
    Last Post: 04-06-2006, 04:57 AM
  5. Debian Linux Questions
    By Scorpion1985 in forum Software & Software Development
    Replies: 6
    Last Post: 09-04-2004, 11:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •