Page 8 of 10 FirstFirst 12345678910 LastLast
Results 71 to 80 of 99

Thread: iGuidance 2.1.3 in Wine

  1. #71
    Newbie
    Join Date
    Dec 2007
    Posts
    6
    Quote Originally Posted by concertedrxn View Post
    y2b4sure,

    What distribution of Linux are you using and what version? You would need Ubuntu 7.10 to make use of the .deb file I created. It might install on an older version of Ubuntu or another Debian derivative, but there's a good chance of a dependency problem.

    What error are you getting when you try to install the package you built?
    Got it working! For some strange reason the later versions of Wine segfault when I first launch them. After a reboot it launches fine. iGuidance runs perfectly, sound, good GUI, and the bluetooth GPS connects great.

    Thanks very much, I figured one of the comm files were bad, and was just about to settle down troubleshooting segfaults and backtraces, so you saved me a bunch of time. Nice one!! You might want to know that I've posted this information on the EEEPC forum at http://forum.eeeuser.com/viewtopic.p...131173#p131173.

    Thanks again.

  2. #72
    Newbie
    Join Date
    Feb 2008
    Posts
    4

    Unhappy

    Hi there,

    I'm glad I found this thread. Here's my deal:

    I've got an Asus Eee with eeeXubuntu (7.10), and a Holux GR-213u. The GPS unit works fine in xgps and GpsDrive.

    I've got iGuidance3 installed via CXOffice. It runs fine, but GPS info shows nothing (other than Lat/Long data, which seems relatively correct but unconfirmed). I've done the appropriate /dev/ttyUSB0 -> dosdevices/com2 linkage.

    I figure I've got the same comm issue you've been talking about with Wine. Wondering if you can hook my up with your .deb file.

    For the record, I had Wine 0.9.46. I just installed 0.9.54 (via the wineHQ apt source), still no dice.

    ----
    I just had a thought... I don't think CXOffice uses the normal Wine install. Perhaps I should try Wine instead of CXOffice. Can you hit me with your .deb anyway? thx
    ----

    Thanks,

    noot

  3. #73
    Newbie
    Join Date
    Feb 2008
    Posts
    4

    update

    Update here:

    I uninstalled iGuidance from CXoffice.

    Then I compiled Wine 0.9.55 using the 0.9.22 "comm.c" file. Unfortunately, I'm still having the same results as before in iGuidance. Also, I mentioned before that the GPS Info in iGuidance showed correct Lat/Long data... well it's not actually correct

    I'm thinkin it must be my GPS receiver.

    I did use it in Windows, and (perhaps I dreamt this) I vaguely remember something about after using the unit in Windows, it messes things up in linux. Like I said, not sure if this is remotely true... and my unit DOES work in XGPS, so I know it's working.

    Any ideas?

    thanks in advance,

    noot

  4. #74
    Newbie
    Join Date
    Dec 2007
    Posts
    6
    Quote Originally Posted by alexnoot View Post
    Update here:

    I uninstalled iGuidance from CXoffice.

    Then I compiled Wine 0.9.55 using the 0.9.22 "comm.c" file. Unfortunately, I'm still having the same results as before in iGuidance. Also, I mentioned before that the GPS Info in iGuidance showed correct Lat/Long data... well it's not actually correct

    I'm thinkin it must be my GPS receiver.

    I did use it in Windows, and (perhaps I dreamt this) I vaguely remember something about after using the unit in Windows, it messes things up in linux. Like I said, not sure if this is remotely true... and my unit DOES work in XGPS, so I know it's working.

    Any ideas?

    thanks in advance,

    noot
    Here's the URL to the wine package...

    http://rapidshare.com/files/91653115..._i386.deb.html

    Try that and let's take it from there. You might want to uninstall the current version of Wine first.

  5. #75
    Newbie
    Join Date
    Feb 2008
    Posts
    4
    No dice =(
    Still nothing in iGuidance.
    I dont' know enough about GPS units... is there some sort of standard for the serial data? I shouldn't need gpsd or anything for this to work right... just the straight serial data should do it in iGuidance?

  6. #76
    Newbie
    Join Date
    Dec 2007
    Posts
    6
    Quote Originally Posted by alexnoot View Post
    No dice =(
    Still nothing in iGuidance.
    I dont' know enough about GPS units... is there some sort of standard for the serial data? I shouldn't need gpsd or anything for this to work right... just the straight serial data should do it in iGuidance?
    Are you able to cat /dev/ttyUSB0 as the same user as you are using when launching wine?

    If you can cat that, are you able to cat the symlink dosdevices/com2? Why are you using com2, is that right?

    When you cat the file you should see a steady stream of data, this is called NMEA data. The website below should give you an idea of what you should be seeing...

    http://www.gpsinformation.org/dale/nmea.htm

  7. #77
    Newbie
    Join Date
    Feb 2008
    Posts
    4

    Solved

    Hey guys,

    So I haven't worked on anything at all since my last post. I actually tried installing 98SE using QEMU, but my CPU doesn't support KVM so it ran like total poop.

    Anyway, I had an epiphany today. I realized that every time I had previously tried to get it all to work, I had GPSD running. Then I realized... I don't think that 2 apps can listen to serial data simultaneously. So, I tried again without running GPSD, and tada! Success!

    Thanks for all the help.

    One more question (since I'm too lazy to look myself), does iGuidance v4 work under Wine?

    Thanks

    alex

  8. #78
    Constant Bitrate
    Join Date
    Jun 2006
    Location
    Chicago, IL
    Posts
    143
    FYI, I tested IG3 on cxoffice, and only version 6.0.0 handles comm ports OK, any newer does not work.

    Wine with old comm.c works flawlessly.
    EPIA TC 1G 256MB 60GB Linux,WindowMaker, Roadnav, Xine, XMMS, iGuidance3
    Lilliput 8", Pharos i360, WUSB11v2.6 WiFi

  9. #79
    Raw Wave shotgunefx's Avatar
    Join Date
    Apr 2005
    Location
    Boston, MA
    Posts
    1,800
    I've been gone for ages (did anyone miss me?). Anyway, I got IG4 (mostly so far) working on linux (Ubuntu Hardy, thankfully I dont' have to write off that $100 I spent on it).

    I was re-doing my car-pc in a clean install and I decided to give it another go.

    I did some googlilng and found a.. um "patched" installer in a certain swedish bay
    This only "fixes" the install issue, you still need to buy it!

    Anyway, I tried installing it and no go, still had the same issues.

    Then I thought maybe it was a SAPI5 thing, as it was again, complaining it could not find the speech files or maps & data.

    Googling around, I found the easiest way to get TTS working was installing Speakonia (a free program) through wine. I don't know if this is needed (but I did this first, so...)
    http://www.cfs-technologies.com/home/?id=1.4

    So I install that and TTS is working. Ok, so I fire up IG4 and... a big fail.

    Then I thought about my old install, I *thought* I had made it somewhere with the RealSoft TTS that IG4 uses. I look for my old wine registry (system.reg) and hit the following...

    Code:
    [Software\\ScanSoft\\Environment] 1188581990
    "SSFTSOLOSDK"="C:\\iNav iGuidance\\ScanSoft\\RealSpeakSolov4"
    
    [Software\\ScanSoft\\TTS\\RealSpeakSolov4] 1188581990
    @="C:\\iNav iGuidance\\ScanSoft\\RealSpeakSolov4"
    
    [Software\\ScanSoft\\TTS\\SAPI5\\Install] 1188581990
    "RealSpeakSolov4"="C:\\iNav iGuidance\\ScanSoft\\RealSpeakSolov4"
    I add it to my new install and BOOSH!, it fires up no problem. Well, mostly no problems, the app seems to be fine, I haven't hooked up my gps yet, but TTS is not working. The audio blips, but that's all, so there's a little more work to do.

    So, hopefully this is helpful to anyone else who was unfortunate enough to buy IG4 before it was know it is not wine friendly like IG3.

    As an aside, they REALLY should make it easy for people like us to give them our business. I mean, outside the c-note it I spent, if you add up all the hours I spent trying to get this to work with both attempts (particularly the first), you're talking a work week, just to give someone my patronage.

  10. #80
    Raw Wave shotgunefx's Avatar
    Join Date
    Apr 2005
    Location
    Boston, MA
    Posts
    1,800
    Muahahahah.

    TTS is working! I apparently didn't have a default audio device set as wineconfig so kindly let me know.

    Odd though, the other TTS program still worked which is odd. The voice is ok, not as nice as I thought it would be, but not bad.

    Now for that damn gps detection

Similar Threads

  1. Replies: 17
    Last Post: 06-15-2006, 01:46 AM
  2. Wtb Iguidance 2.1.3 Dvd
    By madehtsobi in forum Classified Archive
    Replies: 2
    Last Post: 05-26-2006, 02:56 AM
  3. iGuidance Font Size Fix summary thread
    By Viscouse in forum GPS
    Replies: 29
    Last Post: 03-28-2006, 07:21 PM
  4. iGuidance 2.1.3 Nag Screen
    By Volsfan in forum Road Runner
    Replies: 6
    Last Post: 03-28-2006, 09:32 AM
  5. iGuidance 2.1.3 - Warning Screen Issue
    By Purplxd in forum Road Runner
    Replies: 13
    Last Post: 11-14-2005, 06:19 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •