Page 1 of 10 12345678910 LastLast
Results 1 to 10 of 99

Thread: iGuidance 2.1.3 in Wine

  1. #1
    Low Bitrate
    Join Date
    Sep 2004
    Posts
    69

    iGuidance 2.1.3 in Wine

    I wanted to thank everyone else out there who helped me make my first CarPC what it was. I say "was" because the laptop harddrive with RR on XP recently gave up the ghost.

    That got me thinking about my original plan of making my CarPC Linux-based WITH door-to-door gps navigation software and a highly customized native front-end.

    The only thing that really stands in the way of realizing this goal is getting my favorite gps navigation software, iGuidance 2.1, working with Wine. That is, until now.

    Ubuntu Dapper Drake 6.06 on a Celeron 733 with 256MB of RAM. I installed Wine 0.9.9 (the latest with Dapper at the moment) from the default sources list. I mapped a SMB share to my windows box where I had my iGuidance DVD drive mounted. A simple "wine setup.exe" led me through the initial install with no issues. It autostarts the maploader installer, but it gave me errors about finding the map data, etc.

    So, I installed iGuidance on the same Windows box. I ran the maploader, selected the states I wanted, and allowed it to install them on the C: drive. I then simply copied the map data (C:\iNav IGuidance\Maps) into my wine's drive_c folder (/home/geese/.wine/drive_c/iNav\ iGuidance/Maps).

    Now, I tried "wine /home/geese/.wine/drive_c/program\ files/iNav/iGuidance/iGuidance.exe". However, it complained about not being able to find "names.bin" or somesuch. The trick was to cd to the directory first and then run "wine iGuidance.exe".

    So now it's running, but no GPS yet.

    To test my GPS (a Deluo based on the SirfII chipset), I used gpsd. Ubuntu sets it up as /dev/ttyS0 or /dev/ttyUSB0 depending on which connector I used. In the end, both worked well (modprobe pl2303 was needed for the USB).

    I set up the symlink in /home/geese/.wine/dosdevices such that com1 pointed to /dev/ttyS0 and fired up iGuidance again. No luck. Lots of Setupcomm errors

    So, I went to winehq's site and downloaded 0.9.17 from them after adding their site to my sources. Still, no luck. They fixed the original Setupcomm errors, but another popped up.

    I then went and bought Cedaga, installed it, and tried the whole reinstalling process over again. Still, no luck. There weren't any comm errors, but it didn't work.

    I went back to wine (0.9.17) and futzed with it some more. Then, *magically*, it worked. I kid you not, I don't know what did it or how. But, it works. Sound worked (alsa or oss), and I was able to get a lock.

    Can I repeat this? I hope so. I'm going to try my darndest to do it again and document *exactly* the steps I took. I'll be sure to post here when that happens.

    My question is, can a wine-based window be "trapped"/integrated with a linux-based front-end much like skinbedder?

  2. #2
    Newbie
    Join Date
    Apr 2006
    Posts
    6
    Good Work GEESE! I just started messing with knoppix (diff distribution) and read that there arent any availible GPS software yet. So GPS was really holding me back too. Hopefully you can replicate the work! Good luck.

  3. #3
    Low Bitrate
    Join Date
    Sep 2004
    Posts
    69
    Also, just as an FYI, I've let it run continuously for 48 hrs with no issues. It will occasionally lose lock, so I'll check on it. It still is receiving data, but just not from enough satellites. Mind you, this is in a bedroom with a north-facing window. If I give it a few minutes, another satellite comes in and it regains lock. I'm pretty impressed.

  4. #4
    Newbie
    Join Date
    Jul 2006
    Posts
    12
    There is a native navigation software.

    http://www.directions.ltd.uk/moreinfo.php?id=1080

    So far only interesting, if youlife somewhere in Europe.

    But they told me, they will have North America Maps in fall of 2006.

    Bye Stefan

  5. #5
    Low Bitrate
    Join Date
    Sep 2004
    Posts
    69
    Well, it appears that wineserver likes to consume 60K of memory every few seconds. The iGuidance process stays rock solid, though. This means that it can't be run for more than 2 hrs or so without it resorting to mad disk swapping.

    Still, I'm very close...

  6. #6
    Newbie BennY-'s Avatar
    Join Date
    Jan 2006
    Location
    Germany, Cologne
    Posts
    41
    Navigon Mobile Navigator for Laptop is working fine with wine.

    Only problem is that the programm starts 20px to low and all messageboxs are wrong placed, except this it works fine


    updates for Destinator 6:


    heavy cpu usage @ Epia M10000 with 512MB Ram


    (plz excuse my bad english)

  7. #7
    Newbie
    Join Date
    Aug 2005
    Location
    Austin TX
    Posts
    22
    Thanks to Geese's inspiration I also tried to get Iguidance running on Ubuntu Dapper Drake 6.06. Instead of the stock wine or transgaming versions I use Crossover Office from Code Weavers. I have had a subscription with them for 3 years.

    I created a new bottle (what they call a wine instance) in the CXinstaller.
    I ran ~cxoffice/bin/cxrun
    I selected the bottle I created and entered winecfg
    This popped up the wine configuration tool that let me select the XP environment template.

    I threw in the Iguidance DVD in the drive and used Crossover office’s “install unsupported application" option.

    Then I navigated to the DVD and ran setup.exe.

    The map loader worked the first time. Crossover even put all the icons on my desktop.

    I followed Geese’s instructions in how to add gpsd and the com port to dosdevices located in ~.cxoffice/bottlename/dosdevices
    I have a Garmin handheld that can simulate a full lock which (very much needed since this machine is in the basement and not near a window).
    I connected the handheld to the serial port and tested the connection.
    I made sure that I was getting data by using the xgps client.

    After I was sure that the GPS port was spitting out the right data I started IG3 UMPC and got the nag screen. Success.
    Since the gps is only sending the test data there was no movement to see and I could not test a trip but that is next.

    Thanks for all the info Geese!
    Attached Images Attached Images  
    2006 Subaru STI
    Voom2PC with CN700 Lilliput 7" Digimoto mOByDic
    Sirius-SR1 BU-355 - EWF/Roadrunner/LSX

  8. #8
    Variable Bitrate intuitionsys's Avatar
    Join Date
    Jul 2005
    Location
    Northern Virginia
    Posts
    293
    Have you noticed any appreciable redraw lag or other weirdness compared to "real" WindowsXP?
    Silverwolf 2 is dead.
    Silverwolf 3...?

  9. #9
    Newbie
    Join Date
    Aug 2005
    Location
    Austin TX
    Posts
    22
    I guess the short answer to your question is that it runs well enough for me. Read on for the long answer:
    I can only talk about moving the screen around and watching the GPS info update since my machine and gps are tethered. On Ubuntu - moving the screen around forces redraws but not too much lag maybe a second but no more. When I install it on Damn Small Linux (DSL) the XVESA environment forces some more lag into the equation but still not to the point where I think it will be a problem in the car. Unfortunately, I am getting the "too many pipes" error in DSL to try it out in the car as is. I also can't get Ubuntu to install on my Epia 800 test box to confirm what my desktop is doing. Until I get Gentoo working I am forced into DSL for right now.
    2006 Subaru STI
    Voom2PC with CN700 Lilliput 7" Digimoto mOByDic
    Sirius-SR1 BU-355 - EWF/Roadrunner/LSX

  10. #10
    Low Bitrate
    Join Date
    Sep 2004
    Posts
    69
    Quote Originally Posted by intuitionsys View Post
    Have you noticed any appreciable redraw lag or other weirdness compared to "real" WindowsXP?
    Nothing really that noticeable.

    When you drag the screen around in 3D mode, there is about a 1/2 second redraw time. This is compared to about a 1/4 of a second in XP. Behaves the exact same way, just a tad bit slower in that regard.

    I'm rebuilding my testing environment using TinyGentoo, so I'll continue to update this thread with new insights or issues.

Page 1 of 10 12345678910 LastLast

Similar Threads

  1. Replies: 17
    Last Post: 06-15-2006, 12:46 AM
  2. Wtb Iguidance 2.1.3 Dvd
    By madehtsobi in forum Classified Archive
    Replies: 2
    Last Post: 05-26-2006, 01:56 AM
  3. iGuidance Font Size Fix summary thread
    By Viscouse in forum GPS
    Replies: 29
    Last Post: 03-28-2006, 06:21 PM
  4. iGuidance 2.1.3 Nag Screen
    By Volsfan in forum Road Runner
    Replies: 6
    Last Post: 03-28-2006, 08:32 AM
  5. iGuidance 2.1.3 - Warning Screen Issue
    By Purplxd in forum Road Runner
    Replies: 13
    Last Post: 11-14-2005, 05:19 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •