Results 1 to 6 of 6

Thread: Installing nGhost

  1. #1
    Newbie
    Join Date
    Jul 2005
    Posts
    44

    Installing nGhost

    I'm having significant difficulties installing nGhost 0.94.4 on opensuse 10.2 x86_64.

    I first attempted to install from source following the instructions that came with it, installing all of the dependencies. At first it would not configure but I managed to fix that. Make dies a horribly painful death giving errors left right and center.

    I then decided to run the executable from the command line because it gives a more decipherable error message than make. What I don't understand is that the executable was giving errors for libraries or shared somethings that it couldn't find - even though they were installed. Updating the library to the same version that was already installed made the error message go away and I could move on to the next one until i got to "error while loading shared libraries: libSDL_image-1.2.so.0: cannot open shared object file: No such file or directory" reinstalling the package SDL-image did not fix the error - i'm certain that this file is installed however.

    I'm at a loss of how to install this. All the dependencies have different names are not quite equivalent under openSUSE so the dependency list is not 100% correct for me. I fixed most things by installing every relevant development package.

    Spuzzdawg

  2. #2
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    You might have already tried this, when compiling make sure you have the dev libraries installed for sdl (libsdl-dev, libsdl-image-dev, libtag-dev, and libsdl-ttf-dev). what versions of SDL to you have installed?

    run an ldd and list the output:
    Code:
    ldd nghost
    I'm no expert at suse so maybe someone else can jump in...

    *update* I'm downloading opensuse so I'll soon find out exactly how to get it installed...
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  3. #3
    Newbie
    Join Date
    Jul 2005
    Posts
    44
    I ran the command in the folder containing the precompiled nGhost and got:

    linux-gate.so.1 => (0xffffe000)
    libtag.so.1 => /usr/lib/libtag.so.1 (0xf7ed7000)
    libmysqlclient.so.15 => /usr/lib/libmysqlclient.so.15 (0xf7d96000)
    libSDL_image-1.2.so.0 => not found
    libSDL_ttf-2.0.so.0 => not found
    libSDL-1.2.so.0 => not found
    libcrypt.so.1 => /lib/libcrypt.so.1 (0xf7d35000)
    libnsl.so.1 => /lib/libnsl.so.1 (0xf7d1f000)
    libpng12.so.0 => /usr/lib/libpng12.so.0 (0xf7cfb000)
    libaudio.so.2 => not found
    libXt.so.6 => /usr/lib/libXt.so.6 (0xf7caa000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0xf7c9b000)
    librt.so.1 => /lib/librt.so.1 (0xf7c92000)
    libz.so.1 => /usr/lib/libz.so.1 (0xf7c7f000)
    libdl.so.2 => /lib/libdl.so.2 (0xf7c7b000)
    libncurses.so.5 => /lib/libncurses.so.5 (0xf7c34000)
    libslang.so.2 => not found
    libX11.so.6 => /usr/lib/libX11.so.6 (0xf7b16000)
    libpthread.so.0 => /lib/libpthread.so.0 (0xf7afe000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xf7a1a000)
    libm.so.6 => /lib/libm.so.6 (0xf79f4000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf79e7000)
    libc.so.6 => /lib/libc.so.6 (0xf78b9000)
    libSM.so.6 => /usr/lib/libSM.so.6 (0xf78af000)
    libICE.so.6 => /usr/lib/libICE.so.6 (0xf7896000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0xf7892000)
    libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xf788b000)
    /lib/ld-linux.so.2 (0xf7f23000)

    Searching for a package in Yast the provides the missing libraries above i get:

    libSDL_image-1.2.so.0 provided by SDL_image (i have version 1.2.5-24 installed)
    libSDL_ttf-2.0.so.0 provided by SDL_ttf (i have version 2.0.8-25 installed)
    libSDL-1.2.so.0 provided by SDL and SDL-32bit (i have SDL 1.2.11-22 installed)
    libaudio.so.2 provided by libaudio (not installed - going to install version 1.8-0.pm.1)
    libslang.so.2 provided by slang and slang-32bit (slang 2.0.5-32 installed)

    I attempted to compile again after installing libaudio - no luck. I tried running the precompiled binary after installing available 32bit version - also no luck.

    Spuzzdawg

  4. #4
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    I would try maybe creating symbolic links for the libraries that you are missing and put them in /usr/lib with the others.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  5. #5
    blk
    blk is offline
    Newbie blk's Avatar
    Join Date
    Jun 2006
    Location
    Switzerland
    Posts
    44
    we shouldn't ship pre-compiled binaries..and if they should statically be linked.
    could these problems result from us having both debian systems on our dev-boxes which sometimes have a seperate subfolder for the libs? (mysql/mysql.h instead of mysql.h, same with libtag)

    i suggest all people switch to debian-based systems :P

  6. #6
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    my vision of the perfect world would involve everyone running a debian based system. But you can't expect everyone to be perfect
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

Similar Threads

  1. nGhost Media Center Beta
    By tripzero in forum LinuxICE
    Replies: 62
    Last Post: 03-05-2008, 12:24 AM
  2. nGhost Media Center Linux Front-end
    By tripzero in forum Other Cool Front Ends
    Replies: 8
    Last Post: 05-15-2007, 08:45 PM
  3. Replies: 15
    Last Post: 04-30-2006, 01:30 AM
  4. Installing car PC in 1996 Honda Civic
    By PredatorCoder in forum Newbie
    Replies: 8
    Last Post: 08-18-2005, 08:58 AM
  5. installing video card w/ onboard video
    By hannibal in forum Newbie
    Replies: 9
    Last Post: 12-18-2004, 01:18 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •