Page 4 of 6 FirstFirst 123456 LastLast
Results 31 to 40 of 54

Thread: nGhost 2.0.0 Final is out!

  1. #31
    Newbie
    Join Date
    Sep 2008
    Posts
    11
    kev I need your help pls do not quit me!!

  2. #32
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    so you do have the libx11-dev package installed? hmm...

    don't give up brotha' we'll get you fixed up.

    it looks like configure didn't find all the libs, odd. sdl_gfx and sdl_image devel packages need to be installed. I'm surprised you got past configure... that may require looking into.

    Are you still getting that same error after you installed the libx11-dev headers?
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  3. #33
    Registered User
    Join Date
    Nov 2006
    Posts
    13
    Quote Originally Posted by Virtuoid View Post
    i installed all dependecies (like 15 -,-) so ./configure works on libnghost-2.0.1 but this is what i get when i do make

    In file included from gfxengine.h:27,
    from background.h:23,
    from background.cpp:20:
    effects.h:25:23: error: SDL_image.h: No such file or directory
    effects.h:27:26: error: SDL_rotozoom.h: No such file or directory

    In file included from background.h:23,
    from background.cpp:20:
    gfxengine.h:63: error: ISO C++ forbids declaration of ‘Display’ with no type
    gfxengine.h:63: error: expected ‘;’ before ‘*’ token
    gfxengine.h:64: error: expected `;' before ‘static’
    gfxengine.h:64: error: ISO C++ forbids declaration of ‘Window’ with no type
    gfxengine.h:64: error: expected ‘;’ before ‘&’ token
    gfxengine.h:65: error: expected `;' before ‘int’
    gfxengine.h:103: error: ISO C++ forbids declaration of ‘Display’ with no type
    gfxengine.h:103: error: expected ‘;’ before ‘*’ token
    gfxengine.h:104: error: ‘Window’ does not name a type
    make[3]: *** [libnghostgui2_la-background.lo] Error 1
    make[3]: Leaving directory `/home/virtuoid/Desktop/libnghost-2.0.1/src/gui2'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/home/virtuoid/Desktop/libnghost-2.0.1/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/virtuoid/Desktop/libnghost-2.0.1'
    make: *** [all] Error 2


    these are just the last strings

    i get similar errors when i do sudo make install. what should i do?
    Do you have the devel package for sdl_image and sdl_gfx ?

  4. #34
    Newbie
    Join Date
    Sep 2008
    Posts
    11
    I installed both the SDL packages. And the message of missing packages is disappared. This is the error at last version always after the command: make

    In file included from background.h:23,
    from background.cpp:20:
    gfxengine.h:63: error: ISO C++ forbids declaration of ‘Display’ with no type
    gfxengine.h:63: error: expected ‘;’ before ‘*’ token
    gfxengine.h:64: error: expected `;' before ‘static’
    gfxengine.h:64: error: ISO C++ forbids declaration of ‘Window’ with no type
    gfxengine.h:64: error: expected ‘;’ before ‘&’ token
    gfxengine.h:65: error: expected `;' before ‘int’
    gfxengine.h:103: error: ISO C++ forbids declaration of ‘Display’ with no type
    gfxengine.h:103: error: expected ‘;’ before ‘*’ token
    gfxengine.h:104: error: ‘Window’ does not name a type
    make[3]: *** [libnghostgui2_la-background.lo] Error 1
    make[3]: Leaving directory `/home/virtuoid/Desktop/libnghost-2.0.1/src/gui2'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/home/virtuoid/Desktop/libnghost-2.0.1/src'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/virtuoid/Desktop/libnghost-2.0.1'
    make: *** [all] Error 2


    I can't find this gfxengine.h package anywere but if i do locate this is the answer

    virtuoid@Virtu-Ubuntu:~/Desktop/libnghost-2.0.1$ locate gfxengine.h

    /home/virtuoid/Desktop/libnghost-2.0.1/src/gui2/gfxengine.h
    /home/virtuoid/Desktop/libnghost-2.0.1/src/gui3/gfxengine.h
    /home/virtuoid/Desktop/xds.txt/libnghost-2.0.1/src/gui2/gfxengine.h
    /home/virtuoid/Desktop/xds.txt/libnghost-2.0.1/src/gui3/gfxengine.h

  5. #35
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    virtuiod, what distro are you running?

    if it's ubuntu:

    sudo apt-get install libx11-dev
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  6. #36
    Newbie
    Join Date
    Sep 2008
    Posts
    11
    I have already installed it but it doesn't work (I'm on an EEEPC 900 with Ubuntu Hardy Heron). Any suggestions?

  7. #37
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    does the deb package work for you? it's built on feisty, but I run it on my desktop (hardy).
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  8. #38
    Newbie
    Join Date
    Sep 2008
    Posts
    11
    I tried it first of .tar.gz but it didn't work!!

  9. #39
    Newbie
    Join Date
    Sep 2008
    Posts
    11
    I installed deb files but i don't know the command to launch it ^^

    if i do virtuoid@Virtu-Ubuntu:~/Desktop/libnghost-2.0.1$ nghost

    i get

    nghost: symbol lookup error: nghost: undefined symbol: _ZN6nghost5ncore16m_genericActionsE

  10. #40
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    Interesting, there shouldn't be anything that uses genericActions in nGhost 2.0.1.

    I probably installed libnghost + nghost 2.0.1 on a fresh system almost a dozen times with no problems...


    I don't know what to say other than try the debs for 2.0.2. Make sure you uninstall everything you can find related to nghost first.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

Page 4 of 6 FirstFirst 123456 LastLast

Similar Threads

  1. Linux Ice and Nghost looking for developers
    By wirelessdreamer in forum LinuxICE
    Replies: 5
    Last Post: 08-16-2009, 07:05 AM
  2. Centrafuse 2.0 Final
    By Jan_RedGTiVR6 in forum Centrafuse
    Replies: 0
    Last Post: 08-17-2008, 01:35 PM
  3. Can´t get DirectX to work
    By Linde in forum Software & Software Development
    Replies: 0
    Last Post: 10-19-2007, 08:35 AM
  4. SD crashes on startup
    By mangus580 in forum StreetDeck
    Replies: 7
    Last Post: 10-05-2007, 12:14 PM
  5. Carputer as a comp sci final year project?
    By MikeHunt79 in forum General MP3Car Discussion
    Replies: 5
    Last Post: 06-23-2004, 10:19 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •