Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: nGhost 2.0.2 on Ubuntu 9.0.4 - 'make' issue

  1. #11
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,560
    Quote Originally Posted by ThePistonDoctor View Post
    ok, so I'll try that, one stupid question though...how do you "uninstall" something in Linux? I'm very new to it!
    sudo make uninstall

    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  2. #12
    Newbie
    Join Date
    May 2009
    Posts
    1
    i had the same problem and i found a solution that finaly worked.Go to
    http://linuxice.openice.org/packages/ end download the two packages.install them and you will fine.

  3. #13
    Constant Bitrate
    Join Date
    May 2008
    Posts
    116
    ugh, so I've done the code up above now and downloaded both from SVN...I uninstalled everything first and now when I run nGhost's configure I'm getting an error saying the nghostcore package requirement was not met. I searched through Synaptic and couldn't find anything...then googled and found a couple responses saying i need to have libnghost installed...which I just did 3 seconds ago. WTF!!

    Can I just sudo apt-get this package from somewhere?

  4. #14
    Constant Bitrate
    Join Date
    May 2008
    Posts
    116
    scratch that, helps if I run make install on libnghost lol...so, now what? I got it up and running. I guess now I just need to know what to do with it...lol

    Edit: so I got it to boot up on startup so it's pretty much up and running now. I can click on Internet and it pops open mozilla, etc etc but I noticed there is a blank button in the lower right but if I click on it, it's functional and the three buttons it takes me to show some engine disgnostics, weather, and something else I forgot. It says, however, that most of those plugins are not installed. Is this an in development thing? It seems pretty buggy...as when I go into the settings I can't always get the back button to work and stuff like that. Is there a stable version of this or something? I'm using v. 2.0.2...not sure if I should be using a different version. Thanks!!!

  5. #15
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,560
    Quote Originally Posted by ThePistonDoctor View Post
    scratch that, helps if I run make install on libnghost lol...so, now what? I got it up and running. I guess now I just need to know what to do with it...lol

    Edit: so I got it to boot up on startup so it's pretty much up and running now. I can click on Internet and it pops open mozilla, etc etc but I noticed there is a blank button in the lower right but if I click on it, it's functional and the three buttons it takes me to show some engine disgnostics, weather, and something else I forgot. It says, however, that most of those plugins are not installed. Is this an in development thing? It seems pretty buggy...as when I go into the settings I can't always get the back button to work and stuff like that. Is there a stable version of this or something? I'm using v. 2.0.2...not sure if I should be using a different version. Thanks!!!
    Use one of the packages from http://linuxice.openice.org/packages they are much more updated than 2.0.2. Note, these are prerelease packages, but they should be stable enough. Or, there is always SVN. I haven't heard any similar reports from any other users using the latest.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  6. #16
    Constant Bitrate
    Join Date
    May 2008
    Posts
    116
    Quote Originally Posted by kev000 View Post
    Use one of the packages from http://linuxice.openice.org/packages they are much more updated than 2.0.2. Note, these are prerelease packages, but they should be stable enough. Or, there is always SVN. I haven't heard any similar reports from any other users using the latest.

    I downloaded from SVN given your code above...I probably just don't know what I'm doing lol

  7. #17
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,560
    If you are using SVN, then you are on 2.1.0.x. If you compiled from SVN, you need to enable the plugins during configure and add them to your plugins.conf so nghost knows to load them.

    nGhost from SVN isn't the most stable code and changes often. So if you are looking for something more stable, stick with 2.0.2 or earlier (official releases).

    That said, we've been fixing bugs and tweaking 2.1 for quite a while now. nGhost is very much an in-development thing. It's constantly being improved and fixed. I personally don't like using software that isn't in development, cuz then you don't get any new features/bug fixes.

    If there is something specific not working in nGhost, we'd be happy to fix it up for you.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  8. #18
    Newbie
    Join Date
    May 2009
    Posts
    7
    Quote Originally Posted by kev000 View Post
    If you are using SVN, then you are on 2.1.0.x. If you compiled from SVN, you need to enable the plugins during configure and add them to your plugins.conf so nghost knows to load them.
    And how do you do that? I compiled and installed the latest SVN of both libnghost and nghost2, but when I try to run it, I get errors about not being able to load plugins.

  9. #19
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,560
    Quote Originally Posted by Sureshot324 View Post
    And how do you do that? I compiled and installed the latest SVN of both libnghost and nghost2, but when I try to run it, I get errors about not being able to load plugins.
    can you paste the errors here? You may have to run ldconfig or something.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  10. #20
    Newbie
    Join Date
    May 2009
    Posts
    7
    Here are the errors. Running ldconfig didn't help.

    root@louis-laptop:/home/louis# nghost
    06/07/2009 01:45:34 EDT:WARNING - WARNING: Duplicate Global Command 'name' found: subscribeToProgress
    06/07/2009 01:45:34 EDT:WARNING - WARNING: Duplicate Global Command 'name' found: subscribeToProgress
    06/07/2009 01:45:34 EDT:ERROR - npluginloader.cpp:load(42) - lt_dlopenext("") - file not found
    06/07/2009 01:45:34 EDT:WARNING - populate.cpp:SearchDir(62) - Failed to create the download plugin
    06/07/2009 01:45:34 EDT:ERROR - npluginloader.cpp:load(42) - lt_dlopenext("") - file not found
    06/07/2009 01:45:34 EDT:WARNING - populate.cpp:SearchDir(62) - Failed to create the download plugin
    06/07/2009 01:45:34 EDT:ERROR - npluginloader.cpp:load(42) - lt_dlopenext("") - file not found
    06/07/2009 01:45:34 EDT:ERROR - BaseDB: basedb.hpp:init(60) - Failed to load the database plugin

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Linux Ice and Nghost looking for developers
    By wirelessdreamer in forum LinuxICE
    Replies: 5
    Last Post: 08-16-2009, 06:05 AM
  2. Ubuntu Mobile - the next gen Car PC frontend!?
    By wywywywy in forum Unix, Linux, BSD, Etc
    Replies: 27
    Last Post: 06-23-2009, 11:31 AM
  3. nGhost 2.0.2 is baked and released
    By tripzero in forum LinuxICE
    Replies: 14
    Last Post: 05-31-2009, 05:06 PM
  4. Indexing music in 1.0.9.8 Failed
    By hovalistic in forum StreetDeck
    Replies: 0
    Last Post: 07-07-2007, 11:19 AM
  5. False floor
    By i3igmind in forum Fabrication
    Replies: 29
    Last Post: 02-04-2006, 10:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •