Results 1 to 3 of 3

Thread: nweather.py bug,,,maybe

  1. #1
    Newbie govee's Avatar
    Join Date
    Dec 2009
    Location
    Southern, Maryland
    Posts
    45

    nweather.py bug,,,maybe

    I noticed the zip was incorrect for the weather pull so I went to /etc/nghost/weather.conf and changed it there. I performed a restart and still the zip was wrong. I then opened /usr/bin/nweather.py and noticed on line 54 that the config file is listed as below:
    Code:
    CONFIG FILE = "weather.conf"
    I changed it to:
    Code:
    CONFIG FILE = "/etc/nghost/weather.conf"
    This brought up the correct zip code.

    I said maybe on the "bug" as I am not sure if a complete run of "nghost" in term would get the correct zip enetered. Whenever I run "nghost" I get a boat load of failures and it never completes and I have to close the terminal window.

  2. #2
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,560
    Nice catch! I fixed this in svn. I'll push it out to the LinuxICE repo when I'm finished with the other nGhost updates/fixes currently in progress.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  3. #3
    Newbie govee's Avatar
    Join Date
    Dec 2009
    Location
    Southern, Maryland
    Posts
    45
    A few other things I noticed are:
    No Icons show up and the path to the Icons is wrong.
    Day 2 and 3 in the forcast are missing a lot of data, but Day 1, 4, 5 are ok.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •