Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: nghost freezes and pulse audio volume drops every reboot

  1. #1
    Newbie
    Join Date
    Mar 2010
    Posts
    31

    nghost freezes and pulse audio volume drops every reboot

    Hello,
    I'm having major problems with nghost. First it freezes for up to several minutes on almost every action preformed. This leaves an unusable interface. At the same time icepanel works fine and without delay. I have a feeling this problem has to do with nscan locking the database. Why do you need to lock the database if assuming nscan is the only program that writes to it? If you just got rid of the spin lock I don't think there would be an issue. The second problem I'm having is pulse audio's volume will fall to 15% on every reboot.
    Thanks

  2. #2
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    Quote Originally Posted by thatguy666 View Post
    Hello,
    I'm having major problems with nghost. First it freezes for up to several minutes on almost every action preformed. This leaves an unusable interface. At the same time icepanel works fine and without delay. I have a feeling this problem has to do with nscan locking the database. Why do you need to lock the database if assuming nscan is the only program that writes to it? If you just got rid of the spin lock I don't think there would be an issue. The second problem I'm having is pulse audio's volume will fall to 15% on every reboot.
    Thanks
    LinuxICE 2.0.1? why do you think that nghost/nscan is locking the database? is this a new problem or has it always been this slow for you?

    FWIW, nghost only writes to the database to update playback stuff and to remember listbox filters. What kind of harddrive do you have?
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  3. #3
    Newbie
    Join Date
    Mar 2010
    Posts
    31
    LinuxICE 2.0.1? why do you think that nghost/nscan is locking the database? is this a new problem or has it always been this slow for you?

    FWIW, nghost only writes to the database to update playback stuff and to remember listbox filters. What kind of harddrive do you have?

    I've had this issue before but it has never been this bad. In my system I have two harddrives. The bootdrive is an 30 gb ocz ssd. The second drive is an 80gb samsung drive that contains all my 45gbs of music. About ~11000 songs. The sheer size could be an issue as well but I honestly don't think so. I've had problems with nghost and a second harddrive before. I can not mount it at ~/Music or any directory under ~/ or the gui will not start automatically on bootup. This was bypassed by mounting the drive at /Music.
    While I was playing with nghost in ubuntu unr I was running nscan in foreground mode. Whenever the spinlock message came up nghost would freeze. Nghost would resume once nscan released the lock. In addition if I killed nscan nghost would unfreeze.

    The sound issue happens at the start of every song. Mplayer's volume drops to 15%. I have to increase the application volume in pulseaudio every time a new song starts in order to hear anything. This may be a byproduct of messing with bluetooth audio streaming. I'll keep you apprised.
    Thanks,

  4. #4
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    Quote Originally Posted by thatguy666 View Post
    The sound issue happens at the start of every song. Mplayer's volume drops to 15%. I have to increase the application volume in pulseaudio every time a new song starts in order to hear anything. This may be a byproduct of messing with bluetooth audio streaming. I'll keep you apprised.
    Thanks,
    Use icepanel to change the volume. nGhost will try to remember that setting and set it to that level every time you play a song. It doesn't respect pulseaudio's settings right now.

    I wonder if nscan is putting too much load on the system when it scans. I have noticed that nghost lags when loading new screens when nscan is active because nghost tries to access the disk to load the skin images. The workaround is to have nghost cache the skin images at startup by changing the memory profile. IIRC it's nghost --speed aggressive. Give that a try and see if it improves things at all.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  5. #5
    Newbie
    Join Date
    Mar 2010
    Posts
    31
    Use icepanel to change the volume. nGhost will try to remember that setting and set it to that level every time you play a song. It doesn't respect pulseaudio's settings right now.

    I wonder if nscan is putting too much load on the system when it scans. I have noticed that nghost lags when loading new screens when nscan is active because nghost tries to access the disk to load the skin images. The workaround is to have nghost cache the skin images at startup by changing the memory profile. IIRC it's nghost --speed aggressive. Give that a try and see if it improves things at all.

    Well that solved my sound issue. I want to kick myself for that one.

    I added the -s aggressive option to the script in /etc/matchbox/session. This helped considerably but, the same problem remains. It will still lag after startup but much improved. Thanks.
    I have 2gb of ram and no swap so I changed the swappiness to 10. This lead to a large improvement as well.
    For boot time improvements
    I also removed cups and quite a few other unneeded programs. I'm also going to remove some ttys. Finally I added profile after "ro quiet splash" in the grub.lst and dropped the time out to 0.
    Thanks

  6. #6
    Newbie
    Join Date
    Mar 2010
    Posts
    31
    I removed nscan from the startup and the problem has disappeared.

  7. #7
    Maximum Bitrate locs4dayz's Avatar
    Join Date
    Sep 2009
    Location
    Philadelphia, PA
    Posts
    507
    I"m not getting any sound. The volume slider does nothing. Like I said before...as soon as I fix one thing thats not working, something that was stops. How do I get my sound back?
    Linux(Learning the curve...Like when driving!!!)
    Worklog!!!http://www.mp3car.com/vbulletin/fabr...l-worklog.html

  8. #8
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    Quote Originally Posted by locs4dayz View Post
    I"m not getting any sound. The volume slider does nothing. Like I said before...as soon as I fix one thing thats not working, something that was stops. How do I get my sound back?
    launch pavucontrol (its in the apps menu somewhere) and make sure nothing is muted. The reboot-mute issue has been resolved in 2.0.1.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  9. #9
    Maximum Bitrate locs4dayz's Avatar
    Join Date
    Sep 2009
    Location
    Philadelphia, PA
    Posts
    507
    Quote Originally Posted by tripzero View Post
    launch pavucontrol (its in the apps menu somewhere) and make sure nothing is muted. The reboot-mute issue has been resolved in 2.0.1.
    That was the first thing I tried way before posting....nothing is muted....
    Linux(Learning the curve...Like when driving!!!)
    Worklog!!!http://www.mp3car.com/vbulletin/fabr...l-worklog.html

  10. #10
    Maximum Bitrate locs4dayz's Avatar
    Join Date
    Sep 2009
    Location
    Philadelphia, PA
    Posts
    507
    Quote Originally Posted by tripzero View Post
    Use icepanel to change the volume. nGhost will try to remember that setting and set it to that level every time you play a song. It doesn't respect pulseaudio's settings right now.

    I wonder if nscan is putting too much load on the system when it scans. I have noticed that nghost lags when loading new screens when nscan is active because nghost tries to access the disk to load the skin images. The workaround is to have nghost cache the skin images at startup by changing the memory profile. IIRC it's nghost --speed aggressive. Give that a try and see if it improves things at all.

    Also how do I do this...wouldn't mind speeding up my boot time by a few seconds. Also would removing nscan from the startup reduce even more boot time? Would it affect my usplash(got to protect the usplash...after all I went through to get it perfect...will post a vid of my boot up process soon)? How would I accomplish this?
    Linux(Learning the curve...Like when driving!!!)
    Worklog!!!http://www.mp3car.com/vbulletin/fabr...l-worklog.html

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •