Page 9 of 15 FirstFirst 123456789101112131415 LastLast
Results 81 to 90 of 142

Thread: Re-engineered M2-atx firmware with fixes and added functionality

  1. #81
    riv
    riv is offline
    Low Bitrate
    Join Date
    Dec 2009
    Posts
    59
    I am missing a point, please help me understand. Is there any way to re-flash current unit with new firmware? If not then is it possible to purchase "customized" unit?

  2. #82
    Newbie
    Join Date
    Feb 2010
    Posts
    33
    Does it fit on PIC 18F2550? Got one here =)

  3. #83
    Low Bitrate
    Join Date
    Feb 2010
    Location
    Kentucky
    Posts
    84
    Yes it is possible to re-flash the PIC that is currently in the M2 if you have the appropriate code and a PIC programmer. However, I am intending to sell (at very low cost) customized versions. Please keep an eye on this thread as I will give details how to order one in the next couple of days.

    Quote Originally Posted by riv View Post
    I am missing a point, please help me understand. Is there any way to re-flash current unit with new firmware? If not then is it possible to purchase "customized" unit?

  4. #84
    Low Bitrate
    Join Date
    Feb 2010
    Location
    Kentucky
    Posts
    84
    There is plenty of memory on the 18f2550, but since that is a 28 pin PIC, it is not pin compatible with the M2, which uses a 20 pin 16f818.


    Quote Originally Posted by lugi View Post
    Does it fit on PIC 18F2550? Got one here =)

  5. #85
    Low Bitrate
    Join Date
    Feb 2010
    Location
    Kentucky
    Posts
    84

    PICs for sale

    I am ready to start selling preprogrammed PICs with my code on them. As described before, I will charge $10.00 to cover the hardware, postage, and time and then you may donate how ever much you feel like it is worth to you above that. If you feel like it is worth another $5 or $10 to get the added functionality or custom timings, I appreciate that as I have spent a LOT of time on this project. For those of you who have spent countless hours minimizing boot time, how much would 5 seconds off of it be worth to you? If $10 is already enough for you, that is fine too. I will love you anyways.

    Here is how this is going to work:

    I will start a queue in the order that people PM me saying something like "I want to buy a custom chip for my M2." I will PM you details and we can clarify if you want some custom timing or battery voltage. The first 5 orders will go out immediately once I receive payment. In order to keep any issues at a manageable level, all orders after that will be held until I hear back from the first 5 that they are working properly, just as a precautionary measure. I do not expect any problems, as I have been using this exact code in my car for several weeks now.

    Please let me know if you have any questions!

    Thanks, Stephen

  6. #86
    riv
    riv is offline
    Low Bitrate
    Join Date
    Dec 2009
    Posts
    59
    > I want to buy a custom chip for my M2
    But I will need following scenario created for me, confirm that this is possible:
    1. initial wait before sending "power button press" not 5 sec, but rather 15-20 secs
    2. power ON amplifier after 30 seconds.
    3. send shutdown "power button press" after 10 minutes
    4. hard off after 30 minutes
    5. turn amplifier right when #2 (shutdown) is send (actually would be nice is send in 20-30 seconds after, so I can listen for any sounds caused by the system showdown).

    Thanks a lot for your effort.

  7. #87
    Low Bitrate
    Join Date
    Feb 2010
    Location
    Kentucky
    Posts
    84
    Quote Originally Posted by riv View Post
    > I want to buy a custom chip for my M2
    But I will need following scenario created for me, confirm that this is possible:
    1. initial wait before sending "power button press" not 5 sec, but rather 15-20 secs
    2. power ON amplifier after 30 seconds.
    3. send shutdown "power button press" after 10 minutes
    4. hard off after 30 minutes
    5. turn amplifier right when #2 (shutdown) is send (actually would be nice is send in 20-30 seconds after, so I can listen for any sounds caused by the system showdown).

    Thanks a lot for your effort.
    Let me see if I understand correctly:

    1. You turn the ignition on, and the system waits 15-20 sec before turning on the mobo?
    2. Amplifiers come on 30 sec after ignition or 30 sec after mobo turns on?
    3. shutdown power button press to mobo 10 minutes after ignition switched off?
    4. Hard off 30 minutes after system shutdown
    5. Amplifiers turned off at the same time as power button press to shutdown mobo? (or 20-30 sec afterward)

    If you could please clarify some of your timing needs, I am very curious because they are different than what most people use.

    1. Why do you want such a slow boot process?
    2. no problem just clarification
    3. no problem just clarification
    4. no problem
    5. Turning off an audio source before the amps is what causes turn off "pop" although I imagine as long as power is removed from the amp before the system finishes shutting down, it probably will not occur. What sounds does your system make when shutting down that you want to hear (just curious)?

    My firmware can do all that no problem with the exception of number 5, 20-30 sec after button press. I did not imagine that anyone would want to listen to their computer shut down, so the amplifiers are turned off early in the shutdown process.

  8. #88
    riv
    riv is offline
    Low Bitrate
    Join Date
    Dec 2009
    Posts
    59
    1. Correct. I usually start the car within a 2-5 secs of the putting key in it. Also, I have remote start system, which takes at least 3-5 secs between ignition and cranking. So I want to avoid starting the computer at the crank. May be 30 secs is too much, but minimum is 10.
    2. 30 secs after mobo turns on
    3. Correct
    4. Correct
    5. I did not notice any specific sound when the amp starts/shuts, more like relays switching, nothing annoying.

  9. #89
    Low Bitrate
    Join Date
    Feb 2010
    Location
    Kentucky
    Posts
    84
    Quote Originally Posted by riv View Post
    1. Correct. I usually start the car within a 2-5 secs of the putting key in it. Also, I have remote start system, which takes at least 3-5 secs between ignition and cranking. So I want to avoid starting the computer at the crank. May be 30 secs is too much, but minimum is 10.
    2. 30 secs after mobo turns on
    3. Correct
    4. Correct
    5. I did not notice any specific sound when the amp starts/shuts, more like relays switching, nothing annoying.
    1. I still do not understand why you want to wait to turn on the computer until after the car cranks. The M2 can supply regulated power with anything more than 6V, and cranking the car usually takes the voltage down to about 9V. I have my PSU turn on the computer immediately after the ignition goes high and it does not matter when I crank the engine... I can't think of any reason it would cause problems with a remote start system either.

    5. Turning on and off the amp is not what makes the popping sound. It is turning on and off the source when the amp is on. Sometimes power fluctuation makes it into the audio signal lines going to the amp and then the amplifier, well, amplifies them. So if you wait until power is steady in the source before turning the amp on, there is no pop. Similarly, if you turn the amp off before cutting power to the source there is no pop.

    Can you clarify any further on what you want regarding 1 and 5?

  10. #90
    riv
    riv is offline
    Low Bitrate
    Join Date
    Dec 2009
    Posts
    59
    1. But, if I want? Could you do 10 sec wait? Plus I have another power supply (DCDC) to turn my monitor, USB hubs, HD radio, some sensors... which is takes 5 secs as well, so it will be not too good to start computer before all USB accessories. Please correct me if I am wrong
    2. Amp can signaled to turn off right when shutdown is issued. I have implemented this right now with separate relay, which controlled by the ignition... not the cleanest solution, but to prevent battery drain, as well as unoccupied vehicle playing music on some parking lot.

Similar Threads

  1. DigitalFX 4.0
    By JohnWPB in forum RR Skins No Longer Supported
    Replies: 5576
    Last Post: 03-27-2014, 04:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •