Page 1 of 7 1234567 LastLast
Results 1 to 10 of 69

Thread: Draining Battery

  1. #1
    Low Bitrate
    Join Date
    Jan 2008
    Posts
    111

    Draining Battery

    Hey guys,
    I've had my Mac Mini carputer installed in my car for a little over 6 months now and have been struggling with my car battery dying almost daily - this is with the Mac Mini powered off.

    Through the day, I can leave the Mini in sleep mode and my battery is fine. After I park my car for the night though, I switch the Mini off and unless I drive it in the morning, my car will be dead by the afternoon (sometimes even in the morning - meaning I have to charge/jump my car before I can drive it).

    It's quite annoying/frustrating. I know it's my carputer causing the issues because sometimes when the battery goes dead, my Carnetix P1900 gets "confused" and my carputer won't power on until I disconnected the negative battery terminal and reconnect it (I guess that resets it)... my battery will never die while the power supply is "confused" (when the computer doesn't power on). As soon as I decide to reconnect the battery terminal to use my carputer, the same cycle continues.

    I wouldn't think that this is normal. I even replaced my battery thinking it was a crappy lead acid battery (which is was, and the one I replaced it with is). I'm thinking about putting an Optima YellowTop in, but something tells me that my carputer shuold not be draining my battery - especially while its off!

  2. #2
    Low Bitrate
    Join Date
    Jan 2008
    Posts
    111
    Sure enough, I went to start it this afternoon and it was dead as expected. :/

  3. #3
    Variable Bitrate TeamRSX's Avatar
    Join Date
    Nov 2007
    Location
    Ottawa, Ontario
    Posts
    222
    I feel your pain, as i had a battery draining problem when i first installed my carpc.

    The first thing you should do is get a voltmeter which can also read amps.

    Once you know how many amps your car is reading while the engine if off then you can start to figure out what is draining your battery.

    What i did was check my amps while the car is off and unplug things to see if anything is affecting it.

    disconnect your main power for your carpc to see if your amps goes down just so we can be sure it it actually your carpc and not anything else.

    For me i though it was my carpc for sure draining the battery, but it ended up not being the carpc as i checked my amps and even with the carpc disconnected it was the same. It ended up being a stock fuse for my bose system which was still reading 12v while the car was off. Since i was not using the bose system anymore i took out the fuse and it dropped my amps a lot.

    it was 1.5amps before i took out the fuse and 0.2 when i took it out.

    So, first thing first, get a amp reader to verify if its actually your carpc, it could also be a short or a bad ground somewhere.

    if its a new battery i wouldn't expect it to be the battey and don't think the draining would go away by installing a yellow top. Get to the source of the problem by disconnecting things and checking your amps.

  4. #4
    Low Bitrate
    Join Date
    Jan 2008
    Posts
    111
    It has to be my carputer because the Carnetix powersupply will sometimes get "confused" when I attempted to start the car with a dead battery. Once the battery is charged up/the car jumped my Mac Mini and associated perhipherals will not power on no matter how many times I start and power off my car. During this time, I can leave my car sitting for days, and the battery isn't dead.

    However, as soon as I "reset" Carnetix power supply (therefore giving power to all my Carputer related equipment), the cycle continues and my battery will begin to be drained, even while the Mac Mini is shut off.

    I do have a Voltmeter than reads Amps and will see how much current is being drawn with the car off. I find it bizarre that a Mac Mini would draw enough power while its off to kill my battery in around 12 hours.

    Thanks!

  5. #5
    Constant Bitrate scatebase's Avatar
    Join Date
    Oct 2008
    Posts
    146
    What other devices do you have connected to the P1900? maybe usb? I think your best bet is to do what TeamRSX said, and if it is coming from your computer, check each device powered by the P1900. If your computer is turned off when this happens, it must be something else that is powered by the P1900.

  6. #6
    CarFrontEnd Creator iamgnat's Avatar
    Join Date
    Jul 2004
    Location
    NoVA
    Posts
    867
    TeamRSX is on the right track. Even if you left your Mini running with the engine off, it should take a long time to run the battery down. With the Mini off, there should be almost no draw from the P1900. Furthermore, the P1900 (unless you disabled it) has an auto shutoff that will kill the power to it and all the devices attached to it if your battery drops too low (but still leaves more than enough to crank assuming everything else is OK).

    Some things I would suggest:
    1) How old is your battery? It could be that your battery is simply old and no longer holding a charge. You can usually take it into an auto parts store and have it tested. This is the easiest thing to test and easiest to fix.

    2) Have your Alternator checked. If it is no longer functioning properly, it may not be able to meet your needs and recharge the battery.

    3) What is your commute like? If it is short, your alternator may not have enough time to recharge the battery after starting. If the battery and/or Alternator are bad, that will compound the issue.

    3) As TeamRSX suggested, put an ammeter on the line from the battery to the P1900. That will tell you if there is a draw that there shouldn't be (possibly a short which could actually damage both your battery and alternator).

    4) Figure out what your draw is, it could be that your Alternator is fine but just under powered for your needs.

    5) Put an ammeter on the MFG wiring to the battery and make sure that it is operating within spec for your vehicle.

    -dave
    My pathetic worklog.
    CarFrontEnd (now it's own sub-forum!!!!)

  7. #7
    Admin. Linux loser.
    Auto Apps:loading...
    Bugbyte's Avatar
    Join Date
    Sep 2004
    Location
    Corning, NY
    Posts
    7,359
    Blog Entries
    2
    What do you have plugged into the USB ports? The Mini will supply power to the USB ports even when 'shut off'. If you have stuff on those ports, they are probably drawing enough power to run your battery dead.

    You'll need to use a USB port that is only powered when the car ignition is on.
    Quote Originally Posted by ghettocruzer View Post
    I was gung ho on building a PC [until] just recently. However, between my new phone having internet and GPS and all...and this kit...Im starting to have trouble justfiying it haha.
    Want to:
    -Find out about the new iBug iPad install?
    -Find out about carPC's in just 5 minutes? View the Car PC 101 video

  8. #8
    Low Bitrate
    Join Date
    Jan 2008
    Posts
    111
    I tried taking a reading of the amps from my battery with the car off and two ammeters we have read 0 (but then again, they read 0 on other devices too). Maybe I don't know how to measure amps using my Voltmeter? I have a basic Radioshack Voltmeter/Ohms/Ammeter - it reads Volts okay, but not Amps.

    I have my power supply set to put the computer into sleep mode - but I stopped letting the computer sleep overnight because it was killing my battery (which is really shouldn't be - I don't think) - so I told the Mac Mini to not be able to sleep from the power switch and I manually power it down as soon as I switch the car off.

    As far as USB devices, they are all plugged directly into the back of the Mini. I've got a small Belkin USB 2.0 hub (non-powered) plugged in as well. I've got a US GlobalSat BU-353 GPS, Griffin Powermate (the blue LEd for this shuts off when the computer is shut off), Lilliput 7" Touchscreen, VAG-Com diagnostics (there is a Blue LED on - regardless if its plugged into the Mac Mini), and I think that is it.

    Do you guys know of any uSB hubs that are powered only by a power adaptor? I called a bunch of manufacturers and it seems none are produced anymore. I would, however, like to know if it is the USB devices draining my battery before I buy another USB hub though.

    Some things I would suggest:
    1) How old is your battery? It could be that your battery is simply old and no longer holding a charge. You can usually take it into an auto parts store and have it tested. This is the easiest thing to test and easiest to fix.

    Battery is new - I bought another battery thinking my old battery was bad - this one has the same issue. I had the new one tested as well since I thought it was bad. They said my alternator and battery tested okay.

    2) Have your Alternator checked. If it is no longer functioning properly, it may not be able to meet your needs and recharge the battery.

    It was replaced a year ago, and was tested by Interstate as okay - was pushing 14.5V to the battery when my car was on.

    3) What is your commute like? If it is short, your alternator may not have enough time to recharge the battery after starting. If the battery and/or Alternator are bad, that will compound the issue.

    Varies. Roughly 15-40 minutes depending on traffic or going to work or school. After my battery being dead this afternoon (around 3pm), and driving around doing some errands, my battery was at 12.5 volts after sitting for a few hours - Mac Mini shut off.

    3) As TeamRSX suggested, put an ammeter on the line from the battery to the P1900. That will tell you if there is a draw that there shouldn't be (possibly a short which could actually damage both your battery and alternator).

    I couldn't get my ammeter to work - any tips on using it? It's just a basic Radioshack Voltmeter combo.. I thought I'd be able to put the positive/negative leads on the battery terminals and measure it. It came out as zero which can't be right.


    4) Figure out what your draw is, it could be that your Alternator is fine but just under powered for your needs.

    Will need to figure this one out...

  9. #9
    Constant Bitrate scatebase's Avatar
    Join Date
    Oct 2008
    Posts
    146
    I think most hubs that have a separate power cable would work for this.

  10. #10
    Low Bitrate
    Join Date
    Jan 2008
    Posts
    111
    Everyone I've found will revert to drawing power from the computer if there is no power from the AC Adaptor now though.

Page 1 of 7 1234567 LastLast

Similar Threads

  1. Replies: 4
    Last Post: 08-15-2006, 08:20 PM
  2. Battery draining while car sits
    By schapman43 in forum Power Supplies
    Replies: 4
    Last Post: 07-14-2005, 12:33 AM
  3. Replaced Motherboard battery now no post??
    By BADDERICK in forum General Hardware Discussion
    Replies: 8
    Last Post: 07-08-2005, 02:34 PM
  4. Battery an Alternator
    By UM_Fan in forum General MP3Car Discussion
    Replies: 9
    Last Post: 07-07-2005, 06:45 PM
  5. MPJA - MECI ASTEC DC-DC Converter
    By Luc in forum General Hardware Discussion
    Replies: 39
    Last Post: 11-22-2004, 09:31 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •