Results 1 to 6 of 6

Thread: Mac Developers - Can you answer this question?

  1. #1
    Admin. Linux loser.
    Auto Apps:loading...
    Bugbyte's Avatar
    Join Date
    Sep 2004
    Location
    Corning, NY
    Posts
    7,359
    Blog Entries
    2

    Mac Developers - Can you answer this question?

    I took ZapWizard's Google Earth GPS script and put it into an applescript application, adding a GUI that tells you your speed.

    In order to get it to work, I had to use a serial and XML scripting addition (OSAX's). I built the app, got it to work on my development machine, then transferred the app to my in car Mac Mini.

    It doesn't launch. It bounces on the dock 5 or 6 times and then disappears. I thought it was a problem with the OSAX's, so I put them in my Library-->Scripting Additions folder but got the same result.

    Any ideas of how to debug this?
    Quote Originally Posted by ghettocruzer View Post
    I was gung ho on building a PC [until] just recently. However, between my new phone having internet and GPS and all...and this kit...Im starting to have trouble justfiying it haha.
    Want to:
    -Find out about the new iBug iPad install?
    -Find out about carPC's in just 5 minutes? View the Car PC 101 video

  2. #2
    Low Bitrate
    Join Date
    Jul 2005
    Location
    Atlanta
    Posts
    68
    I've run into this before - an app will work fine on the machine it's compiled on but not on anything else. In XCode (I'm assuming that's what you're using), go to Project > Set Active Build Configuration > Release and it should start working.

  3. #3
    CarFrontEnd Creator iamgnat's Avatar
    Join Date
    Jul 2004
    Location
    NoVA
    Posts
    867
    You might also check your logs (Applications -> Utilities -> Console). Typically if something is crashing you'll see something in either the console or system logs.

    I know the above suggestion is important for a Obj-C (and I assume Java) app, but I don't know about AS though it couldn't hurt.

    Also make sure that the Serial and OSAX extentions are installed in the same place as your build machine (though Release vs Debug usually takes care of that kind of thing).

    -dave

  4. #4
    Low Bitrate
    Join Date
    Jul 2005
    Location
    Atlanta
    Posts
    68
    It does happen with AS... I first encountered it with an Applescript frontend I was working on a while ago. It's not exactly a cure-all, but it could definitely help.

  5. #5
    QCar Creator Jirka Jirout's Avatar
    Join Date
    Jul 2005
    Location
    Netherlands
    Posts
    590
    Quote Originally Posted by Mahalis
    I've run into this before - an app will work fine on the machine it's compiled on but not on anything else. In XCode (I'm assuming that's what you're using), go to Project > Set Active Build Configuration > Release and it should start working.
    Exactly. Just for info: the actual reason the application does not run is the ZeroLink, which is disabled in Deployment/Release build style but enabled in Development/Debug. Without many details: ZeroLink is the feature that allows you to modify the application while it is running.

  6. #6
    Admin. Linux loser.
    Auto Apps:loading...
    Bugbyte's Avatar
    Join Date
    Sep 2004
    Location
    Corning, NY
    Posts
    7,359
    Blog Entries
    2
    Ah! Okay, that worked. I still have to have the scripting additions in the right place or it doesn't work -unfortunate.

    At least I can try it out, though. Thanks for the info!
    Quote Originally Posted by ghettocruzer View Post
    I was gung ho on building a PC [until] just recently. However, between my new phone having internet and GPS and all...and this kit...Im starting to have trouble justfiying it haha.
    Want to:
    -Find out about the new iBug iPad install?
    -Find out about carPC's in just 5 minutes? View the Car PC 101 video

Similar Threads

  1. Mini Mac 4 Porsche 944
    By 4thChild in forum MacCar
    Replies: 14
    Last Post: 03-13-2009, 11:16 PM
  2. VW Golf IV - Mac Mini install
    By Fuse314 in forum Worklogs
    Replies: 12
    Last Post: 02-24-2008, 05:25 PM
  3. MOtorized LCD that flips down?
    By AdamChrap in forum LCD/Display
    Replies: 27
    Last Post: 02-01-2006, 11:16 PM
  4. PLEASE answer this question for me Re: GPS button
    By Sonicxtacy02 in forum FrodoPlayer
    Replies: 8
    Last Post: 12-25-2004, 04:49 PM
  5. quick lcd question! anyone whos done one knows the answer!
    By minnow255 in forum General Hardware Discussion
    Replies: 2
    Last Post: 09-12-2000, 05:31 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •