Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Font Tahoma not found

  1. #11
    toc
    toc is offline
    Newbie
    Join Date
    Mar 2007
    Posts
    4

    How to Fix - Font Tahoma not found, and Vista!

    Hi all,

    I see a lot of peeps had this issue being a tech head I couldnt let it beat me on all my development PCs which include Visual studio and XP the program runs fine so I never needed a solution, then I brought a Vista laptop to trip to OZ and installed Mapmonkey as a back up to my GPS and bang!!! "Font Not Found!" - I can live with the error box, but none of the setting windows opened without crashing the program.... now I have no idea of the internals of font registering for the windows system but I tried every/all the steps of removing the font reinstalling the font... intalling an old font.. vista one is twice as large as my xp ones 600k instread of 300k... blah blah... and the same errors.

    It annoyed me so much it was time for a little reverse engineering...

    How to Fix Missing Font Error.

    1) If you haven't already edit with notepad the 'c:\DestinatorApps\Destinator\Common\Interface\Vis ual\All\Destinator.inf'
    there may be 2 referances to "Tahoma" in there do a find and replace "Tahoma" for "Arial" and save it, this will remove 2 font errors.

    2) the other reference to "Tahoma" as already stated is in the 'DestDLL.dll' so this is a little more tricky to change this one... make a back up of this before you start playing.

    Using a Hex Editor open the 'DestDLL.dll'
    Goto Address 000092A26 which should read 'PUSH 01012A608' or in Hex '6808A61210' <- Tahoma Font call
    Change the Hex to '68584F1210' <- which will call for the 'Arial' font instead.
    Save the file and your done.

    No more Font errors, also you may have to check your skin isnt calling the font but I dont change those.

    This allows Map Monkey and Destinator 3 SDK to work fine on VISTA!!!! hurray! Job done.

    I know this sounds a little complicated but its pretty straight forward as long as you know how to use a hex editor, alternitvely I could create a patch to do the work for you and this would NOT contain any copyright material, admins just let me know.

    Hope this helps.

  2. #12
    Maximum Bitrate wizz's Avatar
    Join Date
    Nov 2004
    Location
    Leicestershire UK
    Posts
    652
    Quote Originally Posted by toc View Post
    Hi all,

    I see a lot of peeps had this issue being a tech head I couldnt let it beat me on all my development PCs which include Visual studio and XP the program runs fine so I never needed a solution, then I brought a Vista laptop to trip to OZ and installed Mapmonkey as a back up to my GPS and bang!!! "Font Not Found!" - I can live with the error box, but none of the setting windows opened without crashing the program.... now I have no idea of the internals of font registering for the windows system but I tried every/all the steps of removing the font reinstalling the font... intalling an old font.. vista one is twice as large as my xp ones 600k instread of 300k... blah blah... and the same errors.

    It annoyed me so much it was time for a little reverse engineering...

    How to Fix Missing Font Error.

    1) If you haven't already edit with notepad the 'c:\DestinatorApps\Destinator\Common\Interface\Vis ual\All\Destinator.inf'
    there may be 2 referances to "Tahoma" in there do a find and replace "Tahoma" for "Arial" and save it, this will remove 2 font errors.

    2) the other reference to "Tahoma" as already stated is in the 'DestDLL.dll' so this is a little more tricky to change this one... make a back up of this before you start playing.

    Using a Hex Editor open the 'DestDLL.dll'
    Goto Address 000092A26 which should read 'PUSH 01012A608' or in Hex '6808A61210' <- Tahoma Font call
    Change the Hex to '68584F1210' <- which will call for the 'Arial' font instead.
    Save the file and your done.

    No more Font errors, also you may have to check your skin isnt calling the font but I dont change those.

    This allows Map Monkey and Destinator 3 SDK to work fine on VISTA!!!! hurray! Job done.

    I know this sounds a little complicated but its pretty straight forward as long as you know how to use a hex editor, alternitvely I could create a patch to do the work for you and this would NOT contain any copyright material, admins just let me know.

    Hope this helps.
    I'm running RR/MM on my Vista desktop and get this problem too (no trouble in the car with XP Pro).
    I got as far as "Goto Address 000092A26" but my Hex editor is saying "no such address", so perhaps a patch might be in order.
    Car : Ford Focus Zetec S 1800cc
    Carpc :Galaxy GT-P1000 Original 7in Tab
    Mounted in "On Dash" Custom Install

  3. #13
    Maximum Bitrate wizz's Avatar
    Join Date
    Nov 2004
    Location
    Leicestershire UK
    Posts
    652
    Bump !
    Car : Ford Focus Zetec S 1800cc
    Carpc :Galaxy GT-P1000 Original 7in Tab
    Mounted in "On Dash" Custom Install

  4. #14
    toc
    toc is offline
    Newbie
    Join Date
    Mar 2007
    Posts
    4

    Patch

    sounds as if you need to check offset or how the hex editor is reading the address search for 68584F1210 may help... 1 sec ill make a patch.

    ok done, heres a patch, the CRC32 check will have to validate your using the correct DestDLL.dll to work.

    dont forget to remove the font from the .inf, all above.


    http://www.sendspace.com/file/wwhyoj

    ^ patch for 'Tahoma Font Missing' error.

    Good luck.

  5. #15
    Maximum Bitrate wizz's Avatar
    Join Date
    Nov 2004
    Location
    Leicestershire UK
    Posts
    652
    Quote Originally Posted by toc View Post
    sounds as if you need to check offset or how the hex editor is reading the address search for 68584F1210 may help... 1 sec ill make a patch.

    ok done, heres a patch, the CRC32 check will have to validate your using the correct DestDLL.dll to work.

    dont forget to remove the font from the .inf, all above.


    http://www.sendspace.com/file/wwhyoj

    ^ patch for 'Tahoma Font Missing' error.

    Good luck.
    Still in trouble, your patch is telling me I have the wrong version of DestDLL.dll. I've PM'd you
    Car : Ford Focus Zetec S 1800cc
    Carpc :Galaxy GT-P1000 Original 7in Tab
    Mounted in "On Dash" Custom Install

  6. #16
    toc
    toc is offline
    Newbie
    Join Date
    Mar 2007
    Posts
    4

    Hex Editing

    Wizz, you obviously have a differnt version of DestDLL.dll

    Im not about to write a tut on hex editing or even asm, 000092A26 is the ofset of where the font is called, If yours is a differnt file then it wont be in the same place, this said you will have to do a search for 'PUSH 01012A608' or 6808A61210 any string reference to the Tahmon Font and replace it with the same call for the Arial Font also found in the .dll

  7. #17
    Newbie
    Join Date
    Jul 2007
    Posts
    2

    what disasm

    hopefully its free but what hexedite /dissasembler r u using

    Thanks Paul

  8. #18
    Newbie
    Join Date
    Jul 2007
    Posts
    2
    Quote Originally Posted by toc View Post
    sounds as if you need to check offset or how the hex editor is reading the address search for 68584F1210 may help... 1 sec ill make a patch.

    ok done, heres a patch, the CRC32 check will have to validate your using the correct DestDLL.dll to work.

    dont forget to remove the font from the .inf, all above.


    http://www.sendspace.com/file/wwhyoj

    ^ patch for 'Tahoma Font Missing' error.

    Good luck.
    not on the server anymore. Any chance of a new download for version 1.0.0.1

    Thanks Paul

  9. #19
    Newbie
    Join Date
    Dec 2008
    Posts
    4

    Question Help!

    Replacing tahoma eliminates all font problems yes!.... Program still very unstable on vista though crashing every 2 minutes or so...

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Headunit (Linux/Windows CarPC frontend) + initial screenshots
    By NoPistonPC in forum Other Cool Front Ends
    Replies: 321
    Last Post: 08-24-2007, 02:57 PM
  2. Bug Reports
    By frodobaggins in forum FrodoPlayer
    Replies: 168
    Last Post: 10-16-2004, 12:25 AM
  3. Font colors in Frodoplayer
    By sfay93 in forum FrodoPlayer
    Replies: 3
    Last Post: 06-12-2004, 02:19 AM
  4. font from logo?
    By doig in forum Off Topic
    Replies: 45
    Last Post: 04-17-2004, 03:55 PM
  5. changing font size of file names in Windows Explorer?
    By Squeezer in forum General Hardware Discussion
    Replies: 4
    Last Post: 01-11-2001, 04:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •