Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: I need beta testers for Version 176

  1. #1
    Maximum Bitrate CarComp's Avatar
    Join Date
    Oct 2001
    Location
    Indiana
    Posts
    515

    I need beta testers for Version 176

    Version 176 is available for download / trial. I am experimenting in this version. Mostly "behind the scenes" stuff like advanced error handling and logging, better remote support, and just better stability. But alas, even though, this version will probably cause a few headaches.

    A few guidlines...

    MediaEngine runs best below 1024x768. I had not anticipated some of you running it at some crazy 100000x100000 pixels.

    Make sure you uninstall and DELETE your old M.E. directory from the hard drive. If not, the settings from the old version will try to load in the new version.

    Before you say "my divx movies do this..." make sure to put a .divx at the end of the filename. I need to fix this, have tried, but failed. Not all divx movies are created equal. In the eyes of MediaEngine, this equalizes them.

    If you are using the RF MediaRemote from carplayer, you must set it up initially in Media Engine setup screen, then exit the program, then run the program to initialize the remote. It will work from then on.

    The movie screen does not do standard widescreen / tv modes. It just fills the screen with the movie. If anyone knows how to fix this, let me know. Detecting movie dimensions is something I have not tried.

    If all else fails, email your debug.log to me at [email protected] and explain the problem. You will get a faster response from me than just posting the problem here.

    -CarComp

    Media Engine 1.7.6 beta with CarPlayer RF Remote support
    Get MediaEngine !!!
    Media Engine Download

  2. #2
    Constant Bitrate
    Join Date
    Sep 2002
    Location
    Melbourne, Australia
    Posts
    114
    mate i had a look at your code you're doing the video type identifying thing all wrong

    ok at the start of a video file..... somewhere near the start i dunno EXACTLY where but im sure it's a logical spot like after bytes xxx or at position xx.....

    anyway there is a 4 character code to identify the codec used.... so for divx 4 it is "DIV4" you need to identify where this code will always appear.... must be constant coz im sure this is how media player does it! then have a switch on the variable.....

    ever notice how you can call a divx file .mpeg and media player will still play it? smart programming

    well i can't help you anymore at the moment because im not sure what the constant thing is i'd have to search around or compare multiple divx/mpeg/etc files and have a look but that should point you in the right direction

    you want some help?

  3. #3
    I'm sorry, and you are....? frodobaggins's Avatar
    Join Date
    Jan 2003
    Location
    Ruston, LA
    Posts
    8,846
    They are called fourcc codes.

    Here you go,

    http://www.fourcc.org/

    also google "fourcc" A wealth of info comes up, even programming examples

  4. #4
    Maximum Bitrate CarComp's Avatar
    Join Date
    Oct 2001
    Location
    Indiana
    Posts
    515
    Yes I would love to have some help on this. Right now at the moment, I am trying to "debug" all the code. This includes what you meantioned above, plus any other problems that need to be fixed. I want to have the most stable / reliable platform to operate in a vehicle. So I am understanding that you will be able to make media engine detect the FOURCC code in a video format, and play with the correct codec.

    If you want to drop me an email at [email protected] we can switch files that way.

    -CarComp
    Get MediaEngine !!!
    Media Engine Download

  5. #5

  6. #6
    Maximum Bitrate CarComp's Avatar
    Join Date
    Oct 2001
    Location
    Indiana
    Posts
    515
    Get MediaEngine !!!
    Media Engine Download

  7. #7
    I'm sorry, and you are....? frodobaggins's Avatar
    Join Date
    Jan 2003
    Location
    Ruston, LA
    Posts
    8,846
    I'm glad we could help, wish I could help with the programming, but I'm not yet familiar with VB. Class starts in two weeks though

    My Visual Studio.Net will be here soon too.

    Frodo

  8. #8
    Variable Bitrate
    Join Date
    Mar 2002
    Location
    Long Island, NY
    Posts
    334
    I've been testin the software out a little here and there (.76) and the one bug I notice right away is if Im playing music or a video and hit esc to get back to the main menu, the menu is chopped in half...that is, it fills the left side of the screen and squeezes it in tight, leaving blackness on the right side. This has happened in prior versions before, and you've always fixed it, so Im guessin it's a line of code or two

    I'll have more as I go, but thats what I noticed at first, i'll keep ya posted.

    Grand AMplifier Project 1.0:
    http://drive.to/cliffsgrandamgt/
    http://www.astallaslions.com/carmp3/
    --------------------------------
    -Eden 800 mini-itx motherboard
    -5.6 NTSC TFT-LCD
    -80 gig hard drive
    -128 MB RAM
    -MPBS1 DC-DC PSU
    -PB Remote /w Girder
    -Media Engine & Windows XP
    -Playstation II also added
    -Steering Wheel Buttons modified for Control.


  9. #9
    Raw Wave hijinks21's Avatar
    Join Date
    May 2002
    Location
    Albany, NY
    Posts
    1,803
    Originally posted by Cliff
    I've been testin the software out a little here and there (.76) and the one bug I notice right away is if Im playing music or a video and hit esc to get back to the main menu, the menu is chopped in half...that is, it fills the left side of the screen and squeezes it in tight, leaving blackness on the right side. This has happened in prior versions before, and you've always fixed it, so Im guessin it's a line of code or two

    I'll have more as I go, but thats what I noticed at first, i'll keep ya posted.
    I've only had that problem when i tested it in res above 1024x768.. anything below that was fine for me.
    '98 Explorer Sport
    http://mp3car.zcentric.com (down atm)
    AMD 800mhz 192megs RAM 60gig hard drive 9 inch widescreen VGA
    80% done

  10. #10
    Maximum Bitrate CarComp's Avatar
    Join Date
    Oct 2001
    Location
    Indiana
    Posts
    515
    Ya that is a limitation. The way media engine calculates its percentage based skin system only allows me to successfully support up to 1024x768.

    I didn't think anyone would even get close to that res in a car though, so I didn't make it an issue.


    As for the 1/2 screen errors, I noticed that too. It usually happens to me only when something changes the screens resolution (winamp visuals like to do this). Were you having a res switch in there somewhere Cliff?

    Thanks for the report. Thats good news for me that there were no fatal errors. My goal here is to be able to survive errors that occur. If that is possible, then I should be able to work out the errors completely. Fatal errors that crash the program are bad.

    Get MediaEngine !!!
    Media Engine Download

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •