Results 1 to 3 of 3

Thread: Taking bugfix requests for 2.3.7

  1. #1
    Maximum Bitrate phat_bastard's Avatar
    Join Date
    Sep 2002
    Location
    St.Louis, MO
    Posts
    549

    Taking bugfix requests for 2.3.7

    I'm opening up a 2.3.7 branch to fix some bugs in the video player that have been, well, bugging me for a while.

    Post your bugfix requests in this thread. I'm not looking to do any major overhauls, so keep any feature requests simplistic and even then don't get your hopes up. If I get really bored I may attempt to port radio tuner control to Radiator.

    Bugfix requests should be accompanied by your settings.ini file, a copy of debug.log and clear, concise instructions for reproducing the error. Please trim down your debug.log posts / uploads so they only contain relevant information.
    '01 Chevy Xtreme Stepside (pics)

    FIC K7MNF-64 / Athlon 3200 | 256 DDR | 120 GB 7.2k WD
    WinXP Pro | MediaEngine | 12.1 VGA TFT Touch|Creative CIMR-100
    350w Vector | 320w mATX PS | Hellroaring BIC95150 | ButterflySDC

  2. #2
    Newbie
    Join Date
    Jul 2005
    Location
    Queens, NY
    Posts
    30
    Phat, is it possible to show the Artist/Track text bigger and possibly even scroll while listening to audio while in the Nav screen? the text is very small and sometimes impossible to read.

    Sometimes, when I have shuffle turned on, and go to the music menu from the home screen, it can take altmost 20 seconds of showing the load screen before the music screen comes on and the music starts playing. Sometimes it takes less time so I don't think this is so much a bug as it is a little annoying. Not a big deal if there is too much coding to be done.

    These last two are feature requests rather than bugfix requests but I'll post 'em anyway.

    Since you are working on the video player, would you be able to put a progress bar so that it is clickable to go to that part of the video? also a small time counter somewhere in the auto-hide menu?

    This last request might be of interest to others as well. Would you be able to put an option in the setup menu to have the nav program load up in the background as ME is loading? or maybe just after ME has finished loading and starts up without seeing it so that it is immediately available without having to watch the nav prog load and acquire location.

    Thanks Phat if you are able to get to any of these.
    '99 Volvo S80
    Carputer install progress: ++++++++--- (80%)

  3. #3
    Maximum Bitrate phat_bastard's Avatar
    Join Date
    Sep 2002
    Location
    St.Louis, MO
    Posts
    549
    Quote Originally Posted by Leli001 View Post
    is it possible to show the Artist/Track text bigger and possibly even scroll while listening to audio while in the Nav screen? the text is very small and sometimes impossible to read.
    I believe this is something that can be adjusted in the skin, but not sure... I will try to look into it.

    Quote Originally Posted by Leli001 View Post
    Sometimes, when I have shuffle turned on, and go to the music menu from the home screen, it can take altmost 20 seconds of showing the load screen before the music screen comes on ...
    I have a hard time tracing down bugs when the description begins with the conditional "sometimes". What do you say we revisit this when you can reproduce it all of the time?

    Quote Originally Posted by Leli001 View Post
    These last two are feature requests rather than bugfix requests
    So far the "Sometimes" issue is the only one that sounds like it may be a bug. When I say bug I mean error in programming.

    Quote Originally Posted by Leli001 View Post
    Since you are working on the video player, would you be able to put a progress bar so that it is clickable to go to that part of the video? also a small time counter somewhere in the auto-hide menu?
    I'll see what I can do on these since they're both items I would also like to see and at least the slider has been requested numerous times. Unfortunately the position slider will be a chore.

    Quote Originally Posted by Leli001 View Post
    This last request might be of interest to others as well. Would you be able to put an option in the setup menu to have the nav program load up in the background as ME is loading? or maybe just after ME has finished loading and starts up without seeing it so that it is immediately available without having to watch the nav prog load and acquire location.
    This one I will have to relegate to the "I wouldn't touch it with a 10 foot pole" area. There are way too many variables to deal with when trying to load an application and find it's main window handle while preventing it from showing or stealing focus from the host application. I wish I could improve this, but it's one of those things that I'd rather see get re-coded from scratch and I'm not volunteering to be that mule. If MediaEngine only supported one GPS app this would be remotely possible, but unfortunately this is price you pay for flexibility. Sorry!
    '01 Chevy Xtreme Stepside (pics)

    FIC K7MNF-64 / Athlon 3200 | 256 DDR | 120 GB 7.2k WD
    WinXP Pro | MediaEngine | 12.1 VGA TFT Touch|Creative CIMR-100
    350w Vector | 320w mATX PS | Hellroaring BIC95150 | ButterflySDC

Similar Threads

  1. New Skin *** Taking Requests ***
    By mbkowns in forum RR Skins
    Replies: 1
    Last Post: 04-24-2005, 11:28 PM
  2. Updated Bugs and Requests thread
    By GReeToZ in forum Centrafuse
    Replies: 8
    Last Post: 03-02-2005, 02:28 AM
  3. I'm taking a break
    By febsperanza in forum FrodoPlayer
    Replies: 14
    Last Post: 02-01-2005, 04:26 PM
  4. D3 Front End: Enhancements/Feature Requests
    By Dominik in forum Map Monkey
    Replies: 179
    Last Post: 12-28-2004, 03:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •