Page 7 of 8 FirstFirst 12345678 LastLast
Results 61 to 70 of 76

Thread: routis splash/startup screen

  1. #61
    I'm sorry, and you are....? frodobaggins's Avatar
    Join Date
    Jan 2003
    Location
    Ruston, LA
    Posts
    8,846
    Quote Originally Posted by MatrixPC
    Question for Fodo. How did you get the Warning window to close? I try to use Postmessage/SendMessage with WM_SETKEY/WM_SETHOTKEY but doesn't work and yet I did get the correct hwnd for the Warning window. Currently SendKey function works fine for me but like you said, it's dangerous if the window out of focus.
    I also have the same problem closing Winamp's video windows.
    Here is the source code for Routis Launcher.
    It is kind of dirty because I didn't have time to clean it up.

    Frodo
    Attached Files Attached Files
    [H]4 Life
    My next generation Front End is right on schedule.
    It will be done sometime in the next generation.
    I'm a lesbian too.
    I am for hire!

  2. #62
    Low Bitrate savante's Avatar
    Join Date
    Jul 2004
    Location
    Chicago
    Posts
    101
    Quote Originally Posted by frodobaggins
    If you can find out the classname and windowname I can add support.
    Frodo,
    I finally got around to using Spy++ to try and get this info for you...
    This is what I have obtained for the splash window in iGuidance 2.0:

    Handle: 0008021E
    Caption:
    Class: #32770 (Dialog)

    This is what I have obtained for the 'Ok' button:

    Handle: 00060220
    Caption: OK
    Class: Button

    Im not sure this helps because the actual window doesnt have a name/caption but if there is any other way of getting you info let me know. That iGuidance 2.0 splash screen is really annoying.

    EDIT: I guess the Handle changes all the time depending on whats running in memory. So I dont know how helpful any of this information is other than the class.

  3. #63
    Variable Bitrate rgardjr's Avatar
    Join Date
    Oct 2003
    Posts
    374
    Well here is a little script that I wrote using AutoIt V3. It will launch Iguidance installed to default directory on c:\ drive and wait 2 seconds and send and enter. May work for some of you Iguidance users.
    Attached Files Attached Files

  4. #64
    Maximum Bitrate wysocki's Avatar
    Join Date
    Mar 2004
    Location
    Los Angeles Area
    Posts
    467
    I can't get routislauncher to work right even when I include lmf.
    The following setup will kill the warning screen but then routis is not "embedded" in MC and still shows its own title bar and controls. It works fine when I just launch routis from the MC setup but I want to get rid of the warning. What am I doing wrong here?

    In MediaCar Setup:
    External GPS Software Path: C:\Program Files\Mediacar\Routis\lmf.exe
    Run Embedded: CHECKED
    Search String: *routis*

    In folder C:\Program Files\Mediacar\Routis:
    lmf.exe
    lmf.ini (which contains the following 3 lines):
    [MAIN]
    COMMANDLINE=C:\Program Files\Deluo\Routis\routislauncher.exe
    UNLOAD=TRUE

    In folder C:\Program Files\Deluo\Routis:
    routis.exe
    routislauncher.exe
    routislauncher.ini (which contains the following 3 lines):
    [MAIN]
    PATH=C:\Program Files\Deluo\Routis\routis.exe
    DELAY=2

  5. #65
    Jesus Freak antimatter's Avatar
    Join Date
    Jan 2004
    Location
    California
    Posts
    4,545
    Yea it won't work with my darn Iguidance 2.0 (frodo's that is)

    Anyone wanna have a crack at the source code to make it work
    -Jesus- King of Kings Lord of Lords

  6. #66
    Low Bitrate
    Join Date
    May 2004
    Posts
    73
    In MediaCar Setup:
    External GPS Software Path: C:\Program Files\Mediacar\Routis\lmf.exe
    Run Embedded: Check
    Search String: Routis

    remove the ** and cap the R .... like above

  7. #67
    Maximum Bitrate wysocki's Avatar
    Join Date
    Mar 2004
    Location
    Los Angeles Area
    Posts
    467
    mdrt4me, you are da man! Thanks!

  8. #68
    Low Bitrate
    Join Date
    Mar 2004
    Location
    Marietta, GA
    Posts
    62
    Quote Originally Posted by rgardjr
    Well here is a little script that I wrote using AutoIt V3. It will launch Iguidance installed to default directory on c:\ drive and wait 2 seconds and send and enter. May work for some of you Iguidance users.
    I got IGuidance 2.0 to work embeded without the plash screen!
    Thanks to the abouve software from rgardjr

    This is what I did:
    1. Changed the file name of "iguidance.exe" from the zip file and called it "iguide.exe"

    2. Placed the new "iguide.exe" file in the same folder as the original "iguidance.exe" ( My software in installed in the default C: drive path -- "C:\Program Files\iNav\iGuidance" )

    3. Entered MediaCar setup and changed GPS Settings to the following:
    GPS Port: 6 (Enter your own)
    GPS Software: EXTERNAL
    MAPPOINT VERSION: None
    EXTERNAL GPS SOFTWARE:
    PATH: C:\Program Files\iNav\iGuidance\iGuide.exe
    RUN EMBEDED: CHECKED
    WINDOW SEARCH TIME OUT: 5
    ADDITIONAL WINDOW SEARCH STRING: iGuidance

    Thats all folks! - Worked like a charm first try!

    Again, Thanks a LOT to rgardjr for his program!

    -LekanB

  9. #69
    Low Bitrate
    Join Date
    May 2004
    Posts
    73
    Quote Originally Posted by wysocki
    mdrt4me, you are da man! Thanks!

    No problem... Had to figure it out by trial and error when Frodo first release LMF...

  10. #70
    Constant Bitrate
    Join Date
    Jul 2004
    Posts
    165
    Quote Originally Posted by LekanB
    I got IGuidance 2.0 to work embeded without the plash screen!
    Thanks to the abouve software from rgardjr

    This is what I did:
    1. Changed the file name of "iguidance.exe" from the zip file and called it "iguide.exe"

    2. Placed the new "iguide.exe" file in the same folder as the original "iguidance.exe" ( My software in installed in the default C: drive path -- "C:\Program Files\iNav\iGuidance" )

    3. Entered MediaCar setup and changed GPS Settings to the following:
    GPS Port: 6 (Enter your own)
    GPS Software: EXTERNAL
    MAPPOINT VERSION: None
    EXTERNAL GPS SOFTWARE:
    PATH: C:\Program Files\iNav\iGuidance\iGuide.exe
    RUN EMBEDED: CHECKED
    WINDOW SEARCH TIME OUT: 5
    ADDITIONAL WINDOW SEARCH STRING: iGuidance

    Thats all folks! - Worked like a charm first try!

    Again, Thanks a LOT to rgardjr for his program!

    -LekanB
    Worked like a charm for me. Thanks for the detailed instructions.

Page 7 of 8 FirstFirst 12345678 LastLast

Similar Threads

  1. What the....same screen? Good screen?
    By Seabass in forum General Hardware Discussion
    Replies: 4
    Last Post: 03-30-2004, 11:37 PM
  2. Working out the bigs with MC and Routis
    By shakes in forum MediaCar
    Replies: 10
    Last Post: 03-26-2004, 01:31 PM
  3. BMW pre-installed system - TFT ?
    By tsingsu in forum LCD/Display
    Replies: 11
    Last Post: 08-05-2002, 02:16 AM
  4. NEC Versa M/75 Laptop TFT screen w/touch
    By Macgyver777 in forum LCD/Display
    Replies: 23
    Last Post: 03-24-2002, 02:14 AM
  5. Laptop/LCD screen hookup...
    By UrbanTacticz in forum LCD/Display
    Replies: 1
    Last Post: 11-28-2001, 05:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •