Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Getting my Touch Screen to work

  1. #1
    Newbie
    Join Date
    Feb 2010
    Posts
    40

    Getting my Touch Screen to work

    I had Ubuntu 10.10 installed. I have now installed Meego.
    Everything installed nicely.

    Now I am trying to get my touchscreen working. I am using TouchKit.
    I followed the install instructions and it appeared to install fine, it said the controller was present and it found the xorg file, after a reboot the instructions say to then run the TouchKit Calibration tool, which I have done, but I keep getting the same error:

    No Touch Controller Found


    This confuses me, because during the install it said the controller was present.

    Anyone have any ideas why this is happening.

  2. #2
    Newbie
    Join Date
    Jan 2008
    Location
    San Francisco
    Posts
    10
    I has the same issue with Linuxice. Egalax had some issues. I kept running the application (3-4) times until the window appeared where you can run the calibration software.
    You are lucky. I am running LinuxIce with BlackSea skin. everything works great but nghost don't see the media files, no matter what i do.
    So i tried to install Meego. It goes as far as "select drive to boot from", but there are no drives listed. linuxice had no issues finding it.
    Scratching my head.
    Sunil

  3. #3
    Newbie
    Join Date
    Feb 2010
    Posts
    40
    I guess not a lot of people are using Meego ?

    The Meego OS looks great and boots amazingly fast, 17 seconds from a cold boot to the OS up and running.
    But unless I get my touch screen working, it will be a waste of time.

    ---------- Post added at 03:48 PM ---------- Previous post was at 02:26 PM ----------

    After double checking the install files, I looked in the xorg.conf file. I edited the file and deleted everything, so it was an empty file. I then ran the installer for the driver again.
    Rebooted and ran the TouchKit command from terminal, but still got the same error.
    I then looked again to make sure all the files were there, I remembered seeing this line in the xorg.conf file.

    Option "Parameters" "/var/lib/TouchKit.param"

    So I looked in the folder /var/lib/ and there was no file or folder called TouchKit.param ???

    I assume it should exist, could this be the problem ??

  4. #4
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    don't use touchkit. download the latest meego image (1.1.90+) and your touchscreen should work out of the box (assuming it's egalax). If it requires calibration, use xinput2_calibrator to calibrate it. The touchkit drivers are next to garbage.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  5. #5
    Newbie
    Join Date
    Feb 2010
    Posts
    40
    I am using the in car pc version, my touch screen never worked after the install.

    How do I use xinput2_calibrator ?
    What is the terminal code ?

  6. #6
    Newbie
    Join Date
    Feb 2010
    Posts
    40
    Well you say don't use TouchKit, but the built in touch screen function does NOT work and I have no clue how to make it work. I can find nothing on the internet to help, except to ask here, but I'm getting no where.

    I think I have figured out the problem with TouchKit. I am using Xorg version 1.9 and TouchKit only goes to 1.7 so the driver most likely will not work.

  7. #7
    Maximum Bitrate nasa's Avatar
    Join Date
    Aug 2006
    Location
    PA
    Posts
    696
    pod25music,

    1st off Meego is still in development -- so all the long term functionality isn't there and the versions produced are aimed at specific platforms, which may not be yours. That said, I have gotten the touchscreen to work (mostly out of the box) by removing a file in the /etc/x11/xorg.conf.d/ folder. The named file is something like tsec.conf (don't quote my I removed it :} ). There should not be any xorg.conf file. All the configurations happen in conf files in the /etc/x11/xorg.conf.d directory. Please don't use the versions of meego from http://repo.meego.com/MeeGo/builds/1.1.90/ or http://repo.meego.com/MeeGo/builds/1.1.80/ as a new bug has been introduced with the integration of XInput2 and evtouch (the touchscreen driver being used). See this bug report... https://bugs.meego.com/show_bug.cgi?id=12777 . If you want to try a relatively recent meego effort, you'll have to look for the archives (the repos are only keeping like the last 5 most recent versions). Which I have to look through my emails to find where that's located.

    The file I remove is tsc2007.conf...
    Last edited by nasa; 02-22-2011 at 09:30 AM.

  8. #8
    Newbie
    Join Date
    Feb 2010
    Posts
    40
    Thanks nasa.

    I like the look of Meego and it would be a shame to dump it because of my touch screen not working, but having touch screen functionality in a car pc is a must.

    I still have no idea how to use the built in touch function of meego. I have found several folders and files relating to touch in the meego folder structure.

    I have since tried using the eGalax driver, as that supports xorg 1.9, but I still can't get my touch to work.

    I should have also mentioned that I use the Intel Atom mini ITX board.

  9. #9
    Maximum Bitrate nasa's Avatar
    Join Date
    Aug 2006
    Location
    PA
    Posts
    696
    pod25music,

    Since I don't know what things you have installed, removed, touched... This is what I would suggest,

    1. download image from here: http://archive.meego.com/MeeGo/build...eego-ivi-ia32/ -- which should be old enough not to have the bug I mentioned.

    2. reinstall meego from scratch...

    3. Once you boot up into meego, ctrl-alt-f1 into a virtual window

    4. login in using root/meego

    5. rm /etc/X11/xorg.conf.d/tsc2007.conf

    6. reboot and see if you have a touchscreen.

    BTW: there is a video somewhere on here with me using meego via a touchscreen....

  10. #10
    Newbie
    Join Date
    Feb 2010
    Posts
    40
    OK, I shall do that now.

    And in my huge search of google trying to find answers, I came across your video.

    ---------- Post added at 03:28 PM ---------- Previous post was at 03:11 PM ----------

    Oh and nasa
    I don't suppose you know how to increase the text size in terminal ?
    Using a 7" screen and terminal makes the text size tiny and almost impossible to read.

    ---------- Post added at 04:46 PM ---------- Previous post was at 03:28 PM ----------

    nasa
    I made the bootable usb, exactly the same way as the first image.
    Booted the comp up and it booted into the meego screen, like before I went straight to install.

    It then gave error after error after error and would not install.
    And now it won't boot to the meego off the usb. I shall try creating the usb again.

Page 1 of 2 12 LastLast

Similar Threads

  1. played with services now touch screen doesnt work
    By ultrA_Cowboy in forum WinNT Based
    Replies: 3
    Last Post: 12-05-2006, 01:54 PM
  2. Replies: 4
    Last Post: 01-24-2006, 01:37 PM
  3. Replies: 3
    Last Post: 11-17-2004, 06:17 PM
  4. Touch screen add on for non touch screens, does it work well?
    By spinedoc in forum General Hardware Discussion
    Replies: 0
    Last Post: 11-06-2004, 02:50 PM
  5. lilliput touch screen Vs Xenarc 7" touch screen
    By Fear Effect in forum LCD/Display
    Replies: 2
    Last Post: 10-18-2004, 01:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •