Results 1 to 10 of 10

Thread: G4 motherboard upgrade?

  1. #1
    Maximum Bitrate
    Join Date
    Apr 2007
    Location
    USA
    Posts
    496

    Question G4 motherboard upgrade?

    Has anyone upgraded the G4 motherboard?

    I'd like to get a faster CPU, and have audio pre-outs.

    I guess my main concern is whether the touch-screen, screen tilt, radio, GPS, and hard buttons will still be able to work.

    I'd tear this thing up in a second if I knew it could work... It's amazing that Infill would spend all the time/money on this thing and nerf it with some idiotic design decisions.

  2. #2
    Variable Bitrate JasonMK's Avatar
    Join Date
    Jun 2007
    Location
    Annapolis, MD
    Posts
    406
    Quote Originally Posted by johnk View Post
    Has anyone upgraded the G4 motherboard?

    I'd like to get a faster CPU, and have audio pre-outs.

    I guess my main concern is whether the touch-screen, screen tilt, radio, GPS, and hard buttons will still be able to work.

    I'd tear this thing up in a second if I knew it could work... It's amazing that Infill would spend all the time/money on this thing and nerf it with some idiotic design decisions.

    The screen tilt, radio, GPS should work regardless. If you can find a board that fits that case I'd be eager to hear how it goes and might give it a shot myself.
    _______________________________________________
    All installed, and ready for visitors. Infill G4 in a 2007 Saturn VUE

  3. #3
    Maximum Bitrate
    Join Date
    Apr 2007
    Location
    USA
    Posts
    496
    Quote Originally Posted by JasonMK View Post
    The screen tilt, radio, GPS should work regardless. If you can find a board that fits that case I'd be eager to hear how it goes and might give it a shot myself.

    I don't see how they would work with a different motherboard, since they all seem to have proprietary connectors. The radio and GPS aren't that big a deal to me, since there are alternative connection options for those. But the screen connector (black/white cables on back of screen at top of photos) seems like a showstopper.

    It seems like it would be better to start from scratch. And since I already spent so much money on the G4, it will be a while before I do that. I've got the G4 back together and ready to go back in my car.

    (Sorry for the blurry photos; looks like my crappy digital camera doesn't do well up close.)
    Attached Images Attached Images    

  4. #4
    Registered User
    Join Date
    Jul 2007
    Posts
    1
    I know this is an old thread, but now the G4 has been around for a while just wanted to ask.

    Has anyone upgraded the motherboard and put a faster processor and graphics in?

    If so can you please post what you did and how well its working

    Many thanks

    James

  5. #5
    Variable Bitrate JasonMK's Avatar
    Join Date
    Jun 2007
    Location
    Annapolis, MD
    Posts
    406
    Quote Originally Posted by jdmagoo View Post
    I know this is an old thread, but now the G4 has been around for a while just wanted to ask.

    Has anyone upgraded the motherboard and put a faster processor and graphics in?

    If so can you please post what you did and how well its working

    Many thanks

    James
    The processor AND the video are both integrated into the board, which has a unique FPC connector for the LCD. So, in order to upgrade either you would need to start from scratch. Sorry. I'll buy anyone a beer if they can prove me wrong because my G4 won't start and this would be a great option to get it back in the car and on the road.
    _______________________________________________
    All installed, and ready for visitors. Infill G4 in a 2007 Saturn VUE

  6. #6
    Newbie
    Join Date
    Dec 2009
    Posts
    2

    Hi infill g4 stop working

    Any new from this tread? My g4 start work today and for no reason..... the rear camera still work but nothing also work.... tx Fabio

  7. #7
    Variable Bitrate JasonMK's Avatar
    Join Date
    Jun 2007
    Location
    Annapolis, MD
    Posts
    406
    Quote Originally Posted by biricchino77 View Post
    Any new from this tread? My g4 start work today and for no reason..... the rear camera still work but nothing also work.... tx Fabio
    Just read your other post, sorry no new news. At least, not from me. Please, if anyone else has figured out anything could you please post?

    Infill G4 not powering up but not booting up.
    _______________________________________________
    All installed, and ready for visitors. Infill G4 in a 2007 Saturn VUE

  8. #8
    Newbie
    Join Date
    Feb 2008
    Posts
    4

    another member in this club...

    Unfortunatelly last month I had the same problem. Working ok but suddenly Infill froze and after rebooting was showing the very known green hourglass. After opening and removing all parts the single defective parts was the battery (0,5V instead of 3V) so I solved the cause of loosing time I had before!

    It is not a hdd, battery and other ”simply” issues. The defective is more complex. My advice for those who own a functionally Infill G4 unit is to sell them as fast is possible... I have just bought a ”classic” mini-ITX mainboard because I was sick of the problems I had with G4. Unfortunatelly the new unit wasn't ready before G4

    I tried to accept the situation but I want to recover the touch screen. In this moment I identify some pins which allows me to use the screen for a video composite only. Of course I want to go further and to find the other pins for using as a VGA monitor and USB touch screen. I will keep in touch with this, of course in the time possibility.

  9. #9
    Variable Bitrate JasonMK's Avatar
    Join Date
    Jun 2007
    Location
    Annapolis, MD
    Posts
    406
    Quote Originally Posted by amedesign View Post
    I tried to accept the situation but I want to recover the touch screen. In this moment I identify some pins which allows me to use the screen for a video composite only. Of course I want to go further and to find the other pins for using as a VGA monitor and USB touch screen. I will keep in touch with this, of course in the time possibility.
    I too had thought about replacing the guts of the G4 with non-Infill parts, but was unable to figure out anything on how to use the screen (video or touch). If you would be so kind as to post WHAT you were able to solve and hopefully that will help someone else now or down the road.

    It does seem that it is the lower AMP board, not sure what and not sure how to fix it other than replacing it. I did find a company that can replace/repair that lower board for a reasonable price so that is what I am doing now. I just got an email saying they got it up and running, but they are trying to isolate the problem as well.

    If I learn anything you can be sure I'll post it here. I'm just glad I'll have my G4 back up and ruuning and installed in the next few days (well, plus shipping)
    _______________________________________________
    All installed, and ready for visitors. Infill G4 in a 2007 Saturn VUE

  10. #10
    Newbie
    Join Date
    Feb 2008
    Posts
    4
    Quote Originally Posted by JasonMK View Post
    I too had thought about replacing the guts of the G4 with non-Infill parts, but was unable to figure out anything on how to use the screen (video or touch). If you would be so kind as to post WHAT you were able to solve and hopefully that will help someone else now or down the road.
    The G4 is not working at all so I just wanted to use the screen panel for other purpose. Using a Voltmeter I identify some of the pins of the two connectors (one with 25 pins and one with 20 pins) between boards and touch screen panel. Viewing from the screen and numbering from left to right you have:

    upper board

    1. 0,44V could be related with VGA signals (need O-scope for that. Don't have)
    2. 0,44V could be related with VGA signals (need O-scope for that. Don't have)
    3. ground
    4. 0,44V could be related with VGA signals (need O-scope for that. Don't have)
    5. 0,44V could be related with VGA signals (need O-scope for that. Don't have)
    6. ground
    7. 0,44V could be related with VGA signals (need O-scope for that. Don't have)
    8. 0,44V could be related with VGA signals (need O-scope for that. Don't have)
    9. ground
    10. 0,44V could be related with VGA signals (need O-scope for that. Don't have)
    11. 0,44V could be related with VGA signals (need O-scope for that. Don't have)
    12. ground
    13. 0 V/5V the second value is when back gear is active. Seems to be output from screen panel (don't know exactly yet)as a "1" logic value
    14. 0,56V (don't know)
    15. ground
    16. (don't know)
    17. (don't know)
    18. ground
    19. ground
    20. Video IN

    All measurements were made with both connectors plugin. I have to remove wire by wire to see what are the necessary wires and if I have lucky and a lot of time hope to discover the minim schematics for screen panel to use for VGA. For video composite is clear despite I have to find the requested wire for power supply (which seems to be only 5V).


    lower board

    1. 5V trough 10k resistor. Input for a logical gate (don't know exactly yet)
    2. 5V trough 10k resistor. Input for a logical gate (don't know exactly yet)
    3. 5V trough 10k resistor. Input for a logical gate (don't know exactly yet)
    4. 5V trough 10k resistor. Input for a logical gate (don't know exactly yet)
    5. 5V trough 10k resistor. Input for a logical gate (don't know exactly yet)
    6. ground
    7. 0 V/4,4V the second value is when back gear is active. Seems to be output from screen panel (don't know exactly yet)as a "1" logic value
    8. 0 V/ 2,26V the second value is when back gear is active. (don't know exactly yet)
    9. NC (not connected)
    10. 0 V/4,8V the second value is when back gear is active. Seems to be output from screen panel (don't know exactly yet)as a "1" logic value
    11. 0 V/4,8V the second value is when back gear is active. Seems to be output from screen panel (don't know exactly yet)as a "1" logic value
    12. NC
    13. 5V/2,3V the second value is when back gear is active. (don't know exactly yet)
    14. connected with 13
    15. ground
    16. +5V (power)
    17. +5V (power)
    18. ground
    19. 0 V/4,8V the second value is when back gear is active. Seems to be output from screen panel (don't know exactly yet)as a "1" logic value
    20. 0 V/4,8V the second value is when back gear is active. Seems to be output from screen panel (don't know exactly yet)as a "1" logic value
    21. 0 V/4,8V the second value is when back gear is active. Seems to be output from screen panel (don't know exactly yet)as a "1" logic value
    22. 0 V/4,8V the second value is when back gear is active. Seems to be output from screen panel (don't know exactly yet)as a "1" logic value
    23. ground
    24. +12V (back gear signal)
    25. +12V (back gear signal)

    regards,

    Marcel

Similar Threads

  1. M2-ATX with Intel Atom Motherboard Issues
    By jeremy480 in forum M2-ATX
    Replies: 12
    Last Post: 12-05-2010, 12:28 AM
  2. MTB-057 Intel D945GCLF Mini-ITX Motherboard OS Installation problems
    By Fiberoptic in forum MP3Car Products - store.mp3car.com
    Replies: 0
    Last Post: 07-08-2008, 01:50 PM
  3. Still Can't Get New Motherboard To Power Up
    By james33440 in forum General Hardware Discussion
    Replies: 8
    Last Post: 10-22-2005, 12:02 AM
  4. Build my PC?
    By diddy0071 in forum Newbie
    Replies: 9
    Last Post: 07-11-2005, 12:00 AM
  5. Which Motherboard to Choose
    By james33440 in forum General Hardware Discussion
    Replies: 3
    Last Post: 06-07-2005, 10:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •