Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Real solution to G4 GPS being detected by Windows as crazy serial mouse?

  1. #1
    Maximum Bitrate
    Join Date
    Apr 2007
    Location
    USA
    Posts
    496

    Question Real solution to G4 GPS being detected by Windows as crazy serial mouse?

    Has anyone else had their G4's GPS go haywire?

    A few weeks ago, my GPS spontaneously started being detected by Windows as a serial mouse. The mouse goes around the screen extremely fast and clicking everywhere (causes massive mayhem and makes the system completely unusable). The problem even occurs during Windows XP/Vista setup (the only time it doesn't happen is Safe Mode). It happens even if nothing is plugged in, including the GPS antenna (no connections other than power). After finally figuring out that it was being detected as a serial mouse (by turning off COM ports in the BIOS), I found a number of supposed solutions on the Internet. None of them helped:
    • Adding /noserialmice or /noserialmouse in c:\boot.ini (no effect).
    • Disabling the "serial mouse" in the device manager (stops the spastic mouse, but the GPS is not detected by Streetdeck or Centrafuse).
    • Disabling serial mouse detection by setting SkipEnumerations=FFFFFFFE in the registry under [HKLM\SYSTEM\CurrentControlSet\Enum\ACPI\PNP0501\Po rt#\Device Parameters] (stops the spastic mouse, but the GPS is not detected by Streetdeck or Centrafuse).

    At this point I have just disabled COM1 in the BIOS, and of course have no GPS capability. I am planning on buying a USB GPS, but have several questions:
    1. Has anyone else had this problem with the G4? If so, did you find a real solution to keep using the integrated GPS?
    2. Is there any way to keep using my existing GPS antenna? I'm thinking of a device that would accept my GPS antenna and then plug into a USB port. It just seems like a waste to throw out my current GPS antenna (and maybe worse, to have to rewire the new antenna).
    3. If I have to buy a USB GPS, are there any recommendations?

    Thanks,
    John

  2. #2
    Low Bitrate
    Join Date
    Apr 2007
    Posts
    62
    Are you using XPort. If so, it is reported:

    "Cursor sometimes jumps all over the screen clicking left/right? Here's the fix: Open Regedit. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\SerMouse, and change the value "Start" from 3 to 4. Reboot."

    http://curioustech.home.insightbb.com/xport.html

  3. #3
    Maximum Bitrate
    Join Date
    Apr 2007
    Location
    USA
    Posts
    496
    Thanks, but I'm not using XPort (or any other com port splitter).

    I got a USB GPS working (GlobalSat BU-353), but it kind of sucks because it takes about 2 minutes for it to initialize (at least by Centrafuse) after resuming the PC from a suspend state (my original one on a real COM port worked immediately).

  4. #4
    Low Bitrate
    Join Date
    Apr 2007
    Posts
    62
    I've to agree GlobalSat BU-353 took longer to initialised on my previous Hi-info N5 than the built-in gps with G4 which is pretty fast (if it resumes properly in my case . Not only that, Garmin nRoute and Mapking coordinates does not refresh fast enough to accomodate normal driving speed with GlobalSat BU-353 while G4 built-in GPS feeds Garmin Mobile PC almost instantaneously. Obviously it makes sense to stick to the built-in rather than the GlobalSat BU-353.

    I did encounter similar symptom as yours only once though after I recently updated XPort to the latest version. My first initial reaction was to check if the keyboard I stashed in the glove compartment was being accidently pressed but what appeared to be random clicks continue until I rebooted and have no such occurance since without further intervention nor did I need to do the fix I posted.

    Perhaps we may be able to offer some clues to help each other problems since yours resume fine while mine did not suddenly decide to become a mouse except once.

    Does your G4 shutdown itself when battery charge is low and does the GPS works after that? Or does the GPS resume from hibernation if you choose to hibernate?

  5. #5
    Maximum Bitrate
    Join Date
    Apr 2007
    Location
    USA
    Posts
    496
    My G4 shuts itself down after 12-15 hours in standby, which I think is earlier than it used to (even with a new battery). So just like you mentioned in your other thread, I try to remember to put it in hibernate on the weekend to avoid data loss. I don't think XP has a way of transitioning to hibernate like you asked; that is one feature of Vista I would really like (Sleep mode in Vista is like Standby, but it also makes a hibernation file so that it can resume from hibernation if power is lost).

    But I do not ever remember the built-in GPS failing to initialize after resuming from the suspend state (standby or hibernate).

    I've found that while sometimes it only takes about 20 seconds for the BU353 GPS to initialize in CF, it often takes a couple of minutes and sometimes never initializes. Restarting CF always makes it work, so I think it's a CF bug like discussed at http://forums.fluxmedia.net/gps/4645-bu353-cf.html.

    I am going to try several things (hopefully will have time sometimes this week):
    - Latest Prolific driver for the BU353 GPS: http://www.prolific.com.tw/eng/downloads.asp?ID=31
    - XPort
    - GPS Gate (http://franson.com/gpsgate)
    - Test the internal GPS again using the registry modification mentioned at http://curioustech.home.insightbb.com/xport.html:

    HKLM\SYSTEM\CurrentControlSet\Services\SerMouse\"S tart"=4


    Also you asked in your other post if the G4's GPS is possibly using USB. I don't think it is, since COM1 appears in the BIOS.

  6. #6
    What can I say? I like serial. Curiosity's Avatar
    Join Date
    Mar 2004
    Location
    Florence Yall, BFKY
    Posts
    2,684
    It sounds like you have more than one problem.

    The spaz-mouse is an easy fix though. The registry fix for SerMouse is the same as disabling MS BallPoint in Device Manager. Don't do any of those other things though, and keep COM1 enabled. You shouldn't have any more crazy mouse attacks.

    Not being detected may be software related or may not be. Setup XPort and when SD or CF can't detect the GPS, bring up XPort and look at the status bar to see if data is being received. If it is, then your GPS is working. If not... well, you can't easily unplug it can you? Not sure how to test that yet.

    Also, do you notice any difference when rebooting vs. hibernate/standby?

  7. #7
    Maximum Bitrate
    Join Date
    Apr 2007
    Location
    USA
    Posts
    496
    I tried the SerMouse registry hack as a last attempt to get the internal serial GPS working, and it did not help. It did prevent a serial mouse from being detected, and so the mouse pointer didn't go crazy, but it did not make CF detect a GPS on the COM port. So I guess that maybe the COM port got fried.

    I don't think I've seen a difference in standby vs hibernate.

    I installed the new Prolific USB-serial driver, and it made things worse. At first CF was still detecting the GPS after a couple of minutes, but it soon completely stopped working no matter how many times I rebooted or toggled the GPS settings in CF. (Yet it still worked in the GPS utility that came with the GPS, so I think it is a bug in CF.)

    The last thing I did today was to install Xport, and so far that has made it work for the 4-5 times I've put the PC into standby/suspend. It still takes about 40 seconds after resuming for the GPS to start working in CF, but it also takes about that long for it to resume working when I sleep the PC while the GPS utility is open (showing the raw data). I definitely appreciate the authors of XPort, but that is one of the most confusing UI's I've seen.

  8. #8
    What can I say? I like serial. Curiosity's Avatar
    Join Date
    Mar 2004
    Location
    Florence Yall, BFKY
    Posts
    2,684
    LOL Well, XPort might get easier use at some point from what I hear. The delays you're seeing now are pretty much expected. It takes some units 5 minutes to get a lock, so 40 seconds is pretty fast. You should uninstall that Prolific driver though. It's for a USB receiver that you don't have.

  9. #9
    Low Bitrate
    Join Date
    Apr 2007
    Posts
    62
    johnk, Curiosity is the programmer of XPort.

    Curiosity, even if you do not own a G4, I'm sure you've already helped a lot of grateful G4 users already. During the course of helping them, perhaps you may have got to know more about G4. Will you be able to advise if any of the devices listed in XPort is related to the G4 built-in GPS on com port 1 cos some of the devices has Infill names but I'm not sure what devices are those and if I should select them to resolve my own issue. Also, I only have the built-in GPS com port 1 not initializing properly out of hibernation but not out of resuming from sleep or cold boot. When it happens, XPort status bar will show weird characters rather than GPS coordinates. Not wanting to hijack johnk's thread, if you feel your answer does not help him, kindly reply in my thread.

  10. #10
    Low Bitrate
    Join Date
    Apr 2007
    Posts
    62
    johnk, did you ever tried uninstalling the com port 1? If so, what happens when you reboot? Does it automatically detects it again? Are there any drivers needed for the built-in GPS on com port 1? All the drivers & bios that can be found here I supposed are the latest outside of Korea but definately not the latest in Korea. It is a shame the official site is in Korean. I once tried to register but gave up when the registration form insist on certain fix address format Korean use.

Page 1 of 2 12 LastLast

Similar Threads

  1. garmin mapsource and usb gps mouse
    By thecrow in forum GPS
    Replies: 9
    Last Post: 09-26-2006, 02:24 PM
  2. Wtb: Gps Software And Gps Mouse!!!!
    By HitmanZ in forum Classified Archive
    Replies: 2
    Last Post: 08-03-2004, 09:56 PM
  3. New GPS Mouse and Routis
    By carpcnoobie in forum GPS
    Replies: 5
    Last Post: 06-04-2004, 06:17 AM
  4. Serial GPS
    By mespork in forum GPS
    Replies: 1
    Last Post: 05-08-2004, 12:31 AM
  5. gps mouse not detected...
    By kalito in forum MediaCar
    Replies: 8
    Last Post: 02-04-2004, 01:02 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •