Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 45

Thread: MDT-X7000 broke, out of nowhere.

  1. #21
    Low Bitrate vtecfelon23's Avatar
    Join Date
    Dec 2007
    Location
    Baltimore
    Posts
    82
    err... i have tested this item. To me, it does not seem worth the money, i had many issues with general operation and audio the GUI is disgusting, and yes it lags. I hate to knock the product, but it seems there is still a lot of work to be done.

  2. #22
    Evo
    Evo is offline
    Low Bitrate Evo's Avatar
    Join Date
    May 2005
    Location
    UK
    Posts
    87
    When did you have a unit for testing?; was it the very latest firmware as I believe shops are still waiting on stock. They have allegedly fixed the reported issues but I was hoping to find someone who had tried this latest firmware to confirm it.
    Life moves fast, so don't get left behind, buy a fast car!

  3. #23
    Newbie ryanruff's Avatar
    Join Date
    Dec 2005
    Location
    New York City
    Posts
    2
    I myself just yesterday encountered the failure to retract/extend problem. The monitor will periodically activate properly, but will no longer fully retract back into the dashboard. I am contacting Xenarc today.

    Other than that monstrous problem, it's the best monitor I've ever used.

    Speaking of this, does anyone know the unlock code for the Xenarc DVD? It says it's parental block (will curiously play Van Wilder, but not Animal House) and I can't figure out the freaking password!

  4. #24
    Evo
    Evo is offline
    Low Bitrate Evo's Avatar
    Join Date
    May 2005
    Location
    UK
    Posts
    87
    Latest I heard was that Xenarc has stopped shipping again as they have found another fault in the firmware; eta another 2-3 weeks before they ship.

    Lets hope this latest firmware will sort out the units issues.
    Life moves fast, so don't get left behind, buy a fast car!

  5. #25
    Newbie ryanruff's Avatar
    Join Date
    Dec 2005
    Location
    New York City
    Posts
    2
    I spoke to Xenarc today and received my RMA number. The tech rep stated it would take 3 days for turnaround to have a unit returned to me, but based on what I've read here I don't buy that at all!

    Additionally, I solved my dvd lockout code problem. <3 Mp3Car

  6. #26
    Low Bitrate
    Join Date
    Nov 2007
    Location
    Sydney, Oz
    Posts
    60
    My Retailer has told me that they have tried to contact Xenarc, by both email and phone, and not getting any response from them.
    As I have had continual problems with my screen since February, I am getting very tired of this situation.
    Firstly, for the first month it was awaiting the firmware upgrade.
    Then it was awaiting a cable to do the upgrade. Here it is mid June, and still no progress in resolving the problem. I have advised that I now want a replacement screen, and the excuse now is "awaiting stock"
    I see that Xenarc are now releasing new types of screens. While I applaud any company to expand, they really need to pause for a moment and fix the issues at hand, prior to introducing new items.
    I have tried emailing their support, but got no response.

  7. #27
    Organic Me
    Auto Apps:loading...
    Heather's Avatar
    Join Date
    Sep 2007
    Location
    Fells Point, Baltimore, MD
    Posts
    1,288
    Blog Entries
    48
    If you have not noticed...it is not on Mp3Car, while we carry many other Xenarc products.

    I think that they are committed to putting out a great product, but as it stands we will not sell the unit ourselves. Once they sort the issues out, we look forward to putting the MDT center stage. For now we wait. This is just the way product development goes.

    I am surprised to hear though that Xenarc is not responding at all to support requests, they do provide support.

    If anything - the more people can comment on the unit - the more you will push Xenarc to make a better product.

    The pressure placed on Ituner and the new M4 deliver fairly good results.

  8. #28
    Variable Bitrate
    Join Date
    Jan 2006
    Posts
    345
    I've decided not to wait for this unit to get fixed. I'm gonna look for a decent 7" (maybe larger) transflective LCD, and possibly a slim slot-loading DVD drive.

    I'm kinda still deciding whether to get a motorised screen, or to get one that just sits there in the dash. Previously, I wasn't a fan of having an LCD sitting there in the dash because it can attract thieves, but recently, a friend of mine installed a car PC in his Mazda 3 and his screen isn't motorised. It's just sitting there in the dash with a nice aftermarket frame around it to match the centre console. It looks great, almost like he bought the car with it. So now I'm reconsidering ....

    I'm also not liking the idea of motorised screens being prone to mechanical faults. If I do end up getting a motorised screen, I'd have to make sure it wasn't riddled with faults. Any suggestions?

  9. #29
    Newbie
    Join Date
    Oct 2007
    Posts
    11

    Should have posted this earlier.

    Sorry about not writing about my situation and the end result until now. I did receive my new unit in late March (2008) and it is installed. A few things about this unit. It has not hung up on me yet. I haven't had any issues with the screen coming out or retracting. Those are the pros. The unit is still laggy. My carputer boots before the screen comes up (to be fair tho, my carputer cold starts to fully operational in 15 seconds . The GUI is still the same. The DVD drive doesn't work with my carputer. The DVI port doesn't work, which I hate. If I boot it up in PC mode the sound won't turn on. I have to switch to another mode, then switch back to PC mode to get the sound up, which sucks, because I also have to wait for the usb for the unit to start up again, so it's extra waiting to use the touchscreen.

    Now for some other notes. The audio amplifier on this unit is horrible. I originally had my speakers driven straight from the head unit, but it really couldn't handle it. So I've ran the coaxial outputs to a amplifier, and that made things sound ten times better. The display on this unit is not that bad, I like it, and the touchscreen works really well. This unit wouldn't be that bad if it wasn't for the other annoying issues. I didn't want to do a ton of work to my dash. I built my carputer specifically to be removable without any changes to my cars OEM parts. I guess I could have made a new facia for my dash out of something, but I didn't want to spend the time. The other thing, I only have 1 din slot to mount something in, so a double din unit was out of the question. This unit has a great concept, but in reality it isn't reaching an acceptable standard. I recommend exhausting all other possibilities for your carputer setup before deciding on this unit. Maybe taking a big name brand (alpine, pioneer, etc.) and getting your hands dirty trying to adapt to the 50$ touchscreen cover to it so you can interface to it. I don't know of anyone who has done this, but it's an idea. I've heard this unit is too overpriced, but I don't think so. For all that it does offer it's reasonable, but you pay for what you get. I would gladly pay more for a unit that does all this does, if it's functionality was to par.

  10. #30
    Newbie
    Join Date
    Jun 2008
    Posts
    3
    I had my unit since may 2008, and i am suprised they even sell this product!THIS product is not finished, and have many serious issues !

    1.Amplifier is terrible !
    2.Volume control is not a control, its a random generator (a slow one)
    3.It will not start below zero temperature, interesting in a winter morning !
    4.As mentioned before, you must switch mode, and back, to get sound !
    5.Screen flips at ignition, must power off and on to fix (2 min)
    6.You cannot store radio channels, reprogramming after each power off. (permanent power connected)
    7.All the buttons on the unit is only working if the display is out, because then you dont need them !
    8.DVD is playing a nice DVD-rmp tach in the speakers, so you can keep track of the current spin velocity. (have no amp. only speakers direct to unit)
    9.as a bonus, the unit hangs now and then, but thats not a problem, since i already moved my battery to the passenger seat and welded a wrench to each pole for a quick restart of my Xenarc !
    10. the screen is making two scratches on itself, just by ejecting the screen.

    Exept for the minor mentioned problems, its a marvelous product !

    I am not bitter, just fooled !

    PS. i havent talked to them yet, im going to. im just suprised they ship this product as if they dont know anything about all of this ! DS.

Page 3 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. Just got my LCD and broke the mount
    By TripleThreat in forum LCD/Display
    Replies: 2
    Last Post: 12-08-2007, 01:45 AM
  2. PSU acting weird.. broke?
    By Dj-[NRG] in forum Power Supplies
    Replies: 5
    Last Post: 04-09-2007, 07:01 AM
  3. Finally broke winamp 2.95
    By blk02si in forum Road Runner
    Replies: 1
    Last Post: 04-28-2006, 09:40 AM
  4. HELP!! my lilliput may have broke!!!
    By timdastis in forum LCD/Display
    Replies: 13
    Last Post: 05-28-2005, 08:13 PM
  5. I'm going broke...
    By jm8881 in forum General MP3Car Discussion
    Replies: 17
    Last Post: 05-30-2004, 10:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •