Results 1 to 3 of 3

Thread: Lilliput Problems

  1. #1
    Newbie
    Join Date
    Mar 2011
    Location
    New York
    Posts
    6

    Thumbs down Lilliput Problems

    Back in 2011, I started on my car pc project by slowly gathering parts week by week and eventually assembling them in my car. Everything went off without a hitch... except for the screen. I got a Lilliput 669GL-70NP/C/T-5HB 7" HDMI, DVI, VGA High Brightness, 5 Wire Resistive Touch Screen and set it up in my car, it worked for a few months... then it mysteriously failed. After some testing, I realized the DC adapter was bad. So I ordered a new one right here at mp3car. That's when the trouble really began. The new DC unit fried my screen almost instantly. The screen went bright white and the colors inverted. This got progressively worse in the screen's final minutes until it displayed nothing. Frustrated, I let the project sit for a while. My family, knowing that this was my problem ordered me the exact same model so I could finally get it up and running. Fast forward to today. I re-installed my PC and screen with much excitement, only to watch my brand new screen do the same thing with it's included adapter. I had tested the screen on AC power thoroughly for many days prior and it ran fine. Needless to say I am ****ed and out over $500 with the cost of these two screens! I'm hoping that maybe MP3car, Lilliput or someone will see this and contact me, but who knows. What I do know is that I wont be spending another dime on this website or on another Lilliput display until this issue has been resolved.

    Sincerely,

    A tremendously disappointed CarPC enthusiast

  2. #2
    Neither darque nor pervert DarquePervert's Avatar
    Join Date
    Apr 2004
    Location
    Elsewhere
    Posts
    13,950
    I can't say or certain, but if the screen worked fine under AC power and fried under DC power, then I'd suspect that the problem lies w/ the DC wiring.

    What "adapter" are you talking about? The DC power connector? How is it wired?
    Have you looked in the FAQ yet?
    How about the Wiki?



    Under normal circumstances, a signature would go here.

  3. #3
    Newbie
    Join Date
    Apr 2011
    Posts
    1
    Quote Originally Posted by F1R3STORM View Post
    Back in 2011, I started on my car pc project by slowly gathering parts week by week and eventually assembling them in my car. Everything went off without a hitch... except for the screen. I got a Lilliput 669GL-70NP/C/T-5HB 7" HDMI, DVI, VGA High Brightness, 5 Wire Resistive Touch Screen and set it up in my car, it worked for a few months... then it mysteriously failed. After some testing, I realized the DC adapter was bad. So I ordered a new one right here at mp3car. That's when the trouble really began. The new DC unit fried my screen almost instantly. The screen went bright white and the colors inverted. This got progressively worse in the screen's final minutes until it displayed nothing. Frustrated, I let the project sit for a while. My family, knowing that this was my problem ordered me the exact same model so I could finally get it up and running. Fast forward to today. I re-installed my PC and screen with much excitement, only to watch my brand new screen do the same thing with it's included adapter. I had tested the screen on AC power thoroughly for many days prior and it ran fine. Needless to say I am ****ed and out over $500 with the cost of these two screens! I'm hoping that maybe MP3car, Lilliput or someone will see this and contact me, but who knows. What I do know is that I wont be spending another dime on this website or on another Lilliput display until this issue has been resolved.

    Sincerely,

    A tremendously disappointed CarPC enthusiast
    This is not new to me, I had the same problem, first the screen going to white after some time, later the touch screen going crazy, I mean not functional stucked down corner, I had a lot of gadgets and electronic stuff , and I really think liliput isthe worst product I ever had in all my life, I can say that because it didnt lasted 20 or 30 hours, I didnt returned because I used more than a year to buy all the car pc parts and install them so the screen was out of warranty, after all this experience I bought the screen of Derrick in ebay I think this is his name ,there is a thread here about a 105 or 135 ish screen, after I received I had no problems with s*** tty costly screens.


    Enviado desde mi ASUS Transformer Pad TF700T usando Tapatalk 4

Similar Threads

  1. Lilliput problems
    By Virac in forum LCD/Display
    Replies: 7
    Last Post: 07-10-2007, 01:41 PM
  2. Lilliput 619 problems
    By DK888 in forum LCD/Display
    Replies: 1
    Last Post: 03-07-2006, 02:51 PM
  3. Lilliput problems
    By octavia red in forum General MP3Car Discussion
    Replies: 7
    Last Post: 04-23-2005, 03:32 AM
  4. Lilliput TS Problems
    By djXternal in forum LCD/Display
    Replies: 6
    Last Post: 01-17-2005, 10:00 PM
  5. Having problems with my Lilliput
    By srcstc in forum LCD/Display
    Replies: 4
    Last Post: 03-04-2004, 01:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •