Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: [RELEASE] NMC 0.7 BETA 2 -> introducing ACTIONS and NCS !

  1. #11
    Maximum Bitrate netsuo's Avatar
    Join Date
    Jan 2003
    Location
    Switzerland
    Posts
    557
    its because there's only one button function in scripts

    For each custom action you have to do a NCS with "EXECUTE=FUNCTION:your_function_name". This means 1 custom action = 1 script. Look @ "Custom button action" folder

    For your other request, i dont really understand what your saying sorry ??
    NS - neocar suite
    -----------------
    http://www.neocarmediacenter.com

  2. #12
    Maximum Bitrate netsuo's Avatar
    Join Date
    Jan 2003
    Location
    Switzerland
    Posts
    557
    Quote Originally Posted by RoyN
    Hey Netsuo, I know its not time for more requests, but I just thought of this, *if it isnt very hard* can we have an option to be able to have the audio from a video go on when we go to the other modules (except music), so we can listen to say a video CD, and go into GPS and not stop the music...

    or go to the main menu if we go near a cop, but not stop listening t the music...


    Question: I removed the comment from one of the lines from the MODULE_START:AUDIO example, to get track +10secs whenever audio module starts.... but I can click menu, audio and the track wont advance...!

    is that only when the module starts 1st time?

    Also, when trying to edit that custom button and put a little test:

    for i = 1 to 10
    i = i + 1
    next i
    msgbox i

    I get a crash with this.... is it bad code or something not supported?

    I think MODULE_START is self explaining no ?? Its only one time at start (before the module is painted). The only continuing function is timer.

    Please go to NCS thread for more.
    NS - neocar suite
    -----------------
    http://www.neocarmediacenter.com

  3. #13
    Variable Bitrate
    Join Date
    Apr 2004
    Location
    Belgium - Oostmalle
    Posts
    240
    Another bug :

    If you go to applications, you see your predefined maps. Go to the map where your application xml's are stored. Launch whatever (embedded or not ?)application you want. Exit the application with the red exit button on the lower right corner. If you look to the tree in the left half of NMC, you'll notice you are in the map where the .exe of the application you just launched is situated, and you're stuck in there. If you go to another module and return to the applications module, everything is ok again.
    Car : Hyundai Tucson
    Carpc :
    Lilliput 7" touchscreen indash 90% done
    PSU : M2-ATX
    Epia M10K /512DDR/80GB Maxtor
    Software : Windows XP Pro 100% done
    RR with DigitalFX skin
    In car : 80% done

  4. #14
    Low Bitrate
    Join Date
    Oct 2004
    Location
    Glasgow, UK
    Posts
    106

    Eject???

    netsuo, brilliant work once again, but just one question.

    is there no eject button? i cant find one in NPC

  5. #15
    Maximum Bitrate netsuo's Avatar
    Join Date
    Jan 2003
    Location
    Switzerland
    Posts
    557
    i temporary removed it because of bugs..
    NS - neocar suite
    -----------------
    http://www.neocarmediacenter.com

  6. #16
    Low Bitrate
    Join Date
    Oct 2004
    Location
    Glasgow, UK
    Posts
    106
    ok thanks for quick reply.

    now i have another problem. i was making a new skin, now when i launch nmc i get:

    run-time error 13:
    type mismatch

    do u know what i have done wrong? If it helps, when i am on skin selection screen in NM it shows preview of Light skin but not of my skin.

    Now when i try to open the skin in NPC i get:

    run-time error 91
    Object variable or with block variable not set.


    I had no problems opening the skin before and also checked integrity and was ok.

  7. #17
    Maximum Bitrate netsuo's Avatar
    Join Date
    Jan 2003
    Location
    Switzerland
    Posts
    557
    please send the skin.xml on netsuo _at_ bluewin.ch.

    Thanks.
    NS - neocar suite
    -----------------
    http://www.neocarmediacenter.com

  8. #18
    Low Bitrate
    Join Date
    Oct 2004
    Location
    Glasgow, UK
    Posts
    106
    thanks anyway netsuo, but i got it working. Not quite sure what was wrong.

    While im here can i ask one more question

    When making a skin, how do you add button to return to main module from audio? There is no option for main in "show module".

  9. #19
    Maximum Bitrate netsuo's Avatar
    Join Date
    Jan 2003
    Location
    Switzerland
    Posts
    557
    yeah

    I know, i forgot it on language XML's..

    Here are the good ones:

    http://www.neocarmediacenter.com/files/NSL_EN.xml

    http://www.neocarmediacenter.com/files/NSL_FR.xml


    EDIT: have you taken a look to "Eject button" post ?
    NS - neocar suite
    -----------------
    http://www.neocarmediacenter.com

  10. #20
    Low Bitrate
    Join Date
    Oct 2004
    Location
    Glasgow, UK
    Posts
    106
    yeah i seen the post about eject button, NCS looks really promising.

    Im still having some problems with skinning. In filelist and track elapsed times i keep getting "text 1". Anyway ill play around a bit more to see if i can fix it before i start getting on your nerves.

    Thanks again

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •