Results 1 to 7 of 7

Thread: Increasing static on differential inputs

  1. #1
    Newbie
    Join Date
    May 2011
    Posts
    12

    Increasing static on differential inputs

    I built a custom PCB to attach to the stock head unit harness on my e46 BMW. The audio inputs are differential and go to a separate audio system controller. When I turn it on and enable my circuit everything is fine but as time goes on, static starts building up. I have bypass capacitors on all 4 inputs (left and right +,-). Could charge be building up? Do I need a resistor in there somewhere? Thanks.

  2. #2
    Low Bitrate
    Join Date
    May 2012
    Location
    Edison, New Jersey, United States
    Posts
    60
    does that have the dsp system? yanno it has the 10 speaker system with the factory amp?what year is the bmw? and what kind of audio system are u talking about?

  3. #3
    Newbie
    Join Date
    May 2011
    Posts
    12
    Yes its a 2002 e46 and originally had the 10 speaker HK premium sound system. I've since replaced all the speakers and I'm running an aftermarket amp but I've retained the stock radio unit. Not sure if its dsp or not. My circuit attempts to mimic the tape player. In any case I've since taken apart the stock head unit and reverse engineered the audio path of the tape player. I've put a new filter and DC block so hopefully that will cure the static on my next board.

  4. #4
    Low Bitrate
    Join Date
    May 2012
    Location
    Edison, New Jersey, United States
    Posts
    60
    i was wondering cause i just did a douible din radio in on of them cars and damn it was tricky, i had to deal with that premium sound system, if its the one im thinking about it's probably a 3 channel set up with the fm tuner just to the left of the amp. i ran high input to the amp since when i tried rca level you coudlnt even hear it . bmw's are also hard to keep noise out of the rcs, just make sure to use double twisted, and double check where there are power wires .

  5. #5
    Low Bitrate
    Join Date
    May 2012
    Location
    Edison, New Jersey, United States
    Posts
    60
    wow u replaced all 10 speakers im impressed on that side since they are all small sizes blah .what amp are you using? a reasonably priced amplifier can make a difference in the amount of static thats filtered.double twisted rca wires are i waould say a must in that care since there are power wires everywhere .on my car im gonna purchase a new alpine amp the pdx-v9 .

  6. #6
    Newbie
    Join Date
    May 2011
    Posts
    12
    Well, I actually replaced the front speakers with 6.5" components and am not currently using the back speakers. I have a Phoenix Gold Octane 900.5 or something that I plan to replace in the near future with a much smaller 4 channel.

    But back to my original post, I've found the condition in which I get static and hopefully someone has experience with this....

    When the tablet is connected, the USB and Audio are plugged into my circut board, which in turn plugs into the car. The static occurs only when the USB is connected at the same time as the audio. If I use a different audio source there is no static and if I unplug the USB there is no static. My first thought was a ground loop on my board but the USB and audio jack are connected to the same ground plane. Also, the tablet's USB ground has 0 ohms resistance to it's audio jack ground. I'm going to try putting a ferrite in line with the USB power and maybe a capacitor or two. If someone has any thoughts as to what might be going on I'm all ears. TIA.

  7. #7
    Newbie
    Join Date
    May 2011
    Posts
    12
    I did a bunch of testing this afternoon and I think that the switching regulator is somehow creating noise that gets into the tab's audio output. I'm going to try and wire in a linear regulator to see if that fixes the problem.

Similar Threads

  1. Differential Equations
    By CorMan in forum Off Topic
    Replies: 6
    Last Post: 11-21-2008, 12:41 AM
  2. Replies: 0
    Last Post: 12-30-2006, 12:38 PM
  3. Replies: 8
    Last Post: 02-14-2006, 07:43 PM
  4. Replies: 5
    Last Post: 03-13-2003, 12:02 AM
  5. Ford MACH stereo(differential grounds)
    By Catlas in forum General Hardware Discussion
    Replies: 1
    Last Post: 11-04-2000, 11:11 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •