Results 1 to 4 of 4

Thread: obdgpslogger takes forever to open serial port

  1. #1
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,492

    obdgpslogger takes forever to open serial port

    i've got an obdpro and linuxice upgraded to 9.10. I run obdgpslogger -s /dev/ttyUSB1 which is my obdpro device and obdgpslogger reports "opening serial port, this can take a while". For the next 2-3 mins, it says that. I look at my obdpro and i can occasionally see a light flicker other than the normal power on light (i think it may be a Rx or Tx light on the PC side).

    After the 3 mins, logger reports that it opened the device up correctly, the scantool failed to respond to command "00", spits out a couple sqlite create table errors and then goes silent.

    I don't see it exporting dbus signals and nghost doesn't see them either.

    any hints? are all the lights on the scantool supposed to light up?

    thanks
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  2. #2
    SuperMod - OBDII GPS Logger forum
    Auto Apps:loading...

    Join Date
    Mar 2009
    Location
    Los Angeles
    Posts
    924
    I've been seeing similar problems on ubuntu 9.10, but not on 9.04. unplugging and re-plugging the device usually fixes it [although if you have the same buggy ftdi driver as me, the /dev entry will change because it can't clear the old one out].

    If I try connecting to the port by hand, then it works for a while and then suddenly turns to garbage after typing for a bit.

    Thus far, it seems like this is another 9.10 manifestation-of-bugginess

    You might also try explicitly passing the --baud=9600 option, see if that helps. It shouldn't make a difference, but I have yet to see 9.10 ftdi-sio properly work right, at all.

    Gary (-;
    OBDGPSLogger, for logging OBDII and/or GPS data
    OBDSim, an OBDII/ELM327 software simulator
    mp3car forums: obdgpslogger, obdsim

  3. #3
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,492
    Found this: http://forums.parallax.com/forums/de...&m=298620&p=38

    Looks like we are not alone. I'll recommend LinuxICE users not to upgrade to 9.10 yet.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  4. #4
    SuperMod - OBDII GPS Logger forum
    Auto Apps:loading...

    Join Date
    Mar 2009
    Location
    Los Angeles
    Posts
    924
    Yes, that's exactly the symptoms I'm seeing.

    I'm actually getting to the point that I'm probably going to reinstall that laptop with 9.04 - I've been having all manner of stupid problems with 9.10 so far.

    Gary (-;
    OBDGPSLogger, for logging OBDII and/or GPS data
    OBDSim, an OBDII/ELM327 software simulator
    mp3car forums: obdgpslogger, obdsim

Similar Threads

  1. Replies: 42
    Last Post: 12-11-2009, 02:36 PM
  2. Serial port, relay, and a bunch of LEDs
    By RedGTiVR6 in forum General Hardware Discussion
    Replies: 6
    Last Post: 02-28-2007, 02:36 AM
  3. NMEA extraction AppleScript need help
    By zapwizard in forum MacCar
    Replies: 15
    Last Post: 05-05-2006, 01:10 AM
  4. Signalling a STAMP from the serial port?
    By Bugbyte in forum General Hardware Discussion
    Replies: 5
    Last Post: 05-06-2005, 03:00 PM
  5. USB Serial Port Adapter Troubles
    By bLindmOnkey in forum General MP3Car Discussion
    Replies: 0
    Last Post: 10-13-2004, 11:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •