Results 1 to 5 of 5

Thread: Problems with TV

  1. #1
    Constant Bitrate
    Join Date
    Jul 2001
    Location
    Richmond, VA USA
    Posts
    217

    Post Problems with TV

    Let me set this up... First of all I know this will end up a long thread and I am sorry, so look elswhere if you don't feel like reading...

    Okay, I got a 25" RCA TV last christmas which means I have only had it for approx 9 months. I have a PS2 connected to an aftermarket speaker/switch (input selector) which goes 4 in and 1 out (to the TV "RCA" or composite input)
    that is what is tuned to on the input channel and the switch is basically you push a button for which source you want to watch. The other channel the TV is tuned to ever is channel 3 which I have the digital cable box going to the "screw on" cable connector on the back of the TV.

    Now for the problem:

    For the last few weeks I have been having weird problems with it and it is getting worse. First of all the screen would have a regular image (just watching tv) and then it would go mostly black but have incorrect colors on the middle of the screen which was still showing the image. Not just like a rainbow but really dark like red and blue colors kinda swirling but still showing the image. This happened a few times. Now lately the TV will just seem to "cut off" and come back on, however I know it is not off because I can still here the high pitched noise that it makes when it is on but not tuned to anything. So the tube or screen is going black and then slowly warms back up to the picture. With channel 3 or the cable tuner, it seems to be seemless off then slowly back to a picture... however when on the input channel if nothing is tuned in it shows a message saying "Unusable Signal" (this is nothing new...just how the TV is supposed to work to show its not recieving a signal) anyway I was trying to watch a DVD tonight which I use the PS2 for and when it would turn black and start to come back to the picture it would first show the screen with unusable signal then show the DVD image.

    So now it seems to always "turn off and on" when we are watching it... I use quotes simply because the TV is never really off but the picture is not showing, its just easier to say it like on and off.

    Also I have had good experience with RCA TVs in the past I have two 19" RCAs (one is a few years old and the other is about 10 years old) So I don't know why this one is doing this being fairly new... Also my dad used to have a "console" RCA which is about 20 years old and it stopped working about a year maybe 2 years ago... that one would turn completely off and back on and would also not tune correctly, we started using a VCR as atuner and left it on channel 3 but it eventually went completely and since it was ancient he got a new TV instead of electing to get it repaired. So I just am trying to point out I don't think it is simply the brand, I have had good past experiences.

    I am going to try to get it replaced under the extended warranty at Kmart (my aunt works there and bought it for my dad (employee discount) and I am going to talk with her tomorrow about it). But I am wondering if anyone here has any experience with televisions and can explain what it might be that is causing this.

    One last thing, I take good care of all of my stuff I have never spilled anything or anything like that which would cause damage and when I clean the screen I turn it off and make sure nothing drips down and all that good stuff. So I doubt I may have done anything to it. Also one thing I am afraid of, for the recently in the past weeks (i don't know if it stretches far back enough to match the starting of problems) but we have been having frequent "Brown outs" in my area. For those who are not familiar with that term, it is basically when the power is almost off such as a blackout, but instead it only decreases and then returns again, the only way it is noticed really is that the all the lights in the house will dim considerably then go back to full brightness. But I have read that it is hell on electronic equipment and surge bars (which the TV and everything connected to it is plugged into) do not help against brown outs.

    Anyway once again sorry about the long post, this is probably the longest thing I have typed since school let out for the summer. So if anyone has actually read through this and knows what is wrong or what could be causing this... could you please try to explain it to me... Thanks in advance.

    -Josh
    Josh Karger
    By reading this post you agree to overlook all grammatical, spelling, and typographical errors! ;)

  2. #2
    Maximum Bitrate
    Join Date
    Jul 2002
    Location
    Boston, MA
    Posts
    548
    I just bought a RCA 36" Flat screen HDTV P-in-P with all sorts of cool options for under $1200.

    Two weeks later I had to return it because inputs were not working and it would squeel in the middle of the night when it was off and I was sleeping.

    I wasn't taking any chances and returned it.

    Maybe I just was unlucky, but a $1200 TV after two weeks should not do this.

    RCA has a crap-load of features for the money, but overall, reliability is the key.

    Just my input...

    -Mario

  3. #3
    Maximum Bitrate
    Join Date
    Mar 2001
    Location
    Cincinnati, OH USA
    Posts
    694
    Honestly it sounds like a loose wire somewhere within the TV. How often have you moved it? Have you tried it with just the VCR or cable hooked up? I thought selecter boxes were obsolete nowadays (is that a word?). Here is how I have mine set-up, you may not have the right inputs on your TV, (1 Coaxial input, 1 video RCA input, 1 audio RCA input, and 1 audio RCA out) there may be more but I don't use them.....

    The cable is connected (coaxial) to the VCR, which is connected (coaxial) to the TV. The DVD player is connected (Audio & video - RCA) to the TV. My 5.1 stereo is connected to the TV. No switchbox needed.
    http://www.mp3car.com/usersites/Maveric/ M.A.V.I.C. System
    Asus MB, PII 266, 192 MB Ram, 6.8" LCD, 6 Disk CD-ROM, 21 Gig HD, All-in-Wonder Video w/ TV Tuner, Irman, Windows ME, Winamp, Cobra III -- All in a custom acrylic case.

    http://www.mp3car.com/usersites/listings/ MP3car Listings - Please add to it! :)

  4. #4
    Retired Admin Aaron Cake's Avatar
    Join Date
    Jan 2000
    Location
    London, Ontario, Canada
    Posts
    2,464
    Back in the day, I used to repair TVs. In the old days, we would locate a problem like that by spraying cooling solution onto the board in various places until we found the part that was misbehaving. With your problem, I'd start near the power supply. However, all these modern TVs have tonnes of new-fangled electronics that serve mostly to complicate things unnecessarily. So basically, send it back for warrantee because you have an intermittant power supply or main CPU.
    Player: Pentium 166MMX, Amptron 598LMR MB w/onboard Sound, Video, LAN, 10.2 Gig Fujitsu Laptop HD, Arise 865 DC-DC Converter, Lexan Case, Custom Software w/Voice Interface, MS Access Based Playlists
    Car: 1986 Mazda RX-7 Turbo (highly modded), 1978 RX-7 Beater (Dead, parting out), 2001 Honda Insight
    "If one more body-kitted, cut-spring-lowered, farty-exhausted Civic revs on me at an intersection, I swear I'm going to get out of my car and cram their ridiculous double-decker aluminium wing firmly up their rump."

  5. #5
    Maximum Bitrate Skippman's Avatar
    Join Date
    Mar 2002
    Location
    St. Louis, MO
    Posts
    766
    Sounds like a bad cold solder trace to me. A friend of mine had this problem with an RCA back in the day. I've been told by various sources that the new RCA boards use multilayer PCB's and that the cold solder traces have a tendancy to break when the TV is used for extended periods of time. RCA has really gone down hill in the last few years. It's a shame to.

    I would recommend taking it back. I don't know if I would have it replaced, unless that is your only option. Seems to me you can get a decent Sony for a reasonable price these days. I know from which I speak.

    Living Room
    Mitsubishi 46" 16:9 HDTV
    Panasonic Progressive Scan DVD Player
    Pioneer Elite 6.1 Surround Sound Reciever
    Sony Speakers (Upgrading to Paradigm soon)
    (Other, non important stuff like an CD platers, game consoles etc)

    Bed Room
    Sony 27"
    Sony ES DVD Player
    Yamaha 5.1 Surround Sound Reciever
    Yamaha Speakers w/ Sub

    Sorry about that last part. Just wanted to brag. :P
    Stereo:Alpine IVA-D900 Head Unit | Alpine PXA-H510 DSP | Boston Pro Component Speakers Upfront | Boston Rally Rear Speakers | 2 Polk 10" Subs in the Trunk | Phoenix Gold Ti900.7 Amp

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •