Results 1 to 3 of 3

Thread: Passport 8500 problems

  1. #1
    Maximum Bitrate PoBoy's Avatar
    Join Date
    Jun 2001
    Location
    St. Louis-MO
    Posts
    490

    Post Passport 8500 problems

    Ive had this for about 8 months now. The first 5 months, it was working beautifully. Very few false alarms and it picked up cops at good distances. Lately, however, it goes off all the time. I drove for 20 minutes across town and it wouldnt stop going off. I even have all the sensitivities set to low and X band off. Anyone else have this radar detector and are experiencing this problem? It is still ranked #1 at radartest.com and I would have agreed until lately. Dont know what the deal is. Take her back?
    I'm a ghost...email me if you have any questions on my old setup

    My way outdated website: http://www.poboytech.net

    FYI: I sold my 96 4Runner and bought a 1985

  2. #2
    Variable Bitrate
    Join Date
    Jul 2000
    Location
    Jackson, MS, USA
    Posts
    233

    Talking

    go to http://www.valentineone.com to fix your problem Actually something prolly messed up in your detector, send it back for repair.
    24 y/o w/ Silver/Red
    2000 Honda S2000

    http://www.squeezer.net

  3. #3
    Maximum Bitrate PoBoy's Avatar
    Join Date
    Jun 2001
    Location
    St. Louis-MO
    Posts
    490

    Post

    Valentine One sucks! Read reviews on it. Its merely the most expensive radar detector on the market so everyone thinks its the best. Check out radartest.com for more info. They gave it a 77 out of 100 on pure radar detection capabilities, not best features or style.

    Anyways, Im gonna take back my 8500 and get a new one.
    I'm a ghost...email me if you have any questions on my old setup

    My way outdated website: http://www.poboytech.net

    FYI: I sold my 96 4Runner and bought a 1985

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •