Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: OpenMobile 0.5.0.14 Released (11/27/09)

  1. #11
    Variable Bitrate UnusuallyGenius's Avatar
    Join Date
    Mar 2009
    Location
    Grand Rapids, Mi
    Posts
    306
    i redid my win install, and it worked, didnt crash on its own until i tried to assign a button:
    Name:  om died1.jpg
Views: 962
Size:  32.3 KB

    btw: windows did not come up with a solution.
    - Project: Unified Car Control
    - Original OpenMobile Interface Designer

  2. #12
    Raw Wave
    Auto Apps:loading...
    justchat_1's Avatar
    Join Date
    Jul 2008
    Location
    Boston, Ma or NY,NY
    Posts
    2,359
    Ohhhhh...... let me guess your running 64bit?

    If so, there was an issue with the installer not always figuring out an OS was 64bit. So if you replace System.Data.SQLite.dll from the program directory with the one in the win64 folder of the program directory you should be all good.

  3. #13
    Confusion Master
    Auto Apps:loading...
    Enforcer's Avatar
    Join Date
    Sep 2003
    Location
    If you go down to the woods today, You're sure of
    Posts
    14,581
    OK, some observations so far.


    1.

    I get an error


    I have assigned User Interface to a button, I click on button and get a pretty bland screen with nothing on it. Hit the back button and get the following error. (NB clicking home does the same.)

    Screen 1

    Index was out of range, must be non-negative and less then the size of the collection. parameter name index.

    Windows XP


    2. Clicking Volume button doesn't seem to do anything.


    3. Seems to take ages to start playing music, in fact it seems to happen after I have gone to random screens and pressed random buttons

    4. Ok have now manged to work out how to play a single track, but how about all from same artist, or just all the songs?

    5. Music doesn't seem to start on restarting after exiting with music playing.


    That's it for now, maybe more later

  4. #14
    Confusion Master
    Auto Apps:loading...
    Enforcer's Avatar
    Join Date
    Sep 2003
    Location
    If you go down to the woods today, You're sure of
    Posts
    14,581
    Knew there was something else.

    The only skin images so far are in the subfolder skins, now surely you should have subfolders in the skins folder with the diferent skins names and then in those folders should be the images.


    Same goes for the plugins, surely each plugin should have it's own folder so it can store it's crap in it's own folder, ie like settings (ini or xml files) and working files, rather than clutter up the root plugins folder.

  5. #15
    Variable Bitrate UnusuallyGenius's Avatar
    Join Date
    Mar 2009
    Location
    Grand Rapids, Mi
    Posts
    306
    nope, 32 bit Ultimate, Acer Aspire One

    EDIT: Enforcer, music selection does not work how envisioned, working on it, play back issues is Justchat_1's area though
    - Project: Unified Car Control
    - Original OpenMobile Interface Designer

  6. #16
    Raw Wave
    Auto Apps:loading...
    justchat_1's Avatar
    Join Date
    Jul 2008
    Location
    Boston, Ma or NY,NY
    Posts
    2,359
    Quote Originally Posted by Enforcer View Post
    OK, some observations so far.
    1. I get an error
    I have assigned User Interface to a button, I click on button and get a pretty bland screen with nothing on it. Hit the back button and get the following error. (NB clicking home does the same.)

    Screen 1

    Index was out of range, must be non-negative and less then the size of the collection. parameter name index.

    Windows XP

    2. Clicking Volume button doesn't seem to do anything.

    3. Seems to take ages to start playing music, in fact it seems to happen after I have gone to random screens and pressed random buttons

    4. Ok have now manged to work out how to play a single track, but how about all from same artist, or just all the songs?

    5. Music doesn't seem to start on restarting after exiting with music playing.

    6. The only skin images so far are in the subfolder skins, now surely you should have subfolders in the skins folder with the diferent skins names and then in those folders should be the images.

    7. Same goes for the plugins, surely each plugin should have it's own folder so it can store it's crap in it's own folder, ie like settings (ini or xml files) and working files, rather than clutter up the root plugins folder.
    well you certainly have been busy
    Ok here goes:
    1. Well thats because the User Interface isn't a regular plugin, its loaded only once before anything else and stays running till the program closes....but i'll make sure its no longer in the selection list (logged as issue #7)
    2. Yup not implemented yet...the codes there just haven't finished the graphics part yet (logged as issue #8)
    3. That shouldn't be the case, music playback is asynchronous so it should be instant. try this-> click an artist, then an album, then tap a song twice. Does it play right away? does the artist/album info show up right away but the song takes awhile? or does the whole thing take awhile?
    4. Ok the basic gist of things is click to view, press and hold to play...works for both whole artist and whole album. Song selection is click to play. This is probably not how things are going to stay were experimenting with a few different concepts and well see what works well where and change things till we get it right.
    5. Yea I didn't get a chance to add it into the settings panel (its there just not enabled). Added it to the todo list so it should make the next version (logged as issue #9)
    6. Yes we should and we will...but since loading/unloading skin images is all handled by the framework we can add that in as soon as theres another skin available and the plugins won't know the difference. The plan is each skin in its own folder plus a default folder with the currently loaded skin but more details on why in the near future.
    7. Well yes and no....any plugin can have its own folder (and the rules in the wiki say it has to match the name of your plugin dll)..but theres not that big of a need. OM handles all your data for you, thats one of the big features. Your data can be accessed by any of the other plugins and vice versa with no need to deal with ini files, xml files or the local file system (keep in mind these apps run on windows, linux and mac).
    Quote Originally Posted by UnusuallyGenius View Post
    nope, 32 bit Ultimate, Acer Aspire One

    EDIT: Enforcer, music selection does not work how envisioned, working on it, play back issues is Justchat_1's area though
    hmm... it sounds like a database issue but I can't imagine why (unless you tried clicking ok with nothing selected which was a bug reported a few posts up). Try running OM as administrator (right click->run as admin), if that fixes it that should narrow down the problem.

    Yea well have to discuss the music thing...it needs a bit of work.

  7. #17
    Newbie
    Join Date
    Jan 2010
    Posts
    3
    Hi a new member here,

    I have a little suggestion if I may. Maybe you can help UnusuallyGenius set up a debug environment and hook onto the executable so he can forward you the error? He doesn't need to know what they mean but it will be of great help for the developers.

    I am a fan of C# and would like to see how far this FE goes. I wouldn't mind contributing if I get some free time later on.

  8. #18
    Raw Wave
    Auto Apps:loading...
    justchat_1's Avatar
    Join Date
    Jul 2008
    Location
    Boston, Ma or NY,NY
    Posts
    2,359
    All of this code has been re-written so it shouldn't be a problem anymore, plus we have a debugger plugin if need be. We can always use a little development help though...

  9. #19
    Newbie
    Join Date
    Jan 2010
    Posts
    3
    I have no problem helping out. Let me know what I can do. My free time is very limited this two months but I will try.

  10. #20
    Low Bitrate BCasey's Avatar
    Join Date
    Sep 2008
    Posts
    107
    looks promising, i cant wait to try this out
    New Project in the Works

    Previous Worklog here

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. eLite Lite 1.6.6 (NEWS UPDATE 9-15-11)
    By suavecito in forum RR Released Skins
    Replies: 1007
    Last Post: 10-29-2013, 10:03 AM
  2. Skype Plugin released
    By lambosprit in forum RR Released Plugins
    Replies: 157
    Last Post: 12-21-2010, 10:58 AM
  3. Ranger Released 30/08/09
    By carputer1 in forum RR Skins No Longer Supported
    Replies: 77
    Last Post: 01-04-2010, 06:04 PM
  4. New Lilliput drivers released!
    By RS200Z in forum LCD/Display
    Replies: 1
    Last Post: 06-07-2006, 09:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •