Page 4 of 6 FirstFirst 123456 LastLast
Results 31 to 40 of 59

Thread: om on ubuntu/kubuntu

  1. #31
    Newbie paddydazzer's Avatar
    Join Date
    Oct 2010
    Posts
    13

    Smile

    Thanks justChat...
    you can't stop progess eh...

  2. #32
    Newbie paddydazzer's Avatar
    Join Date
    Oct 2010
    Posts
    13
    Ok that package worked great thanks justChat..
    I got OM installed..
    when I click on the icon to run it brings up a empty window - /opt/openMobile/OMHal.exe
    any ideas...
    Thanks in advance..

  3. #33
    Constant Bitrate chronoglass's Avatar
    Join Date
    Nov 2009
    Posts
    141
    Quote Originally Posted by justchat_1 View Post
    My apologies then...i'm so used to people on these forums asking questions without reading its becoming a habit to ask twice. Is it safe to assume the NewMedia.dll skin file is present as well as the OMLinPlayer.dll plugin? I've seen some cases where everything doesn't install due to a mono bug (fixed upstream just waiting for ubuntu to update to something thats actually stable).

    Theres a gstreamer-sharp.dll.config file that needs to get copied too. Ugh i'm really starting to consider just writing this myself-this library is such a PITA.
    well, I'm using the trunk builds, but, I have to admit.. I havn't looked to verify that's in there. (just unzip, delete the config files from the last time I ran it and run.) i'll verify

    and yeah, I grabbed the config file too.. pretty much short of just doing a cp *.* lol


    *update*
    Looks like yes, the NewMedia.dll is in the Skins/Default folder.
    there is also a Highway folder and I don't see it in there. This is trunk build 520 on my work test machine (I'll go through and verify it's dependancies since it seems OM won't start on it.. ha ha ha)
    ---------
    I'll do the bumbling, and i'll be the idiot.
    if you've got a "stupid" question, search for some of mine!

  4. #34
    Constant Bitrate chronoglass's Avatar
    Join Date
    Nov 2009
    Posts
    141
    Quote Originally Posted by paddydazzer View Post
    Ok that package worked great thanks justChat..
    I got OM installed..
    when I click on the icon to run it brings up a empty window - /opt/openMobile/OMHal.exe
    any ideas...
    Thanks in advance..
    you're still missing some dependancies. take a look at the list I created in the first post..

    you can run tests by running OM from the terminal via mono "Open Mobile.exe" and get more specific errors from mono about what might be missing.

    it should be located at /opt/openMobile/
    ---------
    I'll do the bumbling, and i'll be the idiot.
    if you've got a "stupid" question, search for some of mine!

  5. #35
    Newbie paddydazzer's Avatar
    Join Date
    Oct 2010
    Posts
    13
    Wiil do... Thanks bud..

  6. #36
    Constant Bitrate chronoglass's Avatar
    Join Date
    Nov 2009
    Posts
    141
    no prob.. forewarning.. it's not going to outright TELL you what's missing, but you should at least get errors that mirror the ones i have in this thread.. heh and if not.. well we can find more!
    ---------
    I'll do the bumbling, and i'll be the idiot.
    if you've got a "stupid" question, search for some of mine!

  7. #37
    Newbie
    Join Date
    Mar 2010
    Posts
    34
    Hello,
    I have successfully gotten OM to work on Ubuntu 10.10. I wish to know if there is anyway to call external applications from the OM gui.If I could just link a button to exec programA I would be happy. The app plug-ins for this purpose will not install on ubuntu.

  8. #38
    Raw Wave
    Auto Apps:loading...
    justchat_1's Avatar
    Join Date
    Jul 2008
    Location
    Boston, Ma or NY,NY
    Posts
    2,359
    Quote Originally Posted by thatguy666 View Post
    Hello,
    I have successfully gotten OM to work on Ubuntu 10.10. I wish to know if there is anyway to call external applications from the OM gui.If I could just link a button to exec programA I would be happy. The app plug-ins for this purpose will not install on ubuntu.
    Looks like those packages accidentally got marked windows only...they need a tiny tweak to work with linux too but ill roll them out tomorrow.

  9. #39
    Constant Bitrate chronoglass's Avatar
    Join Date
    Nov 2009
    Posts
    141
    Quote Originally Posted by thatguy666 View Post
    Hello,
    I have successfully gotten OM to work on Ubuntu 10.10. I wish to know if there is anyway to call external applications from the OM gui.If I could just link a button to exec programA I would be happy. The app plug-ins for this purpose will not install on ubuntu.
    Which edition of ubuntu are you working with if i might ask?

    I am seriously doubting my sanity here.
    ---------
    I'll do the bumbling, and i'll be the idiot.
    if you've got a "stupid" question, search for some of mine!

  10. #40
    Newbie
    Join Date
    Mar 2010
    Posts
    34
    Looks like those packages accidentally got marked windows only...they need a tiny tweak to work with linux too but ill roll them out tomorrow.
    Thanks justchat_1.
    I'm assuming that will be in the subversion.

    Which edition of ubuntu are you working with if i might ask?

    I am seriously doubting my sanity here.
    Just plain ubuntu. I installed the mono meta-package.I alsoinstalled the mono-develop meta package. I don't have time to waste experimenting with packages this early in the game.Then I renamed Open Mobile.exe to OpenMobile.exe. Bash and filename spaces don't mix well. Then I launched OM with the command /usr/bin/mono /opt/openMobile/OpenMobile.exe
    Remember sanity is relative.

Page 4 of 6 FirstFirst 123456 LastLast

Similar Threads

  1. Om + pandaboard + ubuntu
    By Punky in forum OpenMobile
    Replies: 22
    Last Post: 04-04-2011, 04:22 AM
  2. om on the igep
    By tripzero in forum OpenMobile
    Replies: 10
    Last Post: 12-08-2010, 01:51 PM
  3. Should I move from cf to om?
    By TheGuv in forum OpenMobile
    Replies: 102
    Last Post: 10-13-2010, 09:43 PM
  4. OM won't run
    By my87ss in forum OpenMobile
    Replies: 1
    Last Post: 10-13-2010, 04:24 AM
  5. OM Install help and a couple other Qs
    By Squirtez in forum OpenMobile
    Replies: 1
    Last Post: 10-09-2010, 03:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •