Page 1 of 6 123456 LastLast
Results 1 to 10 of 59

Thread: om on ubuntu/kubuntu

  1. #1
    Constant Bitrate chronoglass's Avatar
    Join Date
    Nov 2009
    Posts
    141

    om on ubuntu/kubuntu

    As usual, everything im seeing coming out of this project looks 100% BA.. but it seems as if there is so much bad assery that my computer can't even run it! ha ha ha.

    ever since the update to .8 I havn't been able to get OM to even start. Well, lemme take that back, I WAS able to get it to start then after trying a few revs.. it won't anymore.

    I've uninstalled manually (deleting all of the files it creates) and via the uninstall "script"? (which leaves a few things behind even when you tell it not to) and still, when i try to run it from command line it hangs (using mono "open mobile.exe") if i do it with sudo it exits after a few seconds.. no errors blips or blops.. just looks like i started a service or something.

    when i choose it from the gui I see the open mobile window in my taskbar.. but then it just goes away. I'm actually considering the idea of reinstalling my OS again, but part of me is waiting to see what happens with the tiny linux and meego tests.

    So all of this aside, I'd like to maybe try and make this thread an example of the troubleshooting steps that I or someone like me that doesn't have their head 100% wrapped around *nix might be able to try. Can anyone suggest maybe an app that I can run that will tell me what files are accessed by a running process so i can see if there's just some junk left behind from a previous install that I am missing? or maybe I should try compiling from the svn to see where it fails as a fallback?
    ---------
    I'll do the bumbling, and i'll be the idiot.
    if you've got a "stupid" question, search for some of mine!

  2. #2
    Constant Bitrate chronoglass's Avatar
    Join Date
    Nov 2009
    Posts
    141

    reserved

    OM buildfarm:
    http://openmobile.sourceforge.net/main/trunk/

    Known required packages as of .8

    libndesk-dbus-glib1.0-cil
    libndesk-dbus1.0-cil
    libgtk2.0-cil
    libmono-winforms2.0-cil (required for the plugin manager not for OM itself)
    libxi6

    unpackaged: <aka must compile>
    http://gstreamer.freedesktop.org/src...p-0.9.2.tar.gz
    which you can't compile it seems without
    libgstreamer0.10-dev
    libgstreamer-plugins-base0.10-dev

    To list steps taken:
    ----- test #1------
    "Fresh install" of Kubuntu 10.10 on a separate machine, T60 laptop 1 monitor
    Install first time around fails because I select the skins too quickly "if you choose a second or in my case third before the preview loads OMinstaller crashes" I knew about this, but decided to press my luck. heh I also selected the media player and google plugins, as well as OMdebug.

    It started the first time.. but with no skins (i think i can assume why this happened)

    after this mono would start but the process would go no further.

    tried just rerunning the installer to put the proper skins in place. no joy.. I realize now I should have actually LOOKED in the skins folder to see what was there before I did the uninstall.. woops! reinstalling after cleaning everything out.

    --END test #1--

    So round 2!

    -- Test #2--
    I decided to do as basic an install as I could.. I basically touched nothing but "next" and the download and install button on the plugin piece. and huzzah! it started! indexing complete, tap music.. doh, not there. this time however I check the plugins folder.. I see omlinplayer.dll and an omplayer folder.. cool beans. Check the skins folder
    Not seeing the media skin.. maybe that's the prollem?
    let's see if I can add it with the "configure plugins" installer
    I now have a "newmedia.dll" Let's see how this goes!
    still can't get into the music
    So let's mono from command line to see if it kicks anything out at me.

    OMhal.exe 2038 assembly reference could not be loaded.
    NDesk.DBus.Glib

    hmm.. fow oh fow. Lets go searching for ndesk.. TBC!
    --pause test #2--
    --resume---
    first package attempt
    libndesk-dbus-glib1.0-cil
    and we have a winner! sorta...
    unhandled exception: system.componentmodel.win32exception: applicationname='pacmn', commandLine='list-sinks volume', currentDirectory=' '
    looks like another fow oh fow.. Let's try it away from the command line and setup the folders for media.
    no joy still...
    --Pause test 2 again--

    Still no luck on getting the music plugin to work. after installing the gstreamer packages using rev: 513

    downloading rev:518

    I'm attaching the output of ldconfig -v which is allegedly every installed library
    Attached Files Attached Files
    ---------
    I'll do the bumbling, and i'll be the idiot.
    if you've got a "stupid" question, search for some of mine!

  3. #3
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,560
    Quote Originally Posted by chronoglass View Post
    I've uninstalled manually (deleting all of the files it creates) and via the uninstall "script"? (which leaves a few things behind even when you tell it not to) and still, when i try to run it from command line it hangs (using mono "open mobile.exe") if i do it with sudo it exits after a few seconds.. no errors blips or blops.. just looks like i started a service or something.
    I experienced the same on my igepv2 and my work machine. I don't know what I did to get it to eventually run on the igep, but it did start up. I may have installed some suspected dependencies and that may have done it. Without errors, dunno. On my work machine, I never got it to work and didn't spend anytime debugging.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  4. #4
    Raw Wave
    Auto Apps:loading...
    justchat_1's Avatar
    Join Date
    Jul 2008
    Location
    Boston, Ma or NY,NY
    Posts
    2,359
    0.8 is our first release with the new backend...it had some kinks to be worked out. Give this a shot:
    http://openmobile.sourceforge.net/ma...v501-linux.zip

    You can just extract and run right from the folder... i would be really surprised if it doesn't run well but if it doesn't it should tell you whats wrong (or generate a debug file in ~/.config/openMobile/).

    The 0.9 installer will automatically detect your package manager and install required dependencies but for now heres the list:
    mono
    libndesk-dbus-glib1.0-cil
    libndesk-dbus1.0-cil
    libgtk2.0-cil
    libmono-winforms2.0-cil (required for the plugin manager not for OM itself)

  5. #5
    Constant Bitrate chronoglass's Avatar
    Join Date
    Nov 2009
    Posts
    141
    i'll give it a shot. I think i tried 498 last night (not at home to verify)
    I just refuse to give up on this platform.. i know it's beta.. I'll just keep trying anything and everything to break it for ya
    ---------
    I'll do the bumbling, and i'll be the idiot.
    if you've got a "stupid" question, search for some of mine!

  6. #6
    Constant Bitrate chronoglass's Avatar
    Join Date
    Nov 2009
    Posts
    141
    DllNotFoundException
    Exception Message: libXi
    Source: OpenMobile.Graphics
    Stack Trace:
    at (wrapper managed-to-native) OpenMobile.Platform.X11.Functions:XISelectEvents (intptr,intptr,OpenMobile.Platform.X11.XIEventMask &,int)
    at OpenMobile.Platform.X11.Functions.XISelectEvents (IntPtr dpy, IntPtr win, XIEventMask mask) [0x00000] in <filename unknown>:0
    at OpenMobile.Platform.X11.XI2Driver..ctor () [0x00000] in <filename unknown>:0
    at OpenMobile.Platform.X11.X11RawInput..ctor () [0x00000] in <filename unknown>:0
    at OpenMobile.InputRouter.Initialize () [0x00000] in <filename unknown>:0
    at OpenMobile.RenderingWindow.InitializeRendering () [0x00000] in <filename unknown>:0
    at OpenMobile.RenderingWindow.Run (GameWindowFlags flags) [0x00000] in <filename unknown>:0
    at OpenMobile.Core.Main () [0x00000] in <filename unknown>:0
    ---------
    I'll do the bumbling, and i'll be the idiot.
    if you've got a "stupid" question, search for some of mine!

  7. #7
    Raw Wave
    Auto Apps:loading...
    justchat_1's Avatar
    Join Date
    Jul 2008
    Location
    Boston, Ma or NY,NY
    Posts
    2,359
    Quote Originally Posted by chronoglass View Post
    DllNotFoundException
    Exception Message: libXi
    Source: OpenMobile.Graphics
    Stack Trace:
    at (wrapper managed-to-native) OpenMobile.Platform.X11.Functions:XISelectEvents (intptr,intptr,OpenMobile.Platform.X11.XIEventMask &,int)
    at OpenMobile.Platform.X11.Functions.XISelectEvents (IntPtr dpy, IntPtr win, XIEventMask mask) [0x00000] in <filename unknown>:0
    at OpenMobile.Platform.X11.XI2Driver..ctor () [0x00000] in <filename unknown>:0
    at OpenMobile.Platform.X11.X11RawInput..ctor () [0x00000] in <filename unknown>:0
    at OpenMobile.InputRouter.Initialize () [0x00000] in <filename unknown>:0
    at OpenMobile.RenderingWindow.InitializeRendering () [0x00000] in <filename unknown>:0
    at OpenMobile.RenderingWindow.Run (GameWindowFlags flags) [0x00000] in <filename unknown>:0
    at OpenMobile.Core.Main () [0x00000] in <filename unknown>:0
    Thats so strange...I thought every ubuntu variant came with XInput and all of the 10.10 variants came with XInput2. We shouldn't crash neither are there (just fixed that) but i'm going to look into this and see if a bug report needs to be made upstream.

  8. #8
    Constant Bitrate chronoglass's Avatar
    Join Date
    Nov 2009
    Posts
    141
    there is a "runtime configuration" (xinput) installed
    (apparently this ones still using 10.04 sorry about that)
    I'm pulling the lxinput package now

    edit: same deal
    ---------
    I'll do the bumbling, and i'll be the idiot.
    if you've got a "stupid" question, search for some of mine!

  9. #9
    Raw Wave
    Auto Apps:loading...
    justchat_1's Avatar
    Join Date
    Jul 2008
    Location
    Boston, Ma or NY,NY
    Posts
    2,359
    Quote Originally Posted by chronoglass View Post
    there is a "runtime configuration" (xinput) installed
    (apparently this ones still using 10.04 sorry about that)
    I'm pulling the lxinput package now

    edit: same deal
    Not a problem...i'm sure your not the only one that won't have every optional dependency installed. Good thing we found it now... Fixed it in rev506 but the build server was running a little slow..finally uploaded:
    http://openmobile.sourceforge.net/ma...v506-linux.zip

    btw: turns out the actually dependency is libxi6 (the library you use to access xinput)..which is found in ubuntu and ubuntu netbook but not in kubuntu or lubuntu...gotta love linux. Only necessary if you want to use the new input framework (but lets make sure everything works without it first).

  10. #10
    Constant Bitrate chronoglass's Avatar
    Join Date
    Nov 2009
    Posts
    141
    sweet that one starts.. BUT no media.. the music button is there though
    the linwifi plugin fails because of ndesk.dbus
    but that's all the errors i get in the debug.txt
    no crash log this time though!


    chronoglass@kubuntu-test:~/Release$ mono "Open Mobile.exe"

    Unhandled Exception: System.ComponentModel.Win32Exception: ApplicationName='pacmd', CommandLine='list-sinks volume', CurrentDirectory=''
    at System.Diagnostics.Process.Start_noshell (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000] in <filename unknown>:0
    at System.Diagnostics.Process.Start_common (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) [0x00000] in <filename unknown>:0
    at System.Diagnostics.Process.Start () [0x00000] in <filename unknown>:0
    at (wrapper remoting-invoke-with-check) System.Diagnostics.Process:Start ()
    at MainWindow.checkVolume (Int32 instance) [0x00000] in <filename unknown>:0
    at MainWindow..ctor () [0x00000] in <filename unknown>:0
    at OMLinHal.MainClass.Main (System.String[] args) [0x00000] in <filename unknown>:0
    chronoglass@kubuntu-test:~/Release$

    this happens on launch everytime

    and finally debug.txt

    6702.256: ********Plugin Manager******
    Initializing DPGContacts
    6702.285: ********Plugin Manager******
    Initializing DPGWeather
    6702.288: ********Plugin Manager******
    Initializing LinWifi
    6702.380: ********Plugin Manager******
    Exception
    Exception Message: Unable to open the system message bus.
    Source: NDesk.DBus
    Stack Trace:
    at NDesk.DBus.Bus.get_System () [0x00000] in <filename unknown>:0
    at LinWifi.LinWifi.initialize (IPluginHost host) [0x00000] in <filename unknown>:0
    at OpenMobile.Core.getEmReady () [0x00000] in <filename unknown>:0

    6702.381: ********Plugin Manager******
    Initializing OMLinPlayer
    6702.381: ********Plugin Manager******
    Initializing CDDB
    6702.497: ********Plugin Manager******
    Initializing OMMediaDB
    6702.497: ********Plugin Manager******
    Initializing RemovableDB
    6702.586: ********Plugin Manager******
    Initializing Networking
    6702.601: ********Plugin Manager******
    Initializing NewMedia
    6702.611: ********Plugin Manager******
    Initializing OMContacts
    6702.612: ********Plugin Manager******
    Initializing OMDir
    6702.718: ********Plugin Manager******
    Initializing OMNotify
    6702.719: ********Plugin Manager******
    Initializing Radio
    6702.756: ********Plugin Manager******
    Initializing OMSettings
    ------------------Software-------------------
    OS: Ubuntu 10.04.1 LTS
    Framework: Mono v2.6.7 (Debian 2.6.7-3ubuntu1~dhx1)
    Open Mobile: v0.8.1.0
    OpenGL v1.4 Mesa 7.7.1
    Graphics Engine: GreenNitrous v1
    ------------------Hardware-------------------
    Processors: 2
    6702.837: ********Plugin Manager******
    Initializing OMWeather
    Architecture: x86
    Screens: 1
    Graphics Card: Mesa DRI Intel(R) 945GM GEM 20091221 2009Q4 x86/MMX/SSE2
    Embedded:False
    ----------------Inital Assemblies-------------
    0.000: LOADED (NDesk.DBus.Proxies, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (Video, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (Slideshow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OSK, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OMWeather, Version=0.2.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OMSettings, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OMRadio, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OMNotify, Version=0.1.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OMDir, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OMContacts, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (NewMedia, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (Networking, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (RemovableDB, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OMMediaDB, Version=0.0.3.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (Mono.Posix, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756)
    0.000: LOADED (TagLib, Version=2.0.3.5, Culture=neutral, PublicKeyToken=null)
    0.001: LOADED (System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
    0.001: LOADED (Mono.Data.Tds, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756)
    0.001: LOADED (Mono.Security, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756)
    0.001: LOADED (System.Security, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
    0.001: LOADED (System.Configuration, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
    0.001: LOADED (gstreamer-sharp, Version=0.9.3.0, Culture=neutral, PublicKeyToken=4956b48baf980190)
    0.001: LOADED (glib-sharp, Version=2.12.0.0, Culture=neutral, PublicKeyToken=35e10195dab3c99f)
    0.001: LOADED (OMLinPlayer, Version=1.0.3968.28829, Culture=neutral, PublicKeyToken=null)
    0.001: LOADED (NDesk.DBus, Version=1.0.0.0, Culture=neutral, PublicKeyToken=f6716e4f9b2ed099)
    0.001: LOADED (LinWifi, Version=1.0.3968.28830, Culture=neutral, PublicKeyToken=null)
    0.001: LOADED (DPGWeather, Version=0.1.0.0, Culture=neutral, PublicKeyToken=null)
    0.001: LOADED (DPGContacts, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.001: LOADED (!OMDebug, Version=0.5.0.0, Culture=neutral, PublicKeyToken=null)
    0.001: LOADED (MainMenu, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.001: LOADED (UI, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.001: LOADED (System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
    0.001: LOADED (System.Xml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    0.001: LOADED (System.Transactions, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    0.001: LOADED (System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    0.001: LOADED (Mono.Data.Sqlite, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756)
    0.001: LOADED (System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    0.001: LOADED (OpenMobile.Graphics, Version=1.0.0.201, Culture=neutral, PublicKeyToken=null)
    0.001: LOADED (OpenMobile.Framework, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.001: LOADED (Open Mobile, Version=0.8.1.0, Culture=neutral, PublicKeyToken=null)
    0.002: LOADED (mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    ---------------------------------------------
    0.002: ********Plugin Manager******
    Initializing OMDebug
    0.006: ********Plugin Manager******
    Initializing OSK
    0.054: playlistChanged(3,)
    0.055: playlistChanged(0,)
    0.055: playlistChanged(2,)
    0.055: playlistChanged(1,)
    0.057: playlistChanged(4,)
    0.059: playlistChanged(5,)
    0.072: playlistChanged(6,)
    0.074: playlistChanged(7,)
    0.142: ********Plugin Manager******
    Initializing Slideshow
    0.142: ********Plugin Manager******
    Initializing Video
    0.229: RenderingWindowResized(0,,)
    0.278: RenderingWindowResized(0,,)
    0.294: TransitionToPanel(0,MainMenu,)
    1.144: backgroundOperationStatus(LinWifi CRASHED!,,)
    1.146: pluginLoadingComplete(,,)
    1.253: ********TaskManager******
    Task Started: Refresh Networks
    1.266: ********TaskManager******
    Task Ended: Refresh Networks
    1.266: ********TaskManager******
    Task Started: Load Plugin Settings
    1.274: ********TaskManager******
    Task Ended: Load Plugin Settings
    1.274: ********TaskManager******
    Task Started: Index Music Directory
    1.278: ********TaskManager******
    Task Ended: Index Music Directory
    1.285: ********TaskManager******
    Task Started: Delete Old Weather
    1.287: backgroundOperationStatus(Indexing Complete!,,)
    1.289: ********TaskManager******
    Task Ended: Delete Old Weather
    1.631: connectedToInternet(,,)
    1.635: ********TaskManager******
    Task Started: Sync Google Contacts
    1.668: ********TaskManager******
    Task Ended: Sync Google Contacts
    3.346: TransitionFromPanel(0,MainMenu,)
    3.347: TransitionToPanel(0,MainMenu,Settings)
    3.348: ExecuteTransition(0,None,)
    7.647: TransitionFromPanel(0,MainMenu,Settings)
    7.647: TransitionToPanel(0,MainMenu,)
    7.647: ExecuteTransition(0,None,)
    11.794: TransitionToPanel(0,MainMenu,Quit)
    12.020: ExecuteTransition(0,Crossfade,)
    12.794: ********HalInterface******
    Connection refused
    ---------
    I'll do the bumbling, and i'll be the idiot.
    if you've got a "stupid" question, search for some of mine!

Page 1 of 6 123456 LastLast

Similar Threads

  1. Om + pandaboard + ubuntu
    By Punky in forum OpenMobile
    Replies: 22
    Last Post: 04-04-2011, 04:22 AM
  2. om on the igep
    By tripzero in forum OpenMobile
    Replies: 10
    Last Post: 12-08-2010, 01:51 PM
  3. Should I move from cf to om?
    By TheGuv in forum OpenMobile
    Replies: 102
    Last Post: 10-13-2010, 09:43 PM
  4. OM won't run
    By my87ss in forum OpenMobile
    Replies: 1
    Last Post: 10-13-2010, 04:24 AM
  5. OM Install help and a couple other Qs
    By Squirtez in forum OpenMobile
    Replies: 1
    Last Post: 10-09-2010, 03:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •