Results 1 to 10 of 10

Thread: Line-in audio issues with 0.8 and new install

  1. #1
    Maximum Bitrate jmullan99's Avatar
    Join Date
    Feb 2009
    Location
    Niagara Falls, Ontario
    Posts
    553

    Line-in audio issues with 0.8 and new install

    I bit the bullet and bought a new board and chip to replace the 1.6ghz Atom board. Now using a dual core celeron at 2.5ghz on a Zotac board. All in anticipation of adding 2 zones in the rear seats.

    I did a fresh install of OM 0.8 that I had on thumb drive.

    When OM starts, I can hear the Directed HD (connected into the line-in). If I go into the Radio screen, two streams start (the familiar echo). If I exit OM the audio stops.

    I did indeed verify the "listen to this device" in the line-in properties, and it is set as the default recording device.

    I will go out and capture a debug log (shortly) to post here in case it is helpful.

    Any other ideas will be appreciated.

    Cheers,
    John

    EDIT:

    I did this twice. Once with the current fresh install, once with a re-downloaded 0.8 "just in case".

    First one:

    Code:
    ------------------Software-------------------
    OS: Windows 7
    Framework: Microsoft .Net v3.5 SP1
    Open Mobile: v0.8.0.6
    Open GL v.2.1.0 - Build 8.15.10.1855
    ------------------Hardware-------------------
    Processors: 2
    Architecture: x86
    Screens: 1
    Graphics Card: Intel(R) G45/G43 Express Chipset
    ----------------Inital Assemblies-------------
    0.000: LOADED (mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    0.000: LOADED (Open Mobile, Version=0.8.0.6, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OpenMobile.Framework, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OpenMobile.Graphics, Version=1.0.0.201, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    0.000: LOADED (Mono.Data.Sqlite, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756)
    0.000: LOADED (System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    0.062: LOADED (System.Transactions, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    0.062: LOADED (System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
    0.062: LOADED (System.Configuration, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
    0.062: LOADED (System.Xml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    0.062: LOADED (System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
    0.062: LOADED (UI, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.062: LOADED (MainMenu, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.062: LOADED (!OMDebug, Version=0.5.0.0, Culture=neutral, PublicKeyToken=null)
    0.062: LOADED (AudioRouter, Version=1.1.0.0, Culture=neutral, PublicKeyToken=null)
    0.062: LOADED (DirectShowLib-2005, Version=2.0.0.0, Culture=neutral, PublicKeyToken=67e7b740cdfc2d3f)
    0.062: LOADED (DPGWeather, Version=0.1.0.0, Culture=neutral, PublicKeyToken=null)
    0.062: LOADED (HDRadioComm, Version=1.6.0.3, Culture=neutral, PublicKeyToken=6059837a14fef3b8)
    0.062: LOADED (iPodDB, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.062: LOADED (OpenPOD, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.062: LOADED (OMMediaDB, Version=0.0.3.0, Culture=neutral, PublicKeyToken=null)
    0.062: LOADED (OMPlayer, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.062: LOADED (System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    0.062: LOADED (OMVisteonRadio, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.078: LOADED (Microsoft.VisualBasic, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
    0.078: LOADED (WinWifi, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.078: LOADED (ExternalNav, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.078: LOADED (Networking, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.078: LOADED (NewMedia, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.078: LOADED (OMDir, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.078: LOADED (OMNotify, Version=0.1.0.0, Culture=neutral, PublicKeyToken=null)
    0.078: LOADED (OMRadio, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.078: LOADED (OMSettings, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.078: LOADED (OMWeather, Version=0.2.0.0, Culture=neutral, PublicKeyToken=null)
    0.078: LOADED (OSK, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.078: LOADED (Video, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    ---------------------------------------------
    0.093: RenderingWindowResized(0,,)
    0.249: loadAVPlayer(0,OMPlayer)
    0.312: RandomChanged(0,Disabled)
    0.312: playlistChanged(0,)
    0.312: playlistChanged(1,)
    0.327: RandomChanged(1,Disabled)
    0.327: playlistChanged(2,)
    0.358: RandomChanged(2,Disabled)
    0.358: playlistChanged(3,)
    0.358: playlistChanged(4,)
    0.358: playlistChanged(5,)
    0.358: playlistChanged(6,)
    0.374: playlistChanged(7,)
    0.608: pluginLoadingComplete(,,)
    0.670: ********TaskManager******
    Task Started: Load Artists
    0.686: ********TaskManager******
    Task Ended: Load Artists
    0.686: ********TaskManager******
    Task Started: Refresh Networks
    0.702: ********TaskManager******
    Task Ended: Refresh Networks
    0.702: ********TaskManager******
    Task Started: Load Plugin Settings
    0.717: ********TaskManager******
    Task Ended: Load Plugin Settings
    0.717: ********TaskManager******
    Task Started: Index Music Directory
    0.764: ********TaskManager******
    Task Ended: Index Music Directory
    0.764: ********TaskManager******
    Task Started: Delete Old Weather
    0.764: ********TaskManager******
    Task Ended: Delete Old Weather
    0.858: connectedToInternet(,,)
    1.092: backgroundOperationStatus(Indexing Complete!,,)
    10.998: TransitionFromPanel(0,MainMenu,)
    10.998: TransitionToPanel(0,Radio,)
    10.998: unloadAVPlayer(0,)
    11.013: loadTunedContent(0,HD Radio)
    11.232: ExecuteTransition(0,Crossfade,)
    13.353: Play(0,)
    18.299: TransitionFromAny(0,,)
    18.299: TransitionToPanel(0,MainMenu,)
    18.517: ExecuteTransition(0,Crossfade,)
    19.765: TransitionToPanel(0,MainMenu,Quit)
    19.999: ExecuteTransition(0,Crossfade,)
    23.649: closeProgram(,,)
    Second one:

    Code:
    ------------------Software-------------------
    OS: Windows 7
    Framework: Microsoft .Net v3.5 SP1
    Open Mobile: v0.8.0.6
    Open GL v.2.1.0 - Build 8.15.10.1855
    ------------------Hardware-------------------
    Processors: 2
    Architecture: x86
    Screens: 1
    Graphics Card: Intel(R) G45/G43 Express Chipset
    ----------------Inital Assemblies-------------
    0.000: LOADED (mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    0.000: LOADED (Open Mobile, Version=0.8.0.6, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OpenMobile.Framework, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OpenMobile.Graphics, Version=1.0.0.201, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    0.000: LOADED (Mono.Data.Sqlite, Version=2.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756)
    0.000: LOADED (System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    0.000: LOADED (System.Transactions, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    0.000: LOADED (System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
    0.000: LOADED (System.Configuration, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
    0.000: LOADED (System.Xml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    0.000: LOADED (System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
    0.000: LOADED (UI, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (MainMenu, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (!OMDebug, Version=0.5.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (AudioRouter, Version=1.1.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (DirectShowLib-2005, Version=2.0.0.0, Culture=neutral, PublicKeyToken=67e7b740cdfc2d3f)
    0.000: LOADED (DPGWeather, Version=0.1.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (HDRadioComm, Version=1.6.0.3, Culture=neutral, PublicKeyToken=6059837a14fef3b8)
    0.000: LOADED (iPodDB, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OpenPOD, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OMMediaDB, Version=0.0.3.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OMPlayer, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089)
    0.000: LOADED (OMVisteonRadio, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (Microsoft.VisualBasic, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)
    0.000: LOADED (RemovableDB, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (WinWifi, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (ExternalNav, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (Networking, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (NewMedia, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OMDir, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OMNotify, Version=0.1.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OMRadio, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OMSettings, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OMWeather, Version=0.2.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (OSK, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    0.000: LOADED (Video, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null)
    ---------------------------------------------
    0.094: RenderingWindowResized(0,,)
    0.188: loadAVPlayer(0,OMPlayer)
    0.328: RandomChanged(0,Disabled)
    0.328: playlistChanged(0,)
    0.328: playlistChanged(1,)
    0.344: RandomChanged(1,Disabled)
    0.359: RandomChanged(2,Disabled)
    0.359: playlistChanged(2,)
    0.359: playlistChanged(3,)
    0.375: LOADED (System.Management, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a)@file:///C:/Windows/assembly/GAC_MSIL/System.Management/2.0.0.0__b03f5f7f11d50a3a/System.Management.dll
    0.406: playlistChanged(4,)
    0.406: playlistChanged(5,)
    0.406: playlistChanged(6,)
    0.406: playlistChanged(7,)
    1.951: pluginLoadingComplete(,,)
    1.966: Storage Event(NotSet,False,D:\)
    2.013: ********TaskManager******
    Task Started: Load Artists
    2.013: ********TaskManager******
    Task Ended: Load Artists
    2.013: ********TaskManager******
    Task Started: Refresh Networks
    2.044: ********TaskManager******
    Task Ended: Refresh Networks
    2.044: ********TaskManager******
    Task Started: Load Plugin Settings
    2.075: ********TaskManager******
    Task Ended: Load Plugin Settings
    2.075: ********TaskManager******
    Task Started: Index Music Directory
    2.107: ********TaskManager******
    Task Ended: Index Music Directory
    2.107: ********TaskManager******
    Task Started: Delete Old Weather
    2.107: ********TaskManager******
    Task Ended: Delete Old Weather
    2.231: connectedToInternet(,,)
    2.387: backgroundOperationStatus(Indexing Complete!,,)
    2.668: Storage Event(LocalHardware,False,D:\)
    10.421: TransitionFromPanel(0,MainMenu,)
    10.421: TransitionToPanel(0,Radio,)
    10.421: unloadAVPlayer(0,)
    10.437: loadTunedContent(0,HD Radio)
    10.655: ExecuteTransition(0,Crossfade,)
    14.399: TransitionFromAny(0,,)
    14.399: TransitionToPanel(0,MainMenu,)
    14.618: ExecuteTransition(0,Crossfade,)
    15.788: Play(0,)
    17.644: TransitionToPanel(0,MainMenu,Quit)
    17.863: ExecuteTransition(0,Crossfade,)
    20.920: closeProgram(,,)
    Please note all I did was start OM, wait for the audio to start, select Radio, Home, Exit, Quit.

    Cheers.
    John
    ZOTAC G43ITX-A-E 2.5ghz Core i3 2GB 160GB SSD
    Win7 Ultimate - OpenMobile - Directed HD - Wifi
    OMMaps + MS GPS Puck - WiFi via LTE Android phone
    2 Zones - Matrix Orbital LCD - Arduino - Build Pics

  2. #2
    Variable Bitrate heezer7's Avatar
    Join Date
    May 2004
    Location
    IL, USA
    Posts
    255
    K, I'll try to take a look at it tonight and see if I see anything. Have been swamped with work and a few other projects lately. My radio is actually not working at all so need to debug that first. Not sure if the radio died or the serial port or what. Found the original controller last night but didn't get around to testing it.

  3. #3
    Maximum Bitrate jmullan99's Avatar
    Join Date
    Feb 2009
    Location
    Niagara Falls, Ontario
    Posts
    553
    Quote Originally Posted by heezer7 View Post
    K, I'll try to take a look at it tonight and see if I see anything. Have been swamped with work and a few other projects lately. My radio is actually not working at all so need to debug that first. Not sure if the radio died or the serial port or what. Found the original controller last night but didn't get around to testing it.
    Sorry to hear about the radio. Makes it hard to troubleshoot the software.
    ZOTAC G43ITX-A-E 2.5ghz Core i3 2GB 160GB SSD
    Win7 Ultimate - OpenMobile - Directed HD - Wifi
    OMMaps + MS GPS Puck - WiFi via LTE Android phone
    2 Zones - Matrix Orbital LCD - Arduino - Build Pics

  4. #4
    Variable Bitrate heezer7's Avatar
    Join Date
    May 2004
    Location
    IL, USA
    Posts
    255
    Yeah, not sure what is going on with it. Just haven't had the time to look at it.

  5. #5
    Variable Bitrate heezer7's Avatar
    Join Date
    May 2004
    Location
    IL, USA
    Posts
    255
    Confirmed my radio itself still works so either the cable or the serial port adapter died. Need to swap in the old carpc to see. Will attempt to try it over the weekend.

  6. #6
    Maximum Bitrate jmullan99's Avatar
    Join Date
    Feb 2009
    Location
    Niagara Falls, Ontario
    Posts
    553
    Quote Originally Posted by heezer7 View Post
    Confirmed my radio itself still works so either the cable or the serial port adapter died. Need to swap in the old carpc to see. Will attempt to try it over the weekend.
    Good news on the radio. Easier (read: cheaper) to swap out the cable. My new Zotac board had no external RS232 so I too am using a USB-to-SERIAL adapter-to-Mitch's cable which works flawlessly right now.

    NOTE for Others: The follow is partially a re-cap of the issue from other threads.

    As soon as I am able, I am going to try the audio driver from Zotac's website. Perhaps on my lunch break. Who knows how old the driver is on the supplied CD. And I recall that there was more than one option on how to install that so maybe I picked an inferior option. I have no way to tell at the moment.

    However, I have always had a line-in after hibernate issue with OM. Now on 3 different hardware platforms (the orignal Atom, my Acer dual-core laptop and now this Zotac board). And it may not be the HD Radio part, but it's the only plug-in making use of Line-In. And Mitches app doesn't seem to suffer this issue.

    This brings me to ask your (or anyone's) opinion:

    • Could the fact that the Line-In is "in use" during hibernation cause a problem when resuming from hibernation?
    • Does Windows or the hardware say "oh, there is active signal there so remember that"?
    • Does Windows itself say "somebody is using Line-In so remember that"?

    I do not know the actual mechanics behind this type of situation.

    John
    ZOTAC G43ITX-A-E 2.5ghz Core i3 2GB 160GB SSD
    Win7 Ultimate - OpenMobile - Directed HD - Wifi
    OMMaps + MS GPS Puck - WiFi via LTE Android phone
    2 Zones - Matrix Orbital LCD - Arduino - Build Pics

  7. #7
    Maximum Bitrate jmullan99's Avatar
    Join Date
    Feb 2009
    Location
    Niagara Falls, Ontario
    Posts
    553
    We may be able to close this specific issue. And I feel rather bad if I raised any red flags.

    I re-ran the audio driver install. It removed itself, reboot, installed itself, reboot, and the funky echo disappeared.

    Now, I am sure I installed the driver correctly the first time, but hey, these kind of things seem to creep in.

    While I am still left with the original line-in issue (no HD Audio on resume), the 2-in-1 audio stream is gone.

    I am now back to where I was with the old Atom board. Except noticably faster

    Woo hoo.


    John
    ZOTAC G43ITX-A-E 2.5ghz Core i3 2GB 160GB SSD
    Win7 Ultimate - OpenMobile - Directed HD - Wifi
    OMMaps + MS GPS Puck - WiFi via LTE Android phone
    2 Zones - Matrix Orbital LCD - Arduino - Build Pics

  8. #8
    Variable Bitrate heezer7's Avatar
    Join Date
    May 2004
    Location
    IL, USA
    Posts
    255
    Damn, I thought this had fixed the resume. Guess I read wrong. At least the echo is fixed. So you are a no on 3 setups and I am a yes on 2 but with the same usb sound card. Once I get it fixed I will try it on the internal card and see if it resumes ok there. All too weird.

  9. #9
    Maximum Bitrate jmullan99's Avatar
    Join Date
    Feb 2009
    Location
    Niagara Falls, Ontario
    Posts
    553
    DOH! Sorry if I mis-led you somehow. But we'll get there.

    Another plus for me is that I now no longer get any pop sound between some tracks.

    I am begining to think that even though an Atom may have enough oomph to handle at least one zone, my previous board ( even being Intel ) was somewhat inferior quality.

    The bummer is that my new board + chip cost not much more than it cost me to take delivery of the original board.

    Oh well. I look forward to your progress report of anything you get to accomplish this weekend


    Cheers,
    John
    ZOTAC G43ITX-A-E 2.5ghz Core i3 2GB 160GB SSD
    Win7 Ultimate - OpenMobile - Directed HD - Wifi
    OMMaps + MS GPS Puck - WiFi via LTE Android phone
    2 Zones - Matrix Orbital LCD - Arduino - Build Pics

  10. #10
    Variable Bitrate heezer7's Avatar
    Join Date
    May 2004
    Location
    IL, USA
    Posts
    255
    nah, mostly me being stupid. Been a loooooooong week. Good to hear the pop is gone.

Similar Threads

  1. NE1 do a New Beetle Install?
    By ATRT Rob in forum General Hardware Discussion
    Replies: 2
    Last Post: 12-02-2003, 12:30 PM
  2. New install this weekend...Which OS should I load?
    By -al- in forum Software & Software Development
    Replies: 51
    Last Post: 09-27-2003, 06:58 PM
  3. 1990 Celica GT - New Install
    By HereFishyFishy in forum Show off your project
    Replies: 16
    Last Post: 09-08-2003, 12:15 AM
  4. New Audio Control Overdrive Linedriver FS
    By outragis in forum Classified Archive
    Replies: 9
    Last Post: 05-04-2003, 12:27 PM
  5. New install pics
    By ppgt94 in forum General MP3Car Discussion
    Replies: 4
    Last Post: 08-13-2001, 12:25 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •