Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 48

Thread: Om on BeagleBoard XM

  1. #21
    Constant Bitrate smp4488's Avatar
    Join Date
    Oct 2007
    Location
    Louisville, KY
    Posts
    119
    Code:
    Exception
    
    Exception Message: Failed to retrieve GraphicsMode configurations, error 12288, 9 configs available
    
    Source: OpenMobile.Graphics
    
    Stack Trace: 
    
      at OpenMobile.Platform.Egl.EglGraphicsMode.SelectGraphicsMode (ColorFormat color, Int32 depth, Int32 stencil, Int32 samples, ColorFormat accum, Int32 buffers, Boolean stereo) [0x00000] in <filename unknown>:0 
      at OpenMobile.Platform.Egl.EglContext..ctor (OpenMobile.Graphics.GraphicsMode mode, OpenMobile.Platform.Egl.EglWindowInfo window, IGraphicsContext sharedContext, Int32 major, Int32 minor, GraphicsContextFlags flags) [0x00000] in <filename unknown>:0 
      at OpenMobile.Platform.Egl.EglX11PlatformFactory.CreateGLContext (OpenMobile.Graphics.GraphicsMode mode, IWindowInfo window, IGraphicsContext shareContext, Boolean directRendering, Int32 major, Int32 minor, GraphicsContextFlags flags) [0x00000] in <filename unknown>:0 
      at OpenMobile.Graphics.GraphicsContext..ctor (OpenMobile.Graphics.GraphicsMode mode, IWindowInfo window, Int32 major, Int32 minor, GraphicsContextFlags flags) [0x00000] in <filename unknown>:0 
      at OpenMobile.Graphics.GraphicsContext..ctor (OpenMobile.Graphics.GraphicsMode mode, IWindowInfo window) [0x00000] in <filename unknown>:0 
      at OpenMobile.GameWindow.Initialize () [0x00000] in <filename unknown>:0
    I am also now getting assembly not found errors in the terminal. NDesk.DBus.GLib

  2. #22
    Raw Wave
    Auto Apps:loading...
    justchat_1's Avatar
    Join Date
    Jul 2008
    Location
    Boston, Ma or NY,NY
    Posts
    1,783
    Quote Originally Posted by smp4488 View Post
    Code:
    Exception
    
    Exception Message: Failed to retrieve GraphicsMode configurations, error 12288, 9 configs available
    
    Source: OpenMobile.Graphics
    
    Stack Trace: 
    
      at OpenMobile.Platform.Egl.EglGraphicsMode.SelectGraphicsMode (ColorFormat color, Int32 depth, Int32 stencil, Int32 samples, ColorFormat accum, Int32 buffers, Boolean stereo) [0x00000] in <filename unknown>:0 
      at OpenMobile.Platform.Egl.EglContext..ctor (OpenMobile.Graphics.GraphicsMode mode, OpenMobile.Platform.Egl.EglWindowInfo window, IGraphicsContext sharedContext, Int32 major, Int32 minor, GraphicsContextFlags flags) [0x00000] in <filename unknown>:0 
      at OpenMobile.Platform.Egl.EglX11PlatformFactory.CreateGLContext (OpenMobile.Graphics.GraphicsMode mode, IWindowInfo window, IGraphicsContext shareContext, Boolean directRendering, Int32 major, Int32 minor, GraphicsContextFlags flags) [0x00000] in <filename unknown>:0 
      at OpenMobile.Graphics.GraphicsContext..ctor (OpenMobile.Graphics.GraphicsMode mode, IWindowInfo window, Int32 major, Int32 minor, GraphicsContextFlags flags) [0x00000] in <filename unknown>:0 
      at OpenMobile.Graphics.GraphicsContext..ctor (OpenMobile.Graphics.GraphicsMode mode, IWindowInfo window) [0x00000] in <filename unknown>:0 
      at OpenMobile.GameWindow.Initialize () [0x00000] in <filename unknown>:0
    I am also now getting assembly not found errors in the terminal. NDesk.DBus.GLib
    Alright thats better.... your average desktop has between 50 and 130 supported configurations. The BeagleBoard has 9 and we didn't like any of them.

    Instead of the guess and check thing... and since no one has yet written a tool to do this...heres a custom tool to check what your graphics card supports and what versions of what are currently installed.
    Attached Files Attached Files

  3. #23
    Constant Bitrate smp4488's Avatar
    Join Date
    Oct 2007
    Location
    Louisville, KY
    Posts
    119
    Code:
    OpenGL ES v1.4 Supported!
    
    Vendor: Imagination Technologies
    Version: 1.4 build 1.4.14.2616
    Renderer: 
    Extensions: EGL_KHR_image
    EGL_KHR_image_base
    EGL_KHR_gl_texture_2D_image
    EGL_KHR_gl_texture_cubemap_image
    EGL_KHR_gl_renderbuffer_image
    EGL_KHR_vg_parent_image
    EGL_IMG_context_priority
    
    
    9 configurations available
    ------------------
    Alpha Size: 0
    Blue Size: 5
    Green Size: 6
    Red Size: 5
    Depth Size: 24
    Renderable Type: 3
    ---
    
    Alpha Size: 0
    Blue Size: 5
    Green Size: 6
    Red Size: 5
    Depth Size: 0
    Renderable Type: 3
    ---
    
    Alpha Size: 0
    Blue Size: 5
    Green Size: 6
    Red Size: 5
    Depth Size: 24
    Renderable Type: 3
    ---
    
    Alpha Size: 8
    Blue Size: 8
    Green Size: 8
    Red Size: 8
    Depth Size: 24
    Renderable Type: 3
    ---
    
    Alpha Size: 0
    Blue Size: 5
    Green Size: 6
    Red Size: 5
    Depth Size: 24
    Renderable Type: 3
    ---
    
    Alpha Size: 4
    Blue Size: 4
    Green Size: 4
    Red Size: 4
    Depth Size: 24
    Renderable Type: 1
    ---
    
    Alpha Size: 0
    Blue Size: 5
    Green Size: 6
    Red Size: 5
    Depth Size: 24
    Renderable Type: 6
    ---
    
    Alpha Size: 0
    Blue Size: 5
    Green Size: 6
    Red Size: 5
    Depth Size: 0
    Renderable Type: 6
    ---
    
    Alpha Size: 0
    Blue Size: 5
    Green Size: 6
    Red Size: 5
    Depth Size: 24
    Renderable Type: 6
    ---

  4. #24
    Raw Wave
    Auto Apps:loading...
    justchat_1's Avatar
    Join Date
    Jul 2008
    Location
    Boston, Ma or NY,NY
    Posts
    1,783
    As if its not hard enough...theres a bug in the driver. It reports 32bit support for openGL 1.0 but only 16bit video support for openGL 2.0 which is clearly not true. I submitted a bug report but until then i think I have a workaround. Try revision 604 and if that doesn't work i'll just manually configure the cards.

  5. #25
    Constant Bitrate smp4488's Avatar
    Join Date
    Oct 2007
    Location
    Louisville, KY
    Posts
    119
    I tried to run build 607 first and this is the terminal output.

    Code:
    X Error of failed request:  BadWindow (invalid Window parameter)
      Major opcode of failed request:  20 (X_GetProperty)
      Resource id in failed request:  0x3200002
      Serial number of failed request:  49
      Current serial number in output stream:  49
    I then tried to run build 604 and i got missing assembly error again. I also get the missing assembly error while trying to run build 607. There are app crash logs for each build containing the same error in post #21.

  6. #26
    Raw Wave
    Auto Apps:loading...
    justchat_1's Avatar
    Join Date
    Jul 2008
    Location
    Boston, Ma or NY,NY
    Posts
    1,783
    The missing assembly is package: libndesk-dbus-glib1.0-cil but thats not the problem just a warning that om disables features without it.

    Ughh....that was the last of all possible values. Alright i'll work out a manual initialization function for the graphics card since the graphics card can't seem to do it without going to 16bit.

  7. #27
    Raw Wave
    Auto Apps:loading...
    justchat_1's Avatar
    Join Date
    Jul 2008
    Location
    Boston, Ma or NY,NY
    Posts
    1,783
    Added in rev 608.... lets see how far we get now

  8. #28
    Constant Bitrate smp4488's Avatar
    Join Date
    Oct 2007
    Location
    Louisville, KY
    Posts
    119
    The error number has changed from 12288 to 12297

    Failed to create EGL window surface, error 12297

  9. #29
    Raw Wave
    Auto Apps:loading...
    justchat_1's Avatar
    Join Date
    Jul 2008
    Location
    Boston, Ma or NY,NY
    Posts
    1,783
    Quote Originally Posted by smp4488 View Post
    The error number has changed from 12288 to 12297

    Failed to create EGL window surface, error 12297
    Alright made it to step 4/5....now just to get past this last issue.


    New Graphics Explorer attached - need more info on the graphics chips capabilities
    Attached Files Attached Files

  10. #30
    Constant Bitrate smp4488's Avatar
    Join Date
    Oct 2007
    Location
    Louisville, KY
    Posts
    119
    For some reason i cant copy the output from the graphicsexplorer. The last line says: OpenGL Not Supported!

Page 3 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. Replies: 42
    Last Post: 12-11-2009, 02:36 PM
  2. Got XM to work, then it took a dump
    By DuDs in forum StreetDeck
    Replies: 3
    Last Post: 05-06-2006, 05:42 PM
  3. XM Channel Changes
    By Chuck in forum Road Runner
    Replies: 2
    Last Post: 04-05-2006, 04:33 AM
  4. XM Satellite Radio to Unveil XM Advanced Services at 2006 Consumer
    By Will Albers in forum General MP3Car Discussion
    Replies: 2
    Last Post: 03-27-2006, 08:49 PM
  5. Using an XM direct as an XMPCR
    By dacndar in forum General Hardware Discussion
    Replies: 20
    Last Post: 10-17-2004, 01:21 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •