Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Need assistance improving boot time - Windows Xp - 12s

  1. #1
    Newbie
    Join Date
    Jan 2008
    Posts
    10

    Need assistance improving boot time - Windows Xp - 12s

    [Edited with updated info]
    I have run into a brick wall trying to improve Windows XP boot time.

    The problem i am having is that my CF card is increasing boot/hibernate time rather than decreasing it

    This is a list of things i have which are available.

    Hardware:
    AMD Wafer-LX 500Mhz
    256 / 512 / 1024 mb ram
    80gb samsung HD / 20gb hitachi HD / 4gb Sandisk Extreme IV CF
    (it has both a IDE cable and a IDE CF slot)

    Software:
    Windows XP (nlited)
    12 services running
    Minlogon
    EWF
    HORM

    Specific Programs:
    VLC
    Winamp
    Firefox

    Nlite install(192mb) - Windows XP installed 300-350mb.

    POST is 5-6 seconds!

    XP Boot / Hibernate (with post)
    With HDD - Boot time 20-24 seconds, hibernate 12 seconds
    With CF - Boot time 20-25 seconds, hibernate 19 seconds

    With a specially built linux this setup boots in 7-8 seconds with post.(including GUI)

    I would really like to get XP under 10s from hibernate.

    The Boot time increase occurs when the Windows XP loading screen is (blue cubes scrolling from left to right)

    HDtach says - HDD 31mb/s - CF 29mb/s

    Bios says - HDD / CF both run in UDMA

    The problem i am having is that the CF card is increasing my boot rather rather than improving it. I believe it should not.

    So far these are the things i have tried to reduce boot time:
    1) Changed memory modules , it does not change anything regarding hibernate speed.
    2) Changed the default windows shell (explorer.exe)
    3) Tried with/without horm/ewf did not matter
    4) Tried using a sata-cf converter, made it worse
    5) Multiple tests with network(disable) , did not yield any definite results

    I did attempt more things , dont think they are noteworthy.

    What i am thinking may be wrong is that Windows XP is using a lesser driver when loading XP from CF than HDD. Perhaps the driver that NTLDR uses could be changed to a better one ?

    However at this point any idears are welcome.

    [Update]
    Using bootvis i can see that my CF card has a 9 second delay after it loads ISAPNP.SYS
    Next it loads scsiport.sys and after that everything is normal.

    Does anyone know exacly what happends when ISAPNP.SYS loads that would affect my CF but not my HDD ?

  2. #2
    Maximum Bitrate jonessc's Avatar
    Join Date
    Nov 2006
    Location
    Wales, UK
    Posts
    787
    Post your LastSession.ini and ill see if theres anything that can speed things ups

    I have my setup running on as little as 3 services, and just bare to run ok approx 60mb RAM without loading any of the main software of course.

    Im using a 5400 2.5" laptop hard drive which is fast, im just experimenting with CF cards at the moment with EWF
    CarPuter Progress:
    Planning:-----> [||||||||||] 100%
    Hardware Buying:-> [||||||||||] 100%
    Software:-----> [||||||||||] 100%
    Installing:-----> [||||||||||] 100%
    Current Project= Making skins in photoshop...

  3. #3
    Maximum Bitrate galvitron's Avatar
    Join Date
    Mar 2007
    Location
    Socal
    Posts
    719
    The CF card adapter has to initialize. This takes more time than without the adapter. This is probably why your boot time is now taking longer.
    2006 Lancer Evolution IX MR In-Dash PC Project - WIP

    Planning:
    [----------] 100%
    Purchasing:
    [----------] 90%
    Installation/Fab/Assembly (Revised v2):
    [----------] 90%


  4. #4
    Newbie
    Join Date
    Jan 2008
    Posts
    10

    Lastsession.ini Hiddenh

    [Main]
    Env = 1.4.1 - 2.0.50727.42.Microsoft Windows NT 5.1.2600 Service Pack 2
    Target = Windows XP Professional SP2 - 5.1.2600.2180 - English (United States)

    [Tasks]
    Remove Components
    Integrate Drivers
    Tweaks
    Options

    [Components]
    ;# Compatibility #
    Compat02
    Compat11

    [KeepFiles]
    msconfig.exe

    [RemoveFiles]
    clock.avi
    yahoo.bmp
    swtchbrd.bmp

    [Options]
    CABNoHigh
    DisableFreereq
    DisableMinMem
    ProfilesDir = "%SystemDrive%\Documents and Settings"
    TargetPath = "WINDOWS"
    temp_dir = %USERPROFILE%\Local Settings\Temp
    NoWmpComp
    AdvTweaks

    [Patches]

    [Services2]
    AppMgmt,4
    ClipSrv,4
    EventSystem,4
    COMSysApp,3
    Browser,3
    CryptSvc,2
    DHCP,2
    MSDTC,4
    DNSCACHE,3
    Eventlog,3
    FastUserSwitchingCompatibility,4
    HTTPFilter,3
    HidServ,2
    NetLogon,3
    NetBT,3
    Netman,4
    NetDDE,4
    NetDDEdsdm,4
    NLA,4
    xmlprov,3
    NtLmSsp,4
    SysmonLog,4
    PlugPlay,2
    Spooler,3
    ProtectedStorage,4
    RDSessMgr,4
    RpcLocator,2
    RemoteAccess,4
    SamSs,3
    LanmanServer,3
    ShellHWDetection,4
    SENS,4
    LMHosts,3
    TapiSrv,4
    TermService,4
    Themes,4
    WebClient,3
    AudioSrv,2
    SharedAccess,4
    StiSvc,3
    MSIServer,3
    winmgmt,3
    Wmi,3
    WZCSVC,3
    WmiApSrv,3
    LanmanWorkstation,2

    [Tweaks]
    Desktop-My Computer icon-Show
    Desktop-My Documents icon-Hide
    Desktop-My Network Places icon-Hide
    Desktop-Recycle Bin icon-Hide
    Explorer-Change Windows Explorer folder view-Details
    Explorer-Classic Control Panel
    Explorer-Disable Autorun
    Explorer-Disable Beep on errors
    Explorer-Disable Prefix: Shortcut to
    Explorer-Disable shortcut arrow
    Explorer-Disable Web Files and Folders connection
    Explorer-Display the contents of system folders
    Explorer-Recycle Bin: delete files directly
    Explorer-Remove Send To on context menu
    Explorer-Show extensions of known file-types
    Explorer-Show hidden files and folders
    Explorer-Show protected operating system files
    My Computer-Remove Manage from Context Menu
    My Computer-Remove Search from Context Menu
    My Computer-Remove Shared Documents
    Network-Allow receiving Remote Assistance-Disable
    Network-Disable automatic search for network folders and printers
    Network-Disable LM HOSTS lookup
    Network-Disable Simple File Sharing
    Network-Remote Desktop-Disable
    Performance-Disable Info Tips on Files and Folders
    Performance-Disable Last accessed Timestamp on files
    Performance-Disable Optimize harddisk when idle
    Performance-Disable paging of kernel and core-os
    Performance-Disable Tracking of Broken Shortcut Links
    Performance-Disable Warn on low disk space
    Performance-Do not cache thumbnails
    Privacy-Disable Driver Update Internet prompt
    Privacy-Remove Alexa
    Start Menu-Disable popup on first boot
    Start Menu-Do not use Personalized Menus
    Start Menu-Hide Search button in Start Panel
    Start Menu-My Computer-Display as a menu
    Start Menu-My Documents-Don't display this item
    Start Menu-My Music-Don't display this item
    Start Menu-My Network Places-Don't display this item
    Start Menu-My Pictures-Don't display this item
    Start Menu-Network Connections-Don't display this item
    Start Menu-Printers and Faxes-Don't display this item
    Start Menu-Reduce popup delay
    Start Menu-Remove Search the Internet from Search
    Start Menu-Remove Set Program Access and Defaults
    Taskbar-Disable Balloon Tips
    Taskbar-Disable Group similar Taskbar buttons
    Taskbar-Disable Hide inactive icons
    Taskbar-Hide Volume Control Icon in System Tray
    Visual Effects-Active window tracking-Disable
    Visual Effects-Active window tracking speed-Zero delay
    Visual Effects-Animate windows when minimizing and maximizing-Disable
    Visual Effects-Combo box animation-Disable
    Visual Effects-Cursor shadow-Disable
    Visual Effects-Display mouse pointer trails-Disable
    Visual Effects-Fade out selection-Disable
    Visual Effects-Gradient captions in windows-Disable
    Visual Effects-Keyboard shortcut underline-Disable
    Visual Effects-Menu animation-Disable
    Visual Effects-Menu shadows-Disable
    Visual Effects-Show translucent selection rectangle-Disable
    Visual Effects-Show window contents while dragging-Disable
    Visual Effects-Slide taskbar buttons-Disable
    Visual Effects-Smooth edges of screen fonts-ClearType
    Visual Effects-Smooth-scroll list boxes-Disable
    Visual Effects-Tooltip animation-Disable
    Visual Effects-Use a background image for each folder type-Disable
    Visual Effects-Use drop shadows for icon labels on the desktop-Disable

    [Unattended]
    ComputerType = Default
    MaximumDataStorePercentOfDisk = 12
    RestorePointLife = 30
    DesktopTheme = Default||
    AutoUDay = 5
    AutoUHour = 15
    ProgFilesPath = "\Program Files"

    [NetAdapter1]
    connname = ""
    macaddress = ""
    ipaddress = "192.168.0.1"
    subnetmask = "255.255.255.0"
    defaultgateway = ""
    dnsserver1 = ""
    dnsserver2 = ""
    winsserver = ""
    netbiossetting = "0"
    ipxnetworknumber = "00000000"
    ipxnetworkframetype = "0xFF"

    [GuiRunOnce]

    [Drivers]
    D:\Windows XP Small\Wafer LX Drivers\WAFER-LX-R10_Driver_SATA_ALi_M5283\ALi_SATA_M5283\win_xp\m5 228.INF,m5281XP
    D:\Windows XP Small\Wafer LX Drivers\WAFER-LX_Driver_Audio_XP_GeodeLX_WDM_v2.03.00\GeodeLX_XP _XPe_WDM_Audio_v2.03.00\LXWDMAu.inf,0
    D:\Windows XP Small\Wafer LX Drivers\WAFER-LX-R10_Driver_Ethernet_WinXP-98-2k_RTL8100C_V6.21\RTL8100C Windows_XP_98SE_ME_2K V6.21\WinXP\NetrtOEM.inf,0
    D:\Windows XP Small\Wafer LX Drivers\WAFER-LX-R10_Driver_IT8888\IT8888\ite.inf,0
    D:\Windows XP Small\Wafer LX Drivers\WAFER-LX-R10_Driver_IT8888\IT8888\GeodeLX_XP_WDM_AES_v2.01. 00\LXAES.inf,0
    D:\Windows XP Small\Wafer LX Drivers\WAFER-LX_Driver_VGA_WinXP_Norwich_Graphics_v3.00.02\Geod eLX_XP_XPe_Graphics_v3.00.02\lx_win.inf,0

    [Hotfixes]

  5. #5
    Maximum Bitrate galvitron's Avatar
    Join Date
    Mar 2007
    Location
    Socal
    Posts
    719
    Looks like a pretty lean .ini... You might shave another 0.5 sec. playing with Windows and trying to optimize this file.

    You might get more Gain toolin' around in your BIOS. What MB? Try setting the hard drive auto-detects to manual pre-sets. Shave like a second off depending on your board.
    2006 Lancer Evolution IX MR In-Dash PC Project - WIP

    Planning:
    [----------] 100%
    Purchasing:
    [----------] 90%
    Installation/Fab/Assembly (Revised v2):
    [----------] 90%


  6. #6
    Newbie
    Join Date
    Jan 2008
    Posts
    10
    Update:

    I have gotten hibernate boot times from CF down to only 12 seconds(6sek post, 6sec windows load).

    I dont have it certain but i think this has something to do with CF + Hibernate + Minlogon + EWF.
    Not sure yet but it think this is what i have to do when i have everything set up. Hibernate the computer untill it does quick restore from hibernate(12 sec instead of 18) and then put EWF back on so windows wont overwrite the hibernate file.(which i currently only have 1 copy of) - so far i have reboot perhaps 200 times and only got maybe 5 quick hibernate files.

    Memory usage is only 60-73mb depending on if i have Wireless or not.

    My highest priority now is finding out what does make some hibernates fasters than others and reducing the size of XP even further (deleting OEMBIOS and such)

    galvitron:
    I guess its doubtful that it is the "initialization" of the CF adapter since this appearantly does not happend everytime i hibernate.

  7. #7
    Maximum Bitrate galvitron's Avatar
    Join Date
    Mar 2007
    Location
    Socal
    Posts
    719
    A system boot taking inconsistent times is usually related to the last peripheral device you plugged in.
    2006 Lancer Evolution IX MR In-Dash PC Project - WIP

    Planning:
    [----------] 100%
    Purchasing:
    [----------] 90%
    Installation/Fab/Assembly (Revised v2):
    [----------] 90%


  8. #8
    Newbie
    Join Date
    Jan 2008
    Posts
    10
    Alright.

    Connected items areall USB)
    Mouse, Keyboard , Speakers , Hub , Thumb Drive , Wireless Card.

    This would either be the mouse or keyboard since this problem has exists way before i started using the other items.

    However my last successful Hibernate file has keyboard and mouse loaded.

    Could it be caused by them in some wierd way ?

  9. #9
    Maximum Bitrate galvitron's Avatar
    Join Date
    Mar 2007
    Location
    Socal
    Posts
    719
    USB is a nightmare. All software controlled which means bugs. Unplug all USB and see if anything changes.
    2006 Lancer Evolution IX MR In-Dash PC Project - WIP

    Planning:
    [----------] 100%
    Purchasing:
    [----------] 90%
    Installation/Fab/Assembly (Revised v2):
    [----------] 90%


  10. #10
    Newbie
    Join Date
    Jan 2008
    Posts
    10
    Not possible im afraid, This is a EBC Wafer-LX
    http://www.ieiworld.com/en/Product_I...model=WAFER-LX

    Only ports i have are 4x usb and one RS-232

    And i need the keyboard and mouse to shut down / hibernate the computer.

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 14
    Last Post: 09-11-2008, 03:14 PM
  2. Invalid Argument
    By tn6478 in forum StreetDeck
    Replies: 20
    Last Post: 12-30-2007, 08:02 PM
  3. Using DOS and 98 at once, can I toggle at boot time with a keypress?
    By bombboyer in forum Software & Software Development
    Replies: 7
    Last Post: 04-07-2003, 11:13 PM
  4. boot times with XP
    By Alives in forum General Hardware Discussion
    Replies: 2
    Last Post: 11-15-2001, 12:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •