Page 7 of 39 FirstFirst 1234567891011121314151617 ... LastLast
Results 61 to 70 of 388

Thread: Archive

  1. #61
    Phone Control Moderator zorro's Avatar
    Join Date
    Mar 2004
    Location
    Munich, Germany
    Posts
    1,902
    Quote Originally Posted by lanpa16
    Hi, Zorro,

    Chinese characters are displayed perfectly after your suggestion!



    But PhoCo doesn't automatically created a PhoneCtl.PB.xml compatable with Dual Byte Character Set... which means I'll have to modified that .mxl file, 'Cause these characters become "???" in PhoneCtl.PB.xml when PhoCo trys to read my phonebook in T610 ... Would you please add this function in the future version? Thanks.

    Bob
    Glad to hear that.
    I will build it into the next release. Which characterset and which font did you use?
    Skinning to go... VisualDesigner2!

  2. #62
    Newbie
    Join Date
    Jun 2004
    Location
    Taiwan
    Posts
    17
    It's "BIG5". ( "gb2312" didn't work)
    Thanks, Zorro.

    Bob

  3. #63
    Phone Control Moderator zorro's Avatar
    Join Date
    Mar 2004
    Location
    Munich, Germany
    Posts
    1,902
    Quote Originally Posted by lanpa16
    It's "BIG5". ( "gb2312" didn't work)
    Thanks, Zorro.

    Bob
    Ok Bob, thanks. BTW: Did you do a translation to the GUI elements as well? If so, can you send me the config file with the text?

    Just for the record and anyone who wants to use a Chinese character set until the new version is released, do the following:
    1. Put this line as the very first line into your PhoneCtl.PB.xml <?xml version="1.0" encoding="BIG5"?>
    2. Edit the design with Visual Designer and set the font for the phonebook to a font which supports Chinese characters.
    Skinning to go... VisualDesigner2!

  4. #64
    Newbie
    Join Date
    Jun 2004
    Location
    Taiwan
    Posts
    17
    Quote Originally Posted by zorro
    Ok Bob, thanks. BTW: Did you do a translation to the GUI elements as well? If so, can you send me the config file with the text?

    Just for the record and anyone who wants to use a Chinese character set until the new version is released, do the following:
    1. Put this line as the very first line into your PhoneCtl.PB.xml <?xml version="1.0" encoding="BIG5"?>
    2. Edit the design with Visual Designer and set the font for the phonebook to a font which supports Chinese characters.
    I just did a little bit...

    Characters become "???" as PhoCo reading the phonebook from my T610...


    The SMS editor ( PhoneCtl.PB.xml modified )


    Here goes my config. files:

    PhoneCtl.Config.xml
    PhoneCtl.Design1.xml

    BTW, "BIG5" is for Traditional Chinese Characters used in Taiwan and Hong-Kong only.
    Battery seems lost...

  5. #65
    Phone Control Moderator zorro's Avatar
    Join Date
    Mar 2004
    Location
    Munich, Germany
    Posts
    1,902
    Quote Originally Posted by lanpa16
    Characters become "???" as PhoCo reading the phonebook from my T610...
    You have to set the appropriate characterset for the phone as well (tag <UseCharset>). The only one I can suggest is "ERICSSON"... cause I ain't see anything else in the specification
    To figure out what charsets your phone is supporting, open a session with HyperTerminal and key in the command "AT+CSCS=?". If there's one listed that is more appropriate, use this one.
    Battery seems lost...
    Battery-Symbol is only displayed, if your phone is running on battery (i.e. it's not beeing charged) and the battery level drops below 60%. Otherwise you won't see it.

    Thanks for your Config file.
    Skinning to go... VisualDesigner2!

  6. #66
    Newbie
    Join Date
    Jun 2004
    Location
    Taiwan
    Posts
    17
    Quote Originally Posted by zorro
    You have to set the appropriate characterset for the phone as well (tag <UseCharset>). The only one I can suggest is "ERICSSON"... cause I ain't see anything else in the specification
    To figure out what charsets your phone is supporting, open a session with HyperTerminal and key in the command "AT+CSCS=?". If there's one listed that is more appropriate, use this one.
    Well, non of them works... still trying...




    Bob

  7. #67
    Phone Control Moderator zorro's Avatar
    Join Date
    Mar 2004
    Location
    Munich, Germany
    Posts
    1,902
    Quote Originally Posted by lanpa16
    Well, non of them works... still trying...




    Bob
    I'm afraid, you won't be able to get it correct frrom the phone, as long as it doesn't support a Chinese character set.

    I'm not quite sure, but it might be different with the T618, which is the counterpart of the T610 for the Chinese market.
    Skinning to go... VisualDesigner2!

  8. #68
    Newbie
    Join Date
    Jun 2004
    Location
    las vegas nv.
    Posts
    20

    pbconverter not launching


  9. #69
    FLAC robiewp's Avatar
    Join Date
    Dec 2003
    Location
    Massachusetts, US
    Posts
    958
    I thank you for your equally inquisitive and informative post. 0=0
    car computer rev 5: 8" lilliput and usual suspects

  10. #70
    Newbie
    Join Date
    Jun 2004
    Location
    las vegas nv.
    Posts
    20
    oops, guess what i am new at this.First of all thank you for this program zorro.I have phone control up and running but am having trouble with pbconverter.Could you if its not too much trouble list the steps for dummies to using the converter on csv files.I read the documents you made but was confused,Irealise this was written mostly for bluetooth.I am not too familiar with the command prompt commands.Phone is lg vx4500 cable from verizon connectivity kit.
    When i hit the pbconverter.exe command prompt appears for a second then vanishes,any help is appreciated

Similar Threads

  1. Sound Blaster External USB Question
    By nirvanades in forum General Hardware Discussion
    Replies: 15
    Last Post: 06-16-2006, 02:09 AM
  2. DVD drive question
    By Pokey in forum Newbie
    Replies: 3
    Last Post: 05-11-2004, 05:26 PM
  3. Replies: 5
    Last Post: 02-02-2004, 10:52 PM
  4. lcd power question
    By jrbless in forum LCD/Display
    Replies: 1
    Last Post: 04-07-2002, 01:27 PM
  5. Is this a stupid question??
    By Raymond in forum Power Supplies
    Replies: 1
    Last Post: 05-23-2001, 01:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •