Results 1 to 10 of 10

Thread: Alternative bluetooth drivers anywhere??

  1. #1
    Constant Bitrate
    Join Date
    Jan 2004
    Location
    Champaign, IL
    Posts
    124

    Alternative bluetooth drivers anywhere??

    I have been trying for some time now (as have many, many people here) to get a BT Headset/Audio Gateway profile to work satisfactorily as a speakerphone through my CarPC using Widcomm 3.X and 4.X. There are a few critical problems folks have encountered that have been scattered throughout various threads here:
    (1) excessive noise, sounds like 'skipping' of the audio -- as yet unexplained (?)
    (2) auto answer issues ('mostly' solved with Widcomm 3.X as opposed to 1.4.X)
    (3) huge processor load when connected via headset profile to the phone, causing Centrafuse (and any other app) to slow down substantially when attempting to pass the phone audio to the PC
    (4) anything else I missed?
    I have a SE T637 with IOGear GBU311 BT, Via M10000 512MB, XP SP2, Widcomm drivers.
    (1) and (3) are related: turns out it is the driver itself that is causing the excessive load -- btwdins.exe and services.exe hog about 30-50% of my CPU when the Headset profile is connected. (2) has been addressed but the verdict seems to be that the Widcomm SDK is cost prohibitive, such that Zorro needs $1500 in order to develop this functionality for PhoneControl.
    My test system for software installations is an IBM T41p. Needless to say, this can handle everything simultaneously with no problems: BT Headset connection, PhoneControl serial port connection, audio playback, GPS, XM, blah, blah. What's funny is that task manager reports very little load (<5%) on the processor when doing all of these things. Is my P4 2.0 GHz really that much better than the processor in the M10000? More importantly, given the low bandwidth of the BT audio connection I seriously doubt the BT stack needs to hog the PC that much to make the Headset connection happen.
    Conclusion: Widcomm drivers don't cut it, at least not with my current config. XP SP2 doesn't offer a Headset profile. But the VoIP world really wants to use BT for calls using existing wireless handsets, ala Vonage (see http://communications.siemens.com/cd...iption,00.html or http://www.calls-calls.com/shop/product.cgi/CFSE1/3/) .
    I'm hoping someone using an M10000 has found drivers -- Widcomm or otherwise -- that can make the Headset connection happen without the 'audio skipping', or maybe there is some simple XP tweak. Since most of us only need a single serial port, Headset/Audio Gateway connection, and maybe OBEX are there any other simpler drivers out there?? I think Longhorn will have the Headset profile and will *possibly* be more efficient, anyone beta tested it yet? Any ideas please!!

  2. #2
    Constant Bitrate vintageb3's Avatar
    Join Date
    Nov 2004
    Location
    Scotland
    Posts
    114
    For all our sakes...I hope there is an alternative....but no one has mentioned it in here before....not that I have picked up.

    Would love to be able to use my Jabra with a T610 and my VanPc...

    vintageb3
    M10000 mainboard,256 RAM, 80 Gig 3.5" drive, PWS-120-M, ITPS, Lilliput 7" touchscreen, XP Pro SP2, Frodoplayer, Map Monkey, InfoMap Navigator 4, WIFI

    Current: Bluetooth. Trying to get Phonecontrol to work with SE T610.

  3. #3
    Low Bitrate Kato's Avatar
    Join Date
    Oct 2003
    Location
    Toronto
    Posts
    82
    I have the same issue as well. Also, i am not able to hibernate my pc because the headset connection does not automatically disconnect after the call. Any solutions?

  4. #4
    Phone Control Moderator zorro's Avatar
    Join Date
    Mar 2004
    Location
    Munich, Germany
    Posts
    1,902
    Try this: Need some help...
    Skinning to go... VisualDesigner2!

  5. #5
    Low Bitrate Kato's Avatar
    Join Date
    Oct 2003
    Location
    Toronto
    Posts
    82
    thanks zorro. Will it automatically stop the headset service after the call so that i can hibernate peacefully?

  6. #6
    Phone Control Moderator zorro's Avatar
    Join Date
    Mar 2004
    Location
    Munich, Germany
    Posts
    1,902
    It's supposed to. Works only on version 1.4 and above.
    Skinning to go... VisualDesigner2!

  7. #7
    Low Bitrate Kato's Avatar
    Join Date
    Oct 2003
    Location
    Toronto
    Posts
    82
    Zorro: I have downloaded the trial, and am looking for this setting in the config dialog or the xml config file itself. Is it a new parameter? Can i just add it to the xml file.

    --------snip---------



    <UseBTManager device="Name" controlHeadset="True" mode="OnStart">True</UseBTManager>

    Please use PhoneCtlConfig for this.

  8. #8
    Phone Control Moderator zorro's Avatar
    Join Date
    Mar 2004
    Location
    Munich, Germany
    Posts
    1,902
    Skinning to go... VisualDesigner2!

  9. #9
    Low Bitrate Kato's Avatar
    Join Date
    Oct 2003
    Location
    Toronto
    Posts
    82
    I have the configuration program. The question i had was if this was a new parameter that i need to add to the config file, or should i see it somewhere already.

  10. #10
    Low Bitrate Kato's Avatar
    Join Date
    Oct 2003
    Location
    Toronto
    Posts
    82
    Ok..I tried the setting at lunch.

    I set the parameter to "onCall", but the headset service seems to connect on phoneco startup. Once the call is made, the headset remains connected and i'm unable to hibernate the pc. Is this working as designed?

Similar Threads

  1. X10 remote and bluetooth problem
    By liquid_smoke in forum Input Devices
    Replies: 2
    Last Post: 02-27-2008, 05:51 PM
  2. TouchScreen Drivers & Installation
    By [iG] in forum Input Devices
    Replies: 15
    Last Post: 02-17-2005, 10:40 PM
  3. Via Epia M-900 Video Drivers Not working
    By mattdisaster in forum General Hardware Discussion
    Replies: 2
    Last Post: 01-06-2005, 10:33 AM
  4. Lilliput drivers do not install with bluetooth
    By ryguy in forum LCD/Display
    Replies: 4
    Last Post: 06-12-2004, 10:52 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •