Page 2 of 15 FirstFirst 123456789101112 ... LastLast
Results 11 to 20 of 147

Thread: PhoneControl.NET 1.4 Released!

  1. #11
    Constant Bitrate
    Join Date
    Feb 2005
    Posts
    189
    Quote Originally Posted by zorro
    Nothing changed with reading phonebook since you got the new version from me. Did you setup your config right?
    Yea, I checked the settings. I actually tried just copying the config file that we worked on into the new install directory and it still didn't work. I'll look at it again tonight.

  2. #12
    Constant Bitrate
    Join Date
    Apr 2004
    Posts
    154
    I keep getting {--ResString not found--} when I click the Test on the Phone Test app with the recommended port. However I am able to connect to the phone with my P900 suite apps.

    Using the latest Widcomm 4.
    P900 phone.
    Local Services has port 8
    Client Apps has port 9

    I setup PC to use port 9 and

    1. It initializes the phone (it lights up)
    2. Then says resetting phone
    3. Then seems to hang for a while at initializing basic phone parameter
    4. Then starts back at 1 again and goes into a loop of 1 and 2

    Any ideas?

    Lines in the log keep looping this...

    3/10/2005 11:54:33 AM Opening COM9
    ----------------------------------------------------------------------------
    3/10/2005 11:54:35 AM COM-Event "CD" received
    ----------------------------------------------------------------------------
    3/10/2005 11:54:35 AM COM-Event "CD" received
    ----------------------------------------------------------------------------
    3/10/2005 11:54:38 AM **** TIMEOUT ****

  3. #13
    Phone Control Moderator zorro's Avatar
    Join Date
    Mar 2004
    Location
    Munich, Germany
    Posts
    1,902
    You can't use The Serial Port Profile on Symbian OS phones.
    You have to install mRouter, then PhoneTest will make the right recommendations. In fact, you have to use the Dial-Up Network Profile.

    <edit>
    The message you're not seeing yet is "No Response from port!"
    Get the corrected version here: http://phoco.net/PhoneTest.zip
    </edit>
    Skinning to go... VisualDesigner2!

  4. #14
    Constant Bitrate
    Join Date
    Apr 2004
    Posts
    154
    Ahh so we still use the Dial-up Network Profile... after reading this link http://zhorvat.dyndns.org/PCForums/S...aspx?PostID=78 I was under the assumption that we no longer needed to use it.

  5. #15
    Phone Control Moderator zorro's Avatar
    Join Date
    Mar 2004
    Location
    Munich, Germany
    Posts
    1,902
    No... this is now complicated as hell Tried to make it simple though.

    The standard functions are read out via the Dial-up. Only the phonebook and later the SMS will be done over mRouter (otherwise I had to implement the other stuff as well, which is kinda redundant).
    This was the easy part.
    Know, you have to configure the - what you called "Client Apps Port" - too, because this one is needed to trigger the mRouter connection, if it isn't connected.
    In this case you (respective PhoCo) connects through the SPP, the phone rejects it and connects back through your "Local Services" SPP...

    Wierd... but it works
    Skinning to go... VisualDesigner2!

  6. #16
    Constant Bitrate
    Join Date
    Apr 2004
    Posts
    154
    Ok so do I still add the "<IsSymbianOS port="6">True</IsSymbianOS>" and phone changes in the xml file?

    and is the <port>8</port> set to the mrouter port? or the client apps port?

  7. #17
    Phone Control Moderator zorro's Avatar
    Join Date
    Mar 2004
    Location
    Munich, Germany
    Posts
    1,902
    <IsSymbianOS port="9"> and <Port>whateveryourdialupnetworkportis<Port>
    Skinning to go... VisualDesigner2!

  8. #18
    Constant Bitrate
    Join Date
    Apr 2004
    Posts
    154
    This is how I have it set up.




    So I put the <port>10</port> (Dial Up) and <IsSymbianOS port="9"> but
    when I add the IsSymbianOS child, PhonCo crashes.

    It works until I add the IsSymbianOS child

    When I use the Phone Test app I click "Test" on the recommended port to use I still get the ResString error (I downloaded your new link).

    The SymbianTest.exe program works though!

  9. #19
    Phone Control Moderator zorro's Avatar
    Join Date
    Mar 2004
    Location
    Munich, Germany
    Posts
    1,902
    That's pretty good.
    Try the following remove port="9" from the config and establish the mRouter connection manually by doubleclicking the SPP (COM9) in the BT-Manager
    Skinning to go... VisualDesigner2!

  10. #20
    Newbie
    Join Date
    Dec 2004
    Location
    Denmark
    Posts
    12
    Zorro,
    If I follow the share-it link and buy this version 1.4, is it then only for 1.4 or do I get a license which enables me to have updates and bugfixes etc.?

    Thanks

Similar Threads

  1. Phonecontrol.net and bluetooth headsets
    By Matthew230 in forum Wireless Communications
    Replies: 10
    Last Post: 05-08-2005, 07:22 PM
  2. PhoCo 1.4 RC1
    By execute in forum Centrafuse
    Replies: 17
    Last Post: 03-03-2005, 05:43 AM
  3. Need help with MPXF 1.4
    By dapepster in forum Software & Software Development
    Replies: 20
    Last Post: 10-14-2001, 06:25 PM
  4. lorty's mp3car winamp plugin v.2.4 released!
    By lorty in forum Software & Software Development
    Replies: 2
    Last Post: 07-18-2000, 02:46 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •