Results 1 to 6 of 6

Thread: No Sound on Recieivng Calls

  1. #1
    Low Bitrate
    Join Date
    Aug 2005
    Posts
    103

    No Sound on Receiving Calls

    After many late nights of reading this forum I seem to almost have everything working very well. There are two things that I can not seem to figure out, though I remember reading about them somewhere, but I can not find it now.

    I have a SE T637 and I am using this line in my xml file:

    <UseBTManager device="t637" controlHeadset="True" disconnectAfterCall="True" mode="OnStartup">True</UseBTManager>

    So when phone control starts up, it automatically starts the audio gateway and serial connections, and the headseat icon appears on my phone. I can make calls through PhoneControl and hear audio on my PC speakers. But when I receive a call, it tells me who is calling, and I can answer it through PhoneControl, but their is no audio on my PC speakers, only through my phone. My headseat icon is still active, and both the audio gateway and serial connections are still active.

    When I close PhoneControl and manually connect to the audio gateway through the quickconnect link, I can make and receive calls and get audio on my pc speakers. So I do not think it is how my bluetooth settings are configured on the PC or my phone settings since it works fine outside of PhoneControl.

    I have looked through the XLM config file and could not find anything obvious.

    The second item is that when I have "mode=OnStartup" and I close phonecontrol, it does not release my audio gateway and serial connections. Is there a way to do this. It releases my bluetooth connection fine when "mode=OnCall", but then I do not get audio through my PC speakers with this setting.

    Since PhoneControl is not releasing the bluetooth connection, the PC will not hibernate properly. Same problem as: bluetooth headset connected on hibernate

    Thanks for any help, and sorry if this has already been answered.

  2. #2
    Low Bitrate
    Join Date
    Aug 2005
    Posts
    103
    I've been trying to get this audio thing to work when I receive calls, but I am not having any success. Does anyone have this working with their T637 or similar phone?

    As far as releasing the bluetooth connection from phonecontrol so it doesn't hang up windows when hibernating, is there an AdditionalDeInit command that I may be able to use to release the bluetooth. I have read through the entire manual and could not find any more information on this.

    I am so close to making this software useable for me. I will read up on some AT commands, maybe this will help me understand better. Any help would be greatly appreciated.

    Thanks.

  3. #3
    Phone Control Moderator zorro's Avatar
    Join Date
    Mar 2004
    Location
    Munich, Germany
    Posts
    1,902
    There is no such switch or command. In the next release I will handle Power events and turn off/on the Headset accordingly.

    If you wanna test it, drop me a mail.
    Skinning to go... VisualDesigner2!

  4. #4
    Low Bitrate
    Join Date
    Aug 2005
    Posts
    103
    Thanks for the info. I will contact you as soon as I get this audio working on incomming calls.

    I found an old post on how to transfer voice from your phone to your PC when recieving a call using the Accept command: Thread

    I'll give it a try in the morning. Being an old post, is this still the best way of doing this?

    Thanks.

  5. #5
    Low Bitrate
    Join Date
    Aug 2005
    Posts
    103
    What are the FK1 - FK4 buttons on the SE phones? I see all the buttons defined except for the buttons that accept and reject a call which are the two buttons directly under the screen on either side of the joystick.

    Thanks.

  6. #6
    FLAC -zip-'s Avatar
    Join Date
    Sep 2004
    Location
    Ontario/Canada
    Posts
    1,293
    F350 I PM'ed you, looking to purchase the same phone and Phoco did you get this figured out?
    2008 350z GT Installed since April 22nd 2011 - Worklog
    2000 Protege Installed Since April 2, 2005 - Intel D201GLY|Fusion Brain|ODBPros ODBII|Engenius|GPS Rikaline|Powermate|Motorized Lilli
    Sound Stage
    Eclipse|MTX|Infinity

Similar Threads

  1. Audio problems, Epia Sound, and FAQ stuff
    By gothate in forum Newbie
    Replies: 2
    Last Post: 06-16-2005, 05:04 PM
  2. FS: USB Sound Blast Live 24 bit & Pioneer 4 Channel 300watt amp
    By clean customs in forum Classified Archive
    Replies: 0
    Last Post: 05-21-2005, 11:04 AM
  3. Sound Card discussion, 4.1, sound quality, need help
    By jedi7001 in forum General Hardware Discussion
    Replies: 1
    Last Post: 05-19-2005, 10:47 AM
  4. Sound cards from incarpcs , sacrificing sound quality?
    By skinhead in forum General Hardware Discussion
    Replies: 15
    Last Post: 09-02-2004, 03:05 AM
  5. got sound?
    By masch in forum Newbie
    Replies: 20
    Last Post: 11-17-2003, 10:01 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •