Results 1 to 4 of 4

Thread: SE z520a + Phoneco

  1. #1
    Newbie
    Join Date
    Feb 2006
    Posts
    2

    SE z520a + Phoneco

    I am trying out Phoneco with my Sony-Ericsson z520a phone (supports BT 2.0) with a Bluetake BT007Si USB BT adapter and the 5.0.1.801 WIDCOMM drivers. I am able to successfully make both a serial port and an audio gateway connection with my phone (simultaneously, as a matter of fact). I thought I was home free so I fired up Phoneco to see it work and it connects fine but the audio does not come through the PC. Let me explain how the phone does work with the PC. I make the audio gateway connection and call the phone - a tooltip bubble pops up and says incoming call. I use the phone keypad to answer it and the audio comes through the speakers, just like it should. I make a call with the phone keypad (again, with audio gateway connected) and sure enough the audio comes through the speakers again. Awesome. Note, both times the serial port connection is established but not being used. I start Phoneco, using the SonyEricssonNew profile (and configured to not control my headset) and the software immediately loads my phonebook. So I pick a number to dial from and the Phoneco dials it fine - except this time no audio from the speakers. The same thing if I use Phoneco to answer the call - no audio, even though audio gateway is connected. I can use the phone's keypad even while Phoneco is running and get the audio to work. So, it appears that the serial port commands that Phoneco sends to establish/connect the call somehow disables the phone's audio connection to the PC, even though it still shows it's connected. I can only get the audio connection to work if I use the keypad physically on the phone itself. Any suggestions to how I can get it to work completely? I am so close and I hope there is some way around this. Note - I already tried connecting the audio gateway after the call is established - the phone won't allow this so the information in the sticky about start serial, drop serial, start audio, drop audio, start serial probably won't work for this situation.

    Thanks in advance!

  2. #2
    Newbie josephyancey's Avatar
    Join Date
    Apr 2006
    Location
    Jonesboro Arkansas
    Posts
    12
    I know this is an old thread but I am having the same exact problems. Im going to add a little bit more information though.

    Any time I make or answer a call with the computer (every piece of software that I have tried does the same exact thing) the audio goes through the actual phone not the speakers but if the call is made or answered with the actual phone it works like it should
    mp3car 1% complete

    (\__/)
    (='.'=)This is Bunny. Copy and paste bunny into your
    (")_(")signature to help him gain world domination.

  3. #3
    Newbie
    Join Date
    Feb 2006
    Posts
    2
    Quote Originally Posted by josephyancey
    I know this is an old thread but I am having the same exact problems. Im going to add a little bit more information though.

    Any time I make or answer a call with the computer (every piece of software that I have tried does the same exact thing) the audio goes through the actual phone not the speakers but if the call is made or answered with the actual phone it works like it should
    Yep, this is my problem exactly. Is anyone else using this phone or trying to accomplish this? Maybe there is simply a limitation with the hardware that won't allow this, which would be strange since the phone is great with BT otherwise.

  4. #4
    Variable Bitrate CARLOS_CET's Avatar
    Join Date
    Aug 2004
    Location
    NH
    Posts
    303
    Same here. I was working on finding a fix or a way to get it to work and than I read about the feedback that you get from the car speakers and the microphone. I figured, even if I do get it to work I'll run into the same problem. So I figured that I would be fine with just using my bluetooth headset. Would have been nice to get Phoco working though.
    Car PC Progress

    (>>>>>>>>>>>>---) 90%


    "Don't speak about it, be about it"


Similar Threads

  1. PhoneCo, Widcomm and BSOD
    By CrackerStealth in forum PhoneControl
    Replies: 9
    Last Post: 09-08-2005, 01:36 PM
  2. Phoneco or Sapi ? speaks no's wrong
    By DonkeyBoy in forum PhoneControl
    Replies: 0
    Last Post: 08-23-2005, 03:42 PM
  3. SE phone help
    By djmickyg in forum PhoneControl
    Replies: 17
    Last Post: 08-20-2005, 11:28 AM
  4. 93 accord SE: The Lost Cause
    By fluffy2097 in forum Show off your project
    Replies: 20
    Last Post: 10-15-2003, 04:47 AM
  5. win 98 SE
    By cubanmoses in forum Software & Software Development
    Replies: 8
    Last Post: 08-15-2003, 10:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •