Page 30 of 114 FirstFirst ... 20212223242526272829303132333435363738394080 ... LastLast
Results 291 to 300 of 1134

Thread: Custom USB tyre pressure monitoring interface

  1. #291
    Maximum Bitrate
    Join Date
    Feb 2006
    Location
    Melbourne, Australia
    Posts
    649
    Hello Robby,
    Ok, I have tested AllyPally's kit that I have assembled, but used my pressure sensors, and still unassembled kit, with original display, to compare values.

    As you can see, the one TPMS Doctor also reads sensor 2 hex data incorrectly, but displays it proper - I have verified this against the unassembled TPMS RF Receiver - so most likely a small bug somewhere in TPMS Doctor, same as the descrepancy Fmode's had a few replies back.

    Other than that, things went pretty well, and I am glad AllyPally's is now confirmed working, I have not tested/paired sensor 5, which is the spare wheel, but confirmed that yesterday with his own transducer.

    Well, just thought I'd feedback, and let you know about the small descrepancy.

    Take care, talk to you later again.

    Br,
    MrBean
    Attached Images Attached Images  
    F6 Tornado Project Log ; HP Blackbird Watercooled Server

    Beta Tester for Centrafuse and 3dConnexion (No business affiliation with either)

  2. #292
    Maximum Bitrate Robby BMW's Avatar
    Join Date
    Aug 2005
    Location
    Italy
    Posts
    558
    Quote Originally Posted by mrbean_phillip View Post
    Hello Robby,
    Ok, I have tested AllyPally's kit that I have assembled, but used my pressure sensors, and still unassembled kit, with original display, to compare values.

    As you can see, the one TPMS Doctor also reads sensor 2 hex data incorrectly, but displays it proper - I have verified this against the unassembled TPMS RF Receiver - so most likely a small bug somewhere in TPMS Doctor, same as the descrepancy Fmode's had a few replies back.

    Other than that, things went pretty well, and I am glad AllyPally's is now confirmed working, I have not tested/paired sensor 5, which is the spare wheel, but confirmed that yesterday with his own transducer.

    Well, just thought I'd feedback, and let you know about the small descrepancy.

    Take care, talk to you later again.

    Br,
    MrBean
    Thank you for your feedback, it was very useful to found the bug in the program.
    I just compiled a new release (1.10) with this issue solved and some improvements added.
    It is available for the download at the same link in this post.
    _______________________________________
    Car installation 95% [■■■■■■■■■■■■■■■■■■■]
    Current project: Parking sensor USB interface

  3. #293
    Maximum Bitrate
    Join Date
    Feb 2006
    Location
    Melbourne, Australia
    Posts
    649
    Hello Robby,
    Good work, the new release seems to be quicker at detecting the data once you clear the data from the PIC Eprom - maybe my imagination, but working pretty well, and I can comfirm that it is now detecting the sensor pressure data correctly, same with temperature.

    The only small hiccup still is something with the battery data on sensor 3, also had this descrepancy with version 1.0.0. According to the original receiver display, all battery levels are good.

    I have made this unit using the data-out pin on the RF unit, and not seperated the rf board from the system. This way I can have both original LCD, and Carputer for comparison - will still cut the board and solder it to the PIC pcb, but for now it makes for a handy comparison device.

    Anyway, here is a screenshot of V1.10.
    Attached Images Attached Images  
    F6 Tornado Project Log ; HP Blackbird Watercooled Server

    Beta Tester for Centrafuse and 3dConnexion (No business affiliation with either)

  4. #294
    Maximum Bitrate Robby BMW's Avatar
    Join Date
    Aug 2005
    Location
    Italy
    Posts
    558
    Quote Originally Posted by mrbean_phillip View Post
    Hello Robby,
    Good work, the new release seems to be quicker at detecting the data once you clear the data from the PIC Eprom - maybe my imagination, but working pretty well, and I can comfirm that it is now detecting the sensor pressure data correctly, same with temperature.

    The only small hiccup still is something with the battery data on sensor 3, also had this descrepancy with version 1.0.0. According to the original receiver display, all battery levels are good.

    I have made this unit using the data-out pin on the RF unit, and not seperated the rf board from the system. This way I can have both original LCD, and Carputer for comparison - will still cut the board and solder it to the PIC pcb, but for now it makes for a handy comparison device.

    Anyway, here is a screenshot of V1.10.
    It seems that the data inside the 3rd byte are more complex then I believed, especially the battery level that seems to not be coded as expected.
    I need a time to better analyze the data from sensors. I will you know.
    _______________________________________
    Car installation 95% [■■■■■■■■■■■■■■■■■■■]
    Current project: Parking sensor USB interface

  5. #295
    Maximum Bitrate
    Join Date
    Feb 2006
    Location
    Melbourne, Australia
    Posts
    649
    Thanx Robby,
    After testing the CF plugin too, it exacts the same behaviour, and I think there may be a slight problem with the way the PIC reads the datastream from the RF-Receiver.

    Using the original LCD-based display, all batteries seems to be accurate.

    Thanx for looking
    F6 Tornado Project Log ; HP Blackbird Watercooled Server

    Beta Tester for Centrafuse and 3dConnexion (No business affiliation with either)

  6. #296
    Maximum Bitrate Robby BMW's Avatar
    Join Date
    Aug 2005
    Location
    Italy
    Posts
    558
    No, the PIC firmware is ok, it transmits only the raw data received from sensors to the PC, and CRC confirms that the data are correct. The problem is in the PC software that doesn't convert properly the data.
    I've compiled another release (1.20) (available here) that should resolve definitely the problem.
    The CF plugin has the same bug because it is based on the source code of my RoadRunner plugin that is buggy too, so I have released also a new version of the RoadRunner plugin with the bug fixed.
    _______________________________________
    Car installation 95% [■■■■■■■■■■■■■■■■■■■]
    Current project: Parking sensor USB interface

  7. #297
    Maximum Bitrate
    Auto Apps:loading...
    _Dejan_'s Avatar
    Join Date
    Jul 2007
    Location
    Slovenia
    Posts
    571
    Im send email with source code to guy who write CF plugin...
    LINK for TPMS doctor doesn't work...

  8. #298
    Maximum Bitrate Robby BMW's Avatar
    Join Date
    Aug 2005
    Location
    Italy
    Posts
    558
    Thank you Dejan.
    I've just fixed the download link.
    _______________________________________
    Car installation 95% [■■■■■■■■■■■■■■■■■■■]
    Current project: Parking sensor USB interface

  9. #299
    Maximum Bitrate
    Join Date
    Feb 2006
    Location
    Melbourne, Australia
    Posts
    649
    Thanx Robby,
    Just arrived in Tampere in Finland, dead-tired after 36hours of travel, and no sleep

    Will be back home next Sunday night, and test again - but I am sure all will be fine now.

    Thanx for your efforts.

    Kind regards,
    MrBean
    F6 Tornado Project Log ; HP Blackbird Watercooled Server

    Beta Tester for Centrafuse and 3dConnexion (No business affiliation with either)

  10. #300
    Newbie
    Join Date
    Apr 2007
    Posts
    30
    love the idea

    Name your price! Seriously, name ur price!

Similar Threads

  1. Core Duo / Core 2 Duo Mini-ITX boards
    By RedGTiVR6 in forum General Hardware Discussion
    Replies: 153
    Last Post: 10-03-2010, 11:30 PM
  2. USB self powered hub, which one
    By htsource in forum General Hardware Discussion
    Replies: 5
    Last Post: 07-26-2007, 04:31 PM
  3. Will this layout with a remote USB hub work?
    By NoPistonPC in forum General Hardware Discussion
    Replies: 14
    Last Post: 08-21-2005, 04:24 PM
  4. USB Earthmate - patch for gpsd support
    By dignome in forum GPS
    Replies: 4
    Last Post: 04-05-2005, 11:44 AM
  5. Replies: 4
    Last Post: 04-06-2004, 10:52 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •