Results 1 to 3 of 3

Thread: fried my carnetix power supply?

  1. #1
    Low Bitrate
    Join Date
    Mar 2007
    Posts
    70

    fried my carnetix power supply?

    I may have friend my carnetix power supply.

    I was attempting to wire a switch into the power line between the powersupply and my lilliput display. I incorrectly assumed it wouldn't matter which of the two lines (power versus ground) I tapped into to add the switch. When I turned on the car with my new power switch set to OFF I was initially puzzled because the display was ON! After slapping myself in the for head, I realized that I must have added the switch onto the ground of the lilliput so while it was pulling power from the carnetix it was going back through the ground connection between the display and the mac mini. I unpowered everything and re-wired the switch. This time, the display and switch worked as intended but the mini wouldn't power up.

    I tested the mini inside the house using my original power brick and it works, so that doesn't seem like the problem.

    When I turn on the car, the power supply fan spins and the led lights up as usual so if it is broken in some way, it isn't apparent visually.

    Can I just put a voltmeter on the carnetix to test it? I only ask because I really don't know much about voltmeters and I'm afraid that my putting the voltmeter leads on the power supply pins will short the power supply and make the problem worse.

  2. #2
    Constant Bitrate
    Join Date
    Jun 2006
    Location
    Chicago, IL
    Posts
    143
    Voltmeter not necessarily will show correct voltage, you have to put any load on the PS, and then try to measure. Check, and re-check connections first, see what happens when you turn ignition off and remove the key, that led should blink or so (see manual).
    Even if you short the output, it's unlikely that you fry it. If everything else fail, you can deem you PS fried
    EPIA TC 1G 256MB 60GB Linux,WindowMaker, Roadnav, Xine, XMMS, iGuidance3
    Lilliput 8", Pharos i360, WUSB11v2.6 WiFi

  3. #3
    Low Bitrate
    Join Date
    Mar 2007
    Posts
    70
    Ahh thanks I figured it out.. My home-rolled iSense connector was backwards!

Similar Threads

  1. Carnetix P1900/P2140 and IBM T40 Laptop Power Question
    By l00kster in forum Laptops, Netbooks, Tablets, UMPCs, etc.
    Replies: 14
    Last Post: 01-24-2008, 02:55 PM
  2. My low cost, easy to build power supply...
    By SkinnyBoy in forum Power Supplies
    Replies: 52
    Last Post: 09-27-2006, 07:10 PM
  3. Replies: 13
    Last Post: 09-05-2006, 12:44 PM
  4. Travla AC/DC power supply cable
    By Change in forum Power Supplies
    Replies: 1
    Last Post: 07-25-2006, 11:04 PM
  5. New Mpegbox Power Supply
    By zootjeff in forum Power Supplies
    Replies: 60
    Last Post: 09-20-2005, 01:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •