Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Double power and double ground on OPUS 120W?

  1. #1
    Variable Bitrate
    Join Date
    Jul 2009
    Location
    B.C., Canada
    Posts
    305

    Double power and double ground on OPUS 120W?

    I just got my OPUS 120W PSU in the mail today and I'm confused by the 6 wire pigtail and can't seem to find the answer here.

    Manual says:
    Blue/White - "On/Off of amp, LCD, etc." Does this mean this is the delay, anti-thump on/off wire?
    Red - "IGN/ACC switch." This one is obvious
    2 yellow - "+ from battery." Obvious, but why is there two and why are they only 16AWG when the manual suggests 12AWG or larger?
    2 black - "- from battery." Obvious, but again, why two?
    PROGRESS:
    Hardware: 100%
    Software: 99% - Always upgrading and improving.
    Installation: 100%

    WORKLOG:
    2005 F-150

  2. #2
    Variable Bitrate
    Join Date
    Jul 2009
    Location
    B.C., Canada
    Posts
    305
    Red Hot Chili Peppers - Hump De BUMP.
    PROGRESS:
    Hardware: 100%
    Software: 99% - Always upgrading and improving.
    Installation: 100%

    WORKLOG:
    2005 F-150

  3. #3
    Raw Wave
    Join Date
    Nov 2009
    Posts
    2,118
    And isn't 2x16 = 12?

    One connector can't handle the lot/maximum....

  4. #4
    Neither darque nor pervert DarquePervert's Avatar
    Join Date
    Apr 2004
    Location
    Elsewhere
    Posts
    13,948
    As to the question of "why", shouldn't you contact Opus? They're the ones that designed the thing.
    Have you looked in the FAQ yet?
    How about the Wiki?



    Under normal circumstances, a signature would go here.

  5. #5
    Variable Bitrate
    Join Date
    Jul 2009
    Location
    B.C., Canada
    Posts
    305
    Quote Originally Posted by DarquePervert View Post
    As to the question of "why", shouldn't you contact Opus? They're the ones that designed the thing.
    Perhaps, but I'm still waiting on an e-mail back to answer my question if the can ship using USPS instead of UPS. I ended up not worrying about it and ordering anyways.

    So I guess that means I take a 12AWG from the battery and but splice it to the two 16AWG wires? That was my best guess but I wanted to make sure anyways.
    PROGRESS:
    Hardware: 100%
    Software: 99% - Always upgrading and improving.
    Installation: 100%

    WORKLOG:
    2005 F-150

  6. #6
    Constant Bitrate
    Join Date
    Oct 2009
    Posts
    115
    i think they designed it so that it could use the standard molex wires. the two wires being the next best thing to one thicker wire. Just go ahead and hook them both up. think of it as adding more lanes to the electron highway i guess

  7. #7
    FLAC freeflashstuff's Avatar
    Join Date
    May 2008
    Location
    Socorro, New Mexico, United States
    Posts
    1,141
    On mine I tied the two to one 10AWG wire. Made it WAY easier for me.
    I have bad luck with vehicles...

  8. #8
    Variable Bitrate
    Join Date
    Jul 2009
    Location
    B.C., Canada
    Posts
    305
    Ok, thanks everyone. That is what I'll do. Means only trying to get one wire through that grommet in the firewall. That should keep a few coins out of the curse jar.
    PROGRESS:
    Hardware: 100%
    Software: 99% - Always upgrading and improving.
    Installation: 100%

    WORKLOG:
    2005 F-150

  9. #9
    FLAC freeflashstuff's Avatar
    Join Date
    May 2008
    Location
    Socorro, New Mexico, United States
    Posts
    1,141
    Quote Originally Posted by Tical84 View Post
    That should keep a few coins out of the curse jar.
    OMG, You have one of those?
    I have bad luck with vehicles...

  10. #10
    Variable Bitrate
    Join Date
    Jul 2009
    Location
    B.C., Canada
    Posts
    305
    Haha, no I don't actually, but if I did...
    PROGRESS:
    Hardware: 100%
    Software: 99% - Always upgrading and improving.
    Installation: 100%

    WORKLOG:
    2005 F-150

Page 1 of 2 12 LastLast

Similar Threads

  1. OPUS 120W Failing to Boot
    By ContaiN in forum Power Supplies
    Replies: 1
    Last Post: 07-27-2008, 07:39 AM
  2. OPUS 120W -1 green flashing led
    By maddop in forum Power Supplies
    Replies: 14
    Last Post: 08-16-2007, 02:11 PM
  3. Help with OPUS 120W wiring
    By BobbyCreekwater in forum Power Supplies
    Replies: 1
    Last Post: 06-22-2007, 12:36 PM
  4. opus 120w - power in house
    By SuzukiAerio in forum Power Supplies
    Replies: 8
    Last Post: 05-26-2007, 01:43 PM
  5. Help connecting LCD, DVD, etc to OPUS
    By jdub421 in forum LCD/Display
    Replies: 0
    Last Post: 02-13-2006, 01:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •