Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: P2140 startup/shutdown issues in new carPC

  1. #1
    Low Bitrate
    Join Date
    Aug 2010
    Location
    Vancouver, BC
    Posts
    67

    P2140 startup/shutdown issues in new carPC

    Hey guys, got my carPC all installed and running in my car. But I'm having problems with getting it to go into hibernation on shutdown and turning on startup.
    I have a HP DC7800 small form factor PC with Windows 7, and a P2140/PSUmoni connected via USB with all the correct/updated drivers installed.

    The problem is that the P2140 appears to be powering off the unit before its able to be put into hibernation. I have the delay power-off settings set at 30 seconds so it gives it enough time to go into hibernation, but it doesnt seem to be working?
    Also, this is the only time the PC will turn on back with the car, however it turns on saying that it wasnt shut down properly and asks to start in Safe Mode.

    When I manually put the PC into hibernation, and then turn the car off, the PC will not start (the psu will not bring it out of hibernation). I have to go to my trunk and manually press the PC's power button.

    So my question is, what do the PSUmoni settings have to be to simply put the PC into hibernation on shutdown, and out of hibernation on startup? What should the power setting be at on the PC? What are they supposed to be at in the BIOS?
    Once I get this figured out then my install will be complete!
    - scENFORCER

  2. #2
    Variable Bitrate Wayne613's Avatar
    Join Date
    Apr 2009
    Location
    Delaware
    Posts
    308
    Is it actually starting the hibernation sequence? If itīs not, you probably just donīt have the polarity correct for the motherboard shut-down button line. In addition, with Win7 you usually do have to modify the advanced power management settings for the power button functionality.

    If the polarity for the shutdown leads is backwards, itīll usually get the start-up pulse, but it wonīt see the shut-down, and then the PSU will hard-off eventually leading to the conditions you mention. But check your power management first in Win7 to make sure youīve altered it correctly and saved it.

    Eh, just me, but I never really got hibernation, other than saving a few seconds I just prefer it to fully shutdown/startup fresh. *shrug*
    2008 Ford Mustang GT/CS CARPC(99%)
    Software: Ride/Road-Runner, Digital FX skin 5.x, iGuidance 2011, GPSgate on Win7 64bit

  3. #3
    Maximum Bitrate
    Join Date
    May 2005
    Posts
    725
    Quote Originally Posted by Wayne613 View Post
    Is it actually starting the hibernation sequence? If itīs not, you probably just donīt have the polarity correct for the motherboard shut-down button line. In addition, with Win7 you usually do have to modify the advanced power management settings for the power button functionality.

    If the polarity for the shutdown leads is backwards, itīll usually get the start-up pulse, but it wonīt see the shut-down, and then the PSU will hard-off eventually leading to the conditions you mention. But check your power management first in Win7 to make sure youīve altered it correctly and saved it.

    Eh, just me, but I never really got hibernation, other than saving a few seconds I just prefer it to fully shutdown/startup fresh. *shrug*
    Just out of curiosity, why does the polarity matter on what is essentially a momentary switch?

  4. #4
    Low Bitrate
    Join Date
    Aug 2010
    Location
    Vancouver, BC
    Posts
    67
    Quote Originally Posted by Wayne613 View Post
    Is it actually starting the hibernation sequence? If itīs not, you probably just donīt have the polarity correct for the motherboard shut-down button line. In addition, with Win7 you usually do have to modify the advanced power management settings for the power button functionality.

    If the polarity for the shutdown leads is backwards, itīll usually get the start-up pulse, but it wonīt see the shut-down, and then the PSU will hard-off eventually leading to the conditions you mention. But check your power management first in Win7 to make sure youīve altered it correctly and saved it.

    Eh, just me, but I never really got hibernation, other than saving a few seconds I just prefer it to fully shutdown/startup fresh. *shrug*
    I have it connected via USB, not hardwired into the motherboard. Just seems like the settings arent doing what theyre set to do. And yes Ive updated and saved everything when I change something..
    - scENFORCER

  5. #5
    Variable Bitrate Wayne613's Avatar
    Join Date
    Apr 2009
    Location
    Delaware
    Posts
    308
    Quote Originally Posted by sebberry View Post
    Just out of curiosity, why does the polarity matter on what is essentially a momentary switch?
    Itīs not the polarity on the switch that matters as your just manually shorting the two to tell it to shut-down or power up. Which is also why putting it backwards for the motherboard itself doesnīt hurt anything, just wonīt work properly. Itīs just needed for the motherboard connection itself as otherwise it canīt see the shut-down pulse that the carPSU is sending on its own.

    As to why exactly, that you will have to ask someone else, as I truly donīt know the exact reason. I looked briefly at the ACPI specifications listed, including the newest 4.0 revision, but still not getting exactly what is being done for the button itself to make the interpretation. This is the way the modern ACPI on/off line has always functioned for the modern power supplies and motherboard interaction though.

    Actually in short, a very good question, Iīd like to know myself. It did annoy the crap out of me building my own PC in the earlier days, relatively speaking.

    Quote Originally Posted by scENFORCER View Post
    I have it connected via USB, not hardwired into the motherboard. Just seems like the settings arent doing what theyre set to do. And yes Ive updated and saved everything when I change something..
    Ehm...what? There should be a 2 line connection for the ACPI on/off switch. Same as you would for the front power button on a desktop. This gives it the shutdown/startup signals, Green and White for this unit according to what I just gleaned from looking at the manual (section 5.2). Green is the + lead, White is the - for the ACPI on/off on the motherboard.
    I think there's a simple jumper that came with the unit to connect to for this, but perhaps you needed to get one of the wiring bundles listed on the cables section of the carnetix site.

    Are you using USB wakeup feature in the bios to start it currently? Iīm unfamiliar with the 2140, I think your best bet would be hit the Carnetix forums.

    If your looking to not have to wire the ACPI line, this stickied thread over there gives details. It will give instructions on how to use the BIOS settings instead, so long as your MB has them. Otherwise you'll have to do what I said before. This is just from a quick look at the manual. Look deeper, as Iīm rushing out the door to work now. Look at this thread for an example of what I'm talking about. I also took a quick look at the manual, you need to set JP5 for PC use for the ACPI leads.

    Perhaps someone like soundman98 could comment further as I think heīs got experience with the 2140.
    2008 Ford Mustang GT/CS CARPC(99%)
    Software: Ride/Road-Runner, Digital FX skin 5.x, iGuidance 2011, GPSgate on Win7 64bit

  6. #6
    Low Bitrate
    Join Date
    Aug 2010
    Location
    Vancouver, BC
    Posts
    67
    ^ thanks for the detailed reply. I'll have to go through everything and see whats up, just haven't had the time recently as I am busy with finals.

    However, the past two times I've driven the car the PC has randomly shut down about 5-10 minutes in. ..is that a problem I should be concerned with??
    - scENFORCER

  7. #7
    Maximum Bitrate
    Join Date
    May 2005
    Posts
    725
    Quote Originally Posted by Wayne613 View Post
    Itīs not the polarity on the switch that matters as your just manually shorting the two to tell it to shut-down or power up. Which is also why putting it backwards for the motherboard itself doesnīt hurt anything, just wonīt work properly. Itīs just needed for the motherboard connection itself as otherwise it canīt see the shut-down pulse that the carPSU is sending on its own.

    As to why exactly, that you will have to ask someone else, as I truly donīt know the exact reason. I looked briefly at the ACPI specifications listed, including the newest 4.0 revision, but still not getting exactly what is being done for the button itself to make the interpretation. This is the way the modern ACPI on/off line has always functioned for the modern power supplies and motherboard interaction though.

    Actually in short, a very good question, Iīd like to know myself. It did annoy the crap out of me building my own PC in the earlier days, relatively speaking.
    I'd like to know exactly what happens when the power supply sends the "pulse" to the motherboard.

    If you look at the soft power switch connector on any ATX motherboard, one of the pins is grounded, the other isn't. All you need to do is ground the pin that isn't normally attached to ground briefly.

    I've started and shut down computers by shorting the two pins together with a screwdriver.


    I'm guessing the power supply doesn't simply short the two pins briefly, it must short one to ground. This makes sense - if you have the connector backwards it tries to ground the already grounded pin.

  8. #8
    Variable Bitrate Wayne613's Avatar
    Join Date
    Apr 2009
    Location
    Delaware
    Posts
    308
    Quote Originally Posted by sebberry View Post
    I've started and shut down computers by shorting the two pins together with a screwdriver.

    I'm guessing the power supply doesn't simply short the two pins briefly, it must short one to ground. This makes sense - if you have the connector backwards it tries to ground the already grounded pin.
    That makes logical sense. And it would explain it. Although, how is it getting the start Ļpulse" then? If you wire īem wrong the PSU will still start the computer, just wonīt see the shut-down. N/m, I think I might understand this now. Itīs not actually needing to interpret the start, just shut-down from the + line, as the (car in this case)PSU is acting as the power-button, just simply dragging it down to ground again.

    Quote Originally Posted by scENFORCER
    However, the past two times I've driven the car the PC has randomly shut down about 5-10 minutes in. ..is that a problem I should be concerned with??
    It does have an LED indicator, right? Usually theyīll flash a certain amount of times to give basic codes of whatīs going on, and if itīs operating correctly or not. Maybe that itīs just not set up correctly, somethingīs trying to get more juice then itīs rated for, itīs overheating, no idea really. Might be minor, might not be, from that I really couldnīt say.
    I know this is from a sub-set of mp3car, so if you canīt get enough info here and the manual Iīd try the direct route to their support mail and give īem your setup.
    2008 Ford Mustang GT/CS CARPC(99%)
    Software: Ride/Road-Runner, Digital FX skin 5.x, iGuidance 2011, GPSgate on Win7 64bit

  9. #9
    Low Bitrate
    Join Date
    Aug 2010
    Location
    Vancouver, BC
    Posts
    67
    Hey guys, so I did some more digging and was able to get my PC to hibernate properly (it no longer does a hard shutdown every other time).
    However, now it just doesn't want to wake from hibernate (I have to manually turn it on). According to the P2140 setup video's by Goce, I have to go into BIOS and enable the 'AC PWR Auto Recovery' (the other things outlined in his video are already done). Unfortunately my BIOS doesnt have that option, but it has a buncha other power options which I tried enabling and disabling, to no effect. I've also sent an email to the mp3 support address, hoping they may be able to help.
    I haven't switched the polarity yet, was gonna do that Monday evening, but am starting to think this is no longer the solution as the only problem now is waking from hibernation. Seems like its just a setting that I have to change in Windows or the BIOS. Anyways, let me know what you guys think. I am eager to get this working properly finally..

    Here are some picture of what my BIOS options look like:
    Attached Images Attached Images     
    - scENFORCER

  10. #10
    Variable Bitrate Wayne613's Avatar
    Join Date
    Apr 2009
    Location
    Delaware
    Posts
    308
    Quote Originally Posted by scENFORCER View Post
    However, now it just doesn't want to wake from hibernate (I have to manually turn it on). According to the P2140 setup video's by Goce, I have to go into BIOS and enable the 'AC PWR Auto Recovery' (the other things outlined in his video are already done). Unfortunately my BIOS doesnt have that option, but it
    Switch the motherboard on/off ACPI headerīs, assuming you hooked this up as stated earlier and assuming you even got a cable for it with the default carnetix psu.

    That setting mentioned is for automatically starting after a power loss, the Ļafter power lossĻ is what your after for this HPīs bios.
    2008 Ford Mustang GT/CS CARPC(99%)
    Software: Ride/Road-Runner, Digital FX skin 5.x, iGuidance 2011, GPSgate on Win7 64bit

Page 1 of 2 12 LastLast

Similar Threads

  1. P2140 Issues, Sleep mode problems
    By brianteel in forum CNX-P2140
    Replies: 1
    Last Post: 05-24-2010, 08:00 PM
  2. Carpc or Carputer Complete Guide
    By smhussain in forum Newbie
    Replies: 16
    Last Post: 04-21-2009, 05:58 AM
  3. An interesting solution to adding phone support to CarPC
    By AvWuff in forum Hardware Development
    Replies: 36
    Last Post: 02-08-2009, 12:35 AM
  4. Replies: 10
    Last Post: 05-28-2006, 07:23 PM
  5. Replies: 33
    Last Post: 09-01-2005, 04:14 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •