Page 3 of 11 FirstFirst 1234567891011 LastLast
Results 21 to 30 of 110

Thread: OPUS PROBLEMS: Please post here if your Opus may have damaged your motherboard.

  1. #21
    Newbie dieter's Avatar
    Join Date
    Jul 2003
    Location
    Norman
    Posts
    36
    I spoke with Kris today and he said he was aware of the problem and taking steps to fix it. He wants to have damaged boards, however, to better diagnose the problem. He asked me to tell you all that if you have a damaged board, mail it to him with your name and return address and invoice number, and a description of the problem.

    I'll be mailing mine off tomorrow...

  2. #22
    FLAC guitar333's Avatar
    Join Date
    Jun 2003
    Location
    IDAHO
    Posts
    1,112
    did he say anything about our motherboards, mine isnt under warranty so am I *****ed? If you dont know Ill give him a call
    92 Taurus SHO - Daily driver - Epia M10000 80GB 512mb 7" touchscreen, Opus PSU etc

    93 Black SHO - 30mpg cruiser

    90 Silver SHO - 419whp fun/project car, CarPC to come (for tuning)

  3. #23
    Newbie dieter's Avatar
    Join Date
    Jul 2003
    Location
    Norman
    Posts
    36
    Quote Originally Posted by guitar333
    did he say anything about our motherboards, mine isnt under warranty so am I *****ed? If you dont know Ill give him a call
    I didn't ask, he didn't offer.

  4. #24
    FLAC guitar333's Avatar
    Join Date
    Jun 2003
    Location
    IDAHO
    Posts
    1,112
    no I didnt want to bother him about that until he found out what the problem was. Do you think he should if its not under warranty?
    92 Taurus SHO - Daily driver - Epia M10000 80GB 512mb 7" touchscreen, Opus PSU etc

    93 Black SHO - 30mpg cruiser

    90 Silver SHO - 419whp fun/project car, CarPC to come (for tuning)

  5. #25
    Newbie dieter's Avatar
    Join Date
    Jul 2003
    Location
    Norman
    Posts
    36
    Quote Originally Posted by guitar333
    no I didnt want to bother him about that ubtil he found out what the problem was. To you think he should if its not under warranty?
    In an ideal world, he would. But in the American business world, the rule is generally caveat emptor.

  6. #26
    Newbie
    Join Date
    Jul 2003
    Location
    Milan, Italy
    Posts
    18

    Same problem here!

    Same problem here!

    90W Opus fuse has blown and my motherboard too. It's a Nemiah M10000.
    I wrote to Kris at opus. We will see what happens...

    Let me know

  7. #27
    Low Bitrate Richie's Avatar
    Join Date
    Sep 2003
    Location
    Sweden - Stockholm
    Posts
    79
    Damn guys!
    Now you're scaring me when I'm just about to buy the 90W to my Epia M10000... DAMN..! Now tell me what I should do... Shipping back an opus to the states wont be for free from Sweden and if I burn my MB I'm pretty *****ed without warrenty...
    Please give me advice if I should give it a try or maybe I should take the 150W???
    Anyone had any problems like these with the 150W unit?

  8. #28
    Maximum Bitrate none's Avatar
    Join Date
    Sep 2003
    Posts
    586
    Based on the information in this thread I would definately stay away from Opus products for the time being, at least until these issues are resolved. This is a HUGE number of people with problems for a small volume product, they probably represent a sizable percentage of total Opus units out there.


    Quote Originally Posted by Richie
    Damn guys!
    Now you're scaring me when I'm just about to buy the 90W to my Epia M10000... DAMN..! Now tell me what I should do... Shipping back an opus to the states wont be for free from Sweden and if I burn my MB I'm pretty *****ed without warrenty...
    Please give me advice if I should give it a try or maybe I should take the 150W???
    Anyone had any problems like these with the 150W unit?

  9. #29
    Low Bitrate Richie's Avatar
    Join Date
    Sep 2003
    Location
    Sweden - Stockholm
    Posts
    79
    Quote Originally Posted by none
    Based on the information in this thread I would definately stay away from Opus products for the time being, at least until these issues are resolved. This is a HUGE number of people with problems for a small volume product, they probably represent a sizable percentage of total Opus units out there.
    Yeah... But still I don't see anyone with problems on the 150W'r?
    And the big problem is that I need the Opus since it SO FAR is the only succesful power-supplier... :/

  10. #30
    Low Bitrate shadowlessman's Avatar
    Join Date
    Jun 2003
    Location
    MI
    Posts
    82
    be sure to post which model of Opus PSU you have.

    guitar333, you should also edit your first post to include Opus model number and purchase date/amount of time in use if you can get that info from everyone.

    Maybe this thread should be made sticky...
    "Buckethead's this guy that was raised in a chicken coop and without the bucket on his head, he's helpless"

    - "Really? Oh my god..."

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •