Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Quick question about Opus 150w PSU.

  1. #1
    Newbie
    Join Date
    Jan 2004
    Location
    Stockton, CA
    Posts
    38

    Quick question about Opus 150w PSU.

    Does the power supply come with the +12V Power Connector for P4 Motherboards? Thanks.

  2. #2
    I'm sorry, and you are....? frodobaggins's Avatar
    Join Date
    Jan 2003
    Location
    Ruston, LA
    Posts
    8,846
    no, you will need to buy a molex adapter

    http://www.opussolutions.com/150watt.html
    (look under Output Power Connectors)
    [H]4 Life
    My next generation Front End is right on schedule.
    It will be done sometime in the next generation.
    I'm a lesbian too.
    I am for hire!

  3. #3
    Constant Bitrate
    Join Date
    Apr 2003
    Posts
    189
    Quote Originally Posted by frodobaggins
    no, you will need to buy a molex adapter

    http://www.opussolutions.com/150watt.html
    (look under Output Power Connectors)
    Actually, it does. I bought an Opus 150W from Kris 2 weeks ago and it came with the 4 pin ATX12V connector needed by most P4 motherboards. I think Opus added the connector recently and haven't updated the info on their website.

  4. #4
    Newbie
    Join Date
    Sep 2004
    Location
    Denmark
    Posts
    12
    Do anyone know this for sure. I'm about to order from LinITX.com and my motherboard can't run without the +12 power connector, so it would be relly nice 2 know ....

  5. #5
    Low Bitrate
    Join Date
    Jul 2004
    Location
    Indialantic, Fl
    Posts
    85
    Just got mine a month ago and it has one

  6. #6
    Variable Bitrate
    Join Date
    Jan 2004
    Location
    Jersey/NY
    Posts
    436
    I think originally they didn't, but now they do. So it may depend on how old the stock from LinITX.com is.

  7. #7
    Constant Bitrate
    Join Date
    Sep 2003
    Location
    Northeast Ohio
    Posts
    114
    I ordered & recieved one about a year ago; model SFX-12-15 and it came with the P4 power connector.

    HTH
    System:
    Epia M1000 w/512MB PC2100, Xenarc 700TS, ATI 7500 PCI, OPUS 150 PSU, 2.5 40GB 5400 HDD, 802.11g PCI, Slim Slot DVDR,
    Gyration RF Kybrd, OBDII adpt. + sftwr, XP pro, iGuidance/Royaltek GPS NAV, XMPCR, Kenwd KAC-8401 4 chnl amp, 10" pwd sub

  8. #8
    Super Moderator xBrady's Avatar
    Join Date
    Apr 2004
    Location
    USA
    Posts
    3,687
    Got mine 3 months ago and it had one.
    AMD XP 2600+/512MB RAM/120GB hard drive
    Opus 150W/DVD/GPS/7" Lilliput TS/802.11g/Bluetooth
    Installed.


    -GPSSecure- - GPS Tracking
    -AltTabber2.2.2- - Handy touchscreen utility.

  9. #9
    Jesus Freak antimatter's Avatar
    Join Date
    Jan 2004
    Location
    California
    Posts
    4,545
    And have they fixed the problem with the Standby power being left on?
    -Jesus- King of Kings Lord of Lords

  10. #10
    Variable Bitrate lawrence's Avatar
    Join Date
    Oct 2003
    Location
    carol stream illinois
    Posts
    329
    got mine 2 months ago it's one for an shuttle and it has it

Page 1 of 2 12 LastLast

Similar Threads

  1. Frequently Asked Questions
    By bgoodman in forum The FAQ Emporium
    Replies: 33
    Last Post: 05-03-2005, 07:25 PM
  2. OPUS 150W Question
    By belezeebub in forum Power Supplies
    Replies: 1
    Last Post: 12-23-2003, 03:56 PM
  3. What to look for in a PSU some info for you
    By cproaudio in forum Power Supplies
    Replies: 9
    Last Post: 04-04-2003, 02:07 AM
  4. Quick PSU and Hardware Question
    By Ritalin Kid in forum General Hardware Discussion
    Replies: 4
    Last Post: 01-31-2003, 04:23 PM
  5. Jumpers on the OPUS 150W DC/DC psu
    By t0ffluss in forum Power Supplies
    Replies: 2
    Last Post: 01-21-2003, 10:14 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •