Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: OPUS 90W - please help me identify this cable

  1. #11
    Variable Bitrate Supermike's Avatar
    Join Date
    May 2004
    Location
    AZ
    Posts
    294
    Maybe the tiny pic midway down on this link will help:

    http://www.opussolutions.com/modules...article&sid=20

    Does not show much but may help with orientation.

    As I recall, the Opus 150W supply I have was Red = Batt + (and fused close to the battery, I think I used a 10 or 15 Amp fuse), Black = Ground (Opus recommended that it be grounded at the battery) and yellow was going to the Acc. line from the radio which I think is normally yellow as well. Opus recommended 12 Gauge wire be used for the 150 Watt supply, but some people perfer a lower gauge which won't hurt. Some people have suggested an AMP wireing kit would be a good to use.

    As for the plugs, it looks like the person who had it before you just put a Molex connector on one end for some reason. The funny 3 prong end with the tabs is the one your OPUS needs.

    Again, be sure to put a fuse on the positive as close to the battery as possible.

  2. #12
    Constant Bitrate jaeger's Avatar
    Join Date
    Jul 2004
    Location
    Galveston Is., TX
    Posts
    113


    here i have both cables and their connections on the opus. the smaller one shown [top] is the one i had wired in at the beginning of this thread. When plugged in, the LED would blink once, space, once...etc etc. which meant it was working properly. but it would not power up my motherboard. This one is the mystery cable.

    the second cable, the bottom one in the photo [which i wired up after i was so kindly rebuked in this thread], also caused the LED to blink once, space, once...etc etc...but this one powered up the motherboard.



    closeup of where the mystery cable plugs in. i have read the manual over and over and i am sure i am missing something.
    nine.

  3. #13
    Constant Bitrate
    Join Date
    Mar 2004
    Posts
    192
    OK the mystery cable is for remote trigger. The yellow and black do nothing but the red one is the remote trigger for turning on amps ETC. It sends 12v down it after either 10seconds or 40seconds, depending on your revision on Opus

  4. #14
    Constant Bitrate jaeger's Avatar
    Join Date
    Jul 2004
    Location
    Galveston Is., TX
    Posts
    113
    wow thanks
    nine.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Installing On/Off Switch with Opus 90W
    By Judgement in forum Power Supplies
    Replies: 6
    Last Post: 07-02-2004, 02:43 AM
  2. can i run all this on a 90w opus?
    By DSM97RS in forum Power Supplies
    Replies: 7
    Last Post: 05-17-2004, 04:27 PM
  3. Opus 90w Power Action
    By EBoundEE in forum Power Supplies
    Replies: 12
    Last Post: 03-10-2004, 10:11 PM
  4. Opus DC-DC 90W 150W Pricing Dimensions Info
    By Linus in forum Power Supplies
    Replies: 9
    Last Post: 10-15-2003, 04:29 PM
  5. Opus 90W: PCB module or Open frame?
    By dormouse in forum Power Supplies
    Replies: 8
    Last Post: 10-01-2003, 02:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •